2 Replies Latest reply: Jun 9, 2013 3:16 PM by CU Dezigner RSS

    CS6 Error 16

    weedinner Community Member

      Hi

       

      Everything working great until this morning. Opened CS6 and Lightroom almost at the same time and PS crashed. Tried again and got the dreaded Error 16 message.

      Have repaired and checked the permissions fro Adobe PCD and SLStore folders. Have re downloaded a trial version and installed it twice with no avail. Rebooted the machine. Checked the last install log and everything looked fine. No errors at all.

      Had a CS5.1 installed on the same machine and it came in with the same error when opening. Have since uninstalled that version.

      Deleted the preference files.

      Incidently the the Error 16 message kicks in before it has had time to rewrite the new plist files. I am assuming that that the problem may lie in a corrupt system file or folder due to try in to open both apps at the nearly the same time or am I clutching at straws.

      I am a very busy working photographer so I need to get this fixed fast.

      Thanks guys

       

      OSX 10.8.2

      MacBook Pro

        • 1. Re: CS6 Error 16
          weedinner Community Member

          Solved it!!

           

          Adobe says

           

          Additional information

           

          This error message appears when the SLCore licensing service has encountered a problem. This failure generally means that permissions to the SLStore folder were set incorrectly.

           

          I have another copy of CS6 running on another MAc. I copied the SLStore folder and replaced the on the MacBook Pro and it booted. The files would appear to have been corrupted. Check for a creation date of 1 Jan 1970.

          Hope this helps others

          • 2. Re: CS6 Error 16
            CU Dezigner Community Member

            Thanks for posting weedinner. I had the same problem and your solution is the only one that pointed me in the right direciton. My situation is a little different and so was my fix so I'll share it for anyone else searching.

             

            All my Adobe CS5.5 apps were hanging up just after launching. "Not Responding". I didn't know it was Error: 16 until I created a new user account on my Mac and then would get the Error:16 for every Adobe CS5.5 app. All my SLStore and Adobe PCD permissions were set correctly.

             

            Your post made me think that there might be something wrong with the .lic files. I checked a previous backup and noticed I only had one .lic file. My new install had three. Two were dated the day I installed and one was dated a few days later. I save a copy just in case and deleted the third one. My apps started up without a problem after that. A new .lic file was created and dated for today.

             

            I'm pretty sure I know what caused the problem. I installed CS6 first and then CS5.5 a few days later (didn't realize I needed dual core). All the 5.5 apps worked fine until I opened InDesign CS6 which will run on my Core Duo mac. Using two versions of CS must have confused the licensing. We'll see if I can still use InDesign CS6 without this happening again. At least now I know how to fix it.

             

            Hopefully this helps others too.