10 Replies Latest reply on Feb 6, 2013 9:26 AM by Peter Spier

    Table of contents always appears in new text frame, outside flow of document

    Zeta Tucanae

      I'm making books for print and epub use (using CS6, Windows, latest update), and to avoid duplicating work I make the file for pdf and then create a new version to be the epub (mostly to add the TOC). I don't use separate files and the book function if I can help it, because it's a pain in the *** when you have 50+ separate chapters, and until recently this gave me no problems.

       

      The first couple of times I did this it worked perfectly, but now I keep getting an infuriating problem: when I generate the table of contents, Indesign always generates a new text frame and places it on top of the existing frame (see picture). Nothing I've done can make it slot into the frame of the story, and no matter where I try to insert it, it comes up in the epub at the end (usually without formatting or break from previous text). I've tried different TOC styles, playing with the TOC options, and copying the whole text into a new document, to no avail.

       

      It might be relevant that when I create new blank pages (e.g. add a spread between pages 1 and 2 to try fitting the TOC there), whether using a master or not, they don't fit into the frame of the story either - the threads completely ignore them and their contents still appear at the end. And it doesn't make any different whether smart text reflow is on or not. Again, this wasn't a problem I had in the first couple books, but I haven't found an option which turns this off.

       

      Can anyone tell me why this might be happening (e.g. an option or a function of Indesign I haven't understood, though if so I don't understand why it worked the first couple times) and how to stop it? I'd just like to be able to make a TOC and add pages within the story, without all this overwriting!

       

      Thank you.

       

      Indesign error.png