3 Replies Latest reply on Feb 8, 2013 9:30 AM by cf_null_user

    Problem with CF10 automatic updates

    cf_null_user Level 1

      We are installing CF10 Enterprise on Windows 2008 RC2 with IIS 7.  

      We installed using all default selections, straight-forward installation, and applied the mandatory update.  So far, so good.

      When we go to the updates page for automatic updates for the latest current hotfix 7 (at the time of this post), which is cumulative, the install and download process runs fine, the instance restarts, but then when we check again to see the available updates, it shows all the updates from 1 to 7 again, as if we didn't apply the updates at all.  Installed updates tab shows no updates having been applied. 

      However, looking at the system info page, the udpate level shows HF7.

       

      We tried a variation, applying one hotfix at a time.  This worked through hot fix 2, but after applying HF 4, it 'froze' there with the same problem as described above, not showing any fixes having been applied after HF 2.

      This is incredibly frustrating.  I have no idea if HF's have been applied, and am not sure what to think about the sys info page indicating hotfix level. We are still living in CF update hell.   Any ideas appreciated!

       

      Thanks,

       

      Jeff

        • 1. Re: Problem with CF10 automatic updates
          Carl Von Stetten Adobe Community Professional & MVP

          Jeff,

           

          I just replied to your post on the HOF site.  Here's what I suggested:

          This is a common issue reported on the Adobe ColdFusion forums.  The only solution I have found to work reliably for me (and I'm on the same OS and web server) is to make sure that the service account ColdFusion is running under is a member of the local Administrators group.  You may also want to restart the ColdFusion service after putting the account in the Administrators group.

          Once the updates are installed, remove the ColdFusion service from the Administrators group and restart the ColdFusion service.

           

          There are several similar posts on this forum as well; you might want to check out what others have suggested.

           

          -Carl V.

           

          Message was edited by: Carl Von Stetten

          • 2. Re: Problem with CF10 automatic updates
            cf_null_user Level 1

            Thank you Carl. I tried having the service login with an account that is a member of the local administrators group, but that had no effect.  I had initially searched for other posts, but was not successful.  I will do some more hunting.  Thanks.

            • 3. Re: Problem with CF10 automatic updates
              cf_null_user Level 1

              Thanks for your help.  We have solved the issue, I will post the solution here if it helps anyone in the future. The error message logged in the hotfix log file  (Eg: C:\ColdFusion10\cfusion\hf-updates\hf-10-00007) is the following:

               

               

              Failed to copy hotfix files:C:\Users\xxx\002873.tmp\dist\cfusion

              Status: FATAL ERROR

              Additional Notes: FATAL ERROR - Failed to copy the hotfix files to the target location:C:\ColdFusion10\cfusion

              FATAL ERROR - C:\ColdFusion10\cfusion\bin\coldfusion.exe (The process cannot access the file because it is being used by another process)

               

               

              Several blog posts refer to permission problems, such as making sure the account under which CF10 runs has local admin access, or that the cfusion directory have appropriate permissions.  We had tried these solutions, and several variations without luck. We had also stopped all CF services and applied the HF manually but the same error persisted.

               

               

              In our case, we renamed coldfusion.exe notated in the error log above, applied the hotfix, and everything worked. So, I don't believe it was really a permissions issue but rather (as the error log was trying to tell us), that the coldfusion.exe was in use.

              1 person found this helpful