7 Replies Latest reply: Mar 27, 2013 6:44 PM by groove25 RSS

    Type disappears after scaling

    sboerner2 Community Member

      I am an occasional user of Fireworks so there's a good chance I'm just overlooking a checkbox somewhere.


      I'm working on a series of icons and am resizing them from large to small. The icon contains two text frames with single characters in each frame. When I resize the image the graphic objects scale OK but the type disappears. On inspection (selecting the type layers in the layers panel) the text frames show up but are shortened to the point where the text is overset. The frames have handles but they are not selectable nor can the frames be resized or edited. There's a large red box with a crosshair in the lower right corner of the frame, but that also is not selectable and clicking it has no effect.


      Is this a bug or am I missing something?




        • 1. Re: Type disappears after scaling
          groove25 Community Member

          This sounds like odd behavior for text. What method exactly are you using to scale your icons?


          Your post is well-written, but it's still hard to picture. Could you include a screenshot of the document and interface, including the Layers panel—with at least one of the text layers visible (and selected on the canvas)?

          • 2. Re: Type disappears after scaling
            sboerner2 Community Member

            Thanks for your response. Here are before and after images.


            In the first image the icon is 1024 x 1024 with two text frames, one character in each.




            Here is the result after using Image Size in the Properties panel to scale it to 144 x 144. The two text frames can be moved with the selection tool but can't be resized or edited with the text tool or the direct selection tool:




            This happened with two separate files the other day. I saved one, and still have the same problem with that particular file. (It happened just now, when I made these screenshots.)


            But here's the interesting part. I can't reproduce the problem with any new files. I've made a couple new ones from scratch and they work fine. It also works if I replace the two text frames in the original file.


            The original text frames must have been corrupted somehow. I've rebooted the machine since creating those files, too, so maybe that cleared things up.


            Unless, as I first suspected, there is a scaling preference somewhere that I'm not aware of.



            • 3. Re: Type disappears after scaling
              groove25 Community Member

              Thanks, those screenshots are helpful. I was kind of expecting to see the Properties panel for one of the text objects, too—there may or may not be clues there.


              Like you said, though, it may just be a glitch.


              I was initially puzzled by the red overset text symbol, because it so rarely occurs in Fireworks. Text boxes are fluid in length and resize freely to accomodate the content. But I guess overset text is more common when working at large font sizes and/or with individual letters, as a letter shape wider than the text frame can't "reflow". In those cases, you should be able to click on the overset text symbol (or at the top of the frame) and drag the frame wider to reveal the missing text.


              I did notice that manually adjusting the text box for a single large letter shape—prior to resizing and the overset text issue—can have an impact on the size of the text box and the positioning of the letter within that box; I don't know if that might be relevant in any way.


              The only idea I can suggest is to convert the text to outlines before resizing, using Text > Convert to Paths. Particularly at large text sizes, this command should produce the same rendering and might make the shapes easier to work with. And in this case, it doesn't seem that you're working with the letters as text, per se, more as shapes or logo iconography.

              • 4. Re: Type disappears after scaling
                sboerner2 Community Member

                OK, it's happening again ... and again, and again. This is not a temporary glitch. It's reproducable, and definitely a bug.


                It happens when scaling text, for example, when creating a series of icons in descending sizes. Each time the icon is reduced, the the type is reduced, too -- but the type size does not change in the properties panel. It appears that once the reduction passes a certain threshold, selecting the type causes the frame snap to a smaller size ... and the text disappears. The frame is now uneditable and that's the end of the story.


                I've searched for a scaling switch -- like InDesign's -- to force the application to change the point size of the type when it's rescaled. Can't find one. Am I missing something here?


                Converting to paths works but disables the anti-aliasing settings ... one of the reasons I'd like to use Fireworks for this.


                Back to PS for now I guess.

                • 5. Re: Type disappears after scaling
                  groove25 Community Member

                  I'm still convinced that Text > Convert to Paths offers the simplest solution here—at least for the example you provided.


                  As you mentioned, I see that text size does not change when using Modify > Canvas > Image Size, which is a bit surprising. Have you tried any other transformation methods? Many other scaling/transforming methods do result in a change in font size (which may or may not circumvent this problem).


                  If text anti-aliasing is paramount—and other transformation methods fail—I'm wondering if you could resize the text manually in the Properties panel instead. Use a little bit of percentage math to determine the correct font size.


                  A few other left-field ideas:

                  • Have you tried enlarging the text frame a bit, by dragging its top right handle, prior to resizing? (This may throw off the alignment of the text in the design, so you'd have to reposition afterwards.)
                  • What about defining the text object as a symbol? Symbols offer resizing advantages for bitmaps; perhaps they could help with this issue somehow. If it works, this might be a very simple fix to add to your workflow.


                  You can always report this bug to Adobe; however, there's been very little evidence lately that Adobe is actively supporting Fireworks anymore, so… whether your report would have an effect is unclear.




                  Hey, here's one more idea for you: Have a look at the Text commands included under Commands > Text. Something like "Set Width" or "Toggle Fixed Width" might be able to snap the text frame out of its frozen, uneditable state after resizing. Give these a try and see what happens.

                  • 6. Re: Type disappears after scaling
                    sboerner2 Community Member

                    Thank you for the feedback and ideas. Those are all excellent suggestions, and I'll give them a try and report back.


                    In the meantime Photoshop's Export to Web command seems a more efficient workflow for this, since you can rescale files on the fly as you export them. Setting up layers with various weights of type and anti-alias settings makes it simple to accommodate the dozen or so icon sizes I need for DPS.


                    I still think Fireworks is superior in some ways. It seems to produce lighter-weight PNG files and I've always appreciated the way it blends vector and bitmap imagery. The fast launch time and smaller toolset are perfect for small, web- or device-based tasks. I used to use it quite a bit but rarely now, mainly because I seem to run into some kind of glitch every time I pick it up to do actual work.


                    Sorry to hear that Adobe's not actively supporting it anymore.

                    • 7. Re: Type disappears after scaling
                      groove25 Community Member

                      Sorry I didn't think to bring this up earlier, but if you're using Photoshop's Save for Web, I think you can achieve the same results using File > Image Preview in Fireworks. Certainly, you can do on-the-fly resizing there.


                      If that doesn't do the trick, I'm pretty optimistic about my last suggestion involving the Text Commands (and if not that, then perhaps the symbol workaround). And then there are the other transformation methods…