0 Replies Latest reply on Feb 11, 2013 11:40 AM by Saman

    Anyone have trouble connecting to web services with CF10?

    Saman Level 1

      I'm trying to connect to InDesign server running in the same box @ http://localhost:18383/service?wsdl and this gives me the error "Web service operation RunScript with parameters ... cannot be found". I tried toggling web service version in CF admin to 1 and 2. I tried with CF updates, without updates. Tried in a different box, it is the same.

      When I dump my web service object, before invoking the function, it display WSDL structure correctly with all functions in it, including "RunScript". So I guess, create object part worked correctly.


      Uninstalled CF10, Installed CF9 in the same box, it works fine. 

      Has anyone experienced something similar? Is there any limitation in TomCat executing web services in a high port (18383)?




      I send the SOAP request to InDesign server manually using CFHTTP and it works in CF10. Seems like CF10 somehow did not respect the WSDL instructions.