7 Replies Latest reply on Feb 27, 2013 2:24 PM by ECBowen

    raid0 error occurred(1)  on post

    Trevor.Dennis Adobe Community Professional (Moderator)

      I couldn't think where else to ask this, and you guys were so helpful when I built this system.  I've just started getting the Error Occurred(1) message on post.  The drive concerned is half of the Exports raid0.  I have Googled, and scanned the mainboard manual, but can't find any information.  The array appears to function normally, and is fully backed up - some of it twice.  The board is a Gigabyte X79-UD5

       

      The system is just over a year old, and in that time the Projects raid0 has failed catastrophically.  That was with a pair of 1st generation 300Gb Velociraptors, which are supposed to be among the most reliable of HDDs.  That was also backed up of course.   I didn’t feel able to trust either unit after that, and replaced them with the pair of 2nd generation 600Gb Velociraptors.  This starting to feel more than a coincidence. 

       

      I’ve also lost one of my external USB3 1Tb WD My Books, in the last year, but I can’t think how that could be linked.

       

      If memory serves, I think I am using an Intel Enterprise drive that Erik pointed me at.

       

      So what does the Error Occurred(1) mean?  Do I need to replace the drives?  Is it possible that I have the setup wrong leading to the failures?   ISTR that there issues with the x79 2011 boards back then.  Any help would be much appreciated.

       

      Windows 7

      X79-UD5

      GTX570

      32Gb RAM

      Adata 750W Gold PSU

      CM Storm Trooper full tower

       

      Appart from the drives shown below

      260Gb SSd for OS

      2Tb WD Black

      150Gb Velociraptor Scratch space.

       

      Error Occurred(1).jpg

        • 1. Re: raid0 error occurred(1)  on post
          Harm Millaard Level 7

          Trevor,

           

          I have never encountered such an error, so I do not know what it means, but logic says that you have to:

           

          • Check the SATA cable and power cable to make sure they make the correct contact,
          • If the disk is physically running, use a WD disk checking utility
          • Use Chkdsk to repeat the disk checking, including the check at boot time.

           

          If all else fails, try reformatting the 1 TB Caviar disk and then recreate the raid. If that still fails, try exchanging the disk (under warranty, if you are lucky).

          1 person found this helpful
          • 2. Re: raid0 error occurred(1)  on post
            Trevor.Dennis Adobe Community Professional (Moderator)

            Thanks Harm.  I haven't been inside the case to check cables, but WD Life Guard is currently running.  The quick test showed a pass. The full test has another two hours to run.

             

            What is scary though, I had a look through the Windows Event Logs, and found a number of errors connected with Shadow Protect showing object not found.   Anyway, I shall be popping out to get another 2Tb drive to back up the Export array _again_, and I shall start afresh with Shadow Protect when I get things sorted.  It's a good job drives are cheap now.

             

            Thanks again for pointing me in the right directions.

             

            [EDIT]  Just occurred to me after looking again at the post details, that the (1) is probably the number of the array, and not an error code.  Google found a bunch of Error Occurred(0) hits, but none with a (1).  I'm guessing those people only had the one raid array, which would have carried the (0) designation.

             

            Just checked and 3TB USB3 externals are cheap as chips!  Heck, I'll get a couple and swap out my 1Tb externals and use them for archive storage.  I feel happier having a plan and every reason to believe my data will be OK.

            • 3. Re: raid0 error occurred(1)  on post
              JEShort01 Level 4

              Trevor,

               

              Years ago, probably about 5 years ago if memory serves me right, I did have a very similar problem. Intel ISRT (Intel Rapid Storage Technology) was reporting an error on a RAID 0 drive. I did have good backups, and so far as I could tell, I had not lost any data. Using Intel's software application you can "clear" the error, and whenever I did it the error would show up again and on the same drive. In my case, the drive was going bad and throwing SMART errors, but had not experienced any data loss. Unfortunately, the full SMART data reporting was impossible to get at with the drive configured as a RAID 0 array at the Intel controller / firmware level. The solution was to "break" the RAID, exercise the suspect drive for reads and writes, and view the SMART data as a single drive. In my case, the failing drive was showing over a Million recoverable retry errors and was replaced on warranty.

               

              In my country (USA) the WD Black 1TB WD1001FALS that you have with the error has a 5 year wtty, so hopefully yours is still covered.

               

              This particular personal experience is by the way the event that led me to move to using hardware controllers instead of IRST for most of what I build now. With quality hardware controllers, in addition to high-performance parity RAID levels (ie RAID 5 is warp speed on hardware controllers vs ISRT) and generally more robust operation, I can get at SMART drive statistics for every drive easily using a web-enabled application. I dabbled with bottom-feeder boards (Highpoint, etc.) - horrible, then I used 3WARE cards for a couple of years, and have settled on ARECA cards now, which I am very pleased with.

               

              I've been rambling along I know, but you are touching some old and miserable memories for sure!

               

              Back to your situation, here is what I would suggest:

              1) Make sure your backup for the RAID 0 array with the ailing drive is sound

              2) Break the RAID set

              3) Run HD Tune Pro Read and Write tests (benchmark FULL test, set block size to 2MB) on both drives (from the bad array) and compare the results; note you must remove any drive partitioning before HD Tune will let you run the full WRITE test; this test is awesome by the way to flush out drives that are certainly flawed, but may still be healthy enough to pass the various vendor drive test programs. You minimum read and write speeds for a WD 1TB black should probably somewhere in the neighborhood of 50 to 60 MB/sec. When I've run bad drives through this test they either: look fine for reads but can write OK, look fine for writes, but writes have issues, or sometimes their errors are so significant that the benchmark test will abort before either the read or write test has completed.

              4) Use a utility that can get at the SMART data reporting for both drives and compare those results too

              5) RMA the bad drive (most likely scenario) if SMART reporting and / or HD Tune results suggest your drive is bad, or start troubleshooting SATA channels, cabling, etc. if the drive itself does not appear to be the culprit

               

              Hope this helps, and good luck!

               

              Cheers,

               

              Jim

              1 person found this helpful
              • 4. Re: raid0 error occurred(1)  on post
                JEShort01 Level 4

                Trevor,

                 

                Seems we just cross-posted!

                 

                Regarding WD Life Guard, I'd say don't waste your time! See my other post for a much faster and telling way to diagnose the health of a drive that you will be using for video / photo editing.

                 

                I see you are a ShadowProtect user! I am too, and love it, but there are not too many of us around .

                 

                FYI, if you were not aware, ShadowProtect lets you mount your image backups so Windows sees all of what is in your backup just as if it were another drive. And, you can use Beyond Compare to quickly identify any specific individual file differences between an active drive or array and your archive, or between two separate image backups.

                 

                Regards,

                 

                Jim

                • 5. Re: raid0 error occurred(1)  on post
                  Trevor.Dennis Adobe Community Professional (Moderator)

                  Jim I don't I'd have thought about splitting the drives, but that is a great idea.  WD Life Guard found no problems, and nor did chkdsk run from Windows.  The first thing I need to do is add another level of backup, so I got another 4Tb of USB3 storage this morning in a pair of WD My Books.  They did have 3Tb drives, but they were almost twice the cost per Gb as the 2Tb drives for some reason.   It's going to take a wee while to copy the data across, but I'll split the raid when that's done.

                   

                  I have a good relationship with the dealer I got the drives from, so I'm sure I'll have no problems if one of them does show problems.  There's a lot to be said for dealing with a proper computer store with people who know their business.

                   

                  My approach to getting serious about NLE is, rather shamefully, looking like a stills photographer's journey to getting a decent tripod.  I actually tried to do the job without any raid arrays to start with, and then went with the mainboard controllers because of cost.  Looking at the Areca controllers, it still represents a serious investment to take that route, but I am accepting that it is inevitable.

                   

                  Shadow Protect is great software.  It was easy as to repopulate a new raid0 array after the Projects drive failed, but I have not worked out how to do the virtual boot drive thing with it, and nor have I worked out how to mount the backed up data so I can read it with Windows.  My fear is that the Event log errors associated with Shadow protect, indicate corrupt data.  The target drive appears to be OK, but the Exports raid0 array that shows the error, could indicate that Shadow Protect is seeing corrupt sectors in the source data on that drive.   I’m guessing that running chckdsk on startup will discover problems of that nature.  I have another level of backup for some of that data, so might be OK.

                   

                  Anyway.  So now I have to read all Harm’s raid threads again, and work out the best route to go with a hardware PCIE controller.   I’d had my eyes on a Varavon Tilt Jib crane as my next purchase, (they are as clever as a box of rocket scientists),  but that project might have to go on hold.

                   

                  Thanks for the great ideas.

                  • 6. Re: raid0 error occurred(1)  on post
                    Steven Snyder Tips

                    Hello Trevor and Jim,

                     

                    Thanks for the shout out on StorageCraft's ShadowProtect backup/recovery solution.

                     

                    Trevor, feel free to PM me if you want to talk about VirtualBoot or mounting a shareable volume from your backup chain.  I'm the Technical Marketing Manager here at StorageCraft.  Basically that means that I have one foot in the technical world and one foot as a social catalyst in the marketing world.  It's a pretty awesome job!

                     

                    Here's a "best practices" document on VirtualBoot if you want to read it for yourself.  You may also want to look into ImageReady as a way of automatically mounting your recovery points and then running CHKDSK against them to verify that there is not corruption.  You can set ImageReady to email you if there are problems, and ImageReady is free with the latest version of ShadowProtect.  One more reason to love the product.

                     

                    Glad to meet you both. 

                     

                    Cheers!

                    • 7. Re: raid0 error occurred(1)  on post
                      ECBowen Most Valuable Participant

                      Currently Drive Manufacturer's have a set % of bad blocks that they will ship on drives. That is normally up to 1%. If a drive hit a bad block it will look to repair that data or move it to a new location. During that time it will not respond to instructions from the controller. The onboard controllers will often confuse this lack of response as the drive has failed and it will mark the drive as bad. You can often just go into the Intel Rapid Storage manager and change the status of the drive back to good. If you do then just run a verification check on the raid volume to see if it drops again.

                       

                      If you want to try to ensure this is resolved for each drive then split the raids. Load DiskPart in the command windows. Then select each Disk and run a Clean ALL. That will write zeros to the drive.

                       

                      It seems Drive Manufacturers are not scanning the platters for Bad sectors and marking them out before they ship the drives anymore so this is a good practice before raiding them.

                       

                      The other problem that may occur that cause this is the drive does not respond with the Smart Info as the Controller is initializing in the time the controller expects it to or the data returned from Smart is erroneous. in this case it may be just a drive that was slow to spin up or indicative of a immanent circuit board failure or power issues. Mark the drive as Good in the Intel Manager again and see if it occurs more often. If so then replace the drive.

                       

                      Eric

                      ADK