3 Replies Latest reply on Nov 14, 2007 12:04 PM by Dirck

    scrollPane bug

    Level 7
      Hi,

      I'm using a scrollPane component to scroll a movieClip with text in it.
      When you scroll with the thumb, it works correctly. But when you scroll
      with the up and down buttons or by clicking in the track (scroll by page)
      it's just off. You can't get to the exact end, or back to the exact
      beginning. I can't believe this bug has been here for so long yet hasn't
      been fixed.

      Check it out here: http://www.galaxybeing.com/flash/scrollPane.html

      I've tried changing vLineScrollSize and vPageScrollSize but it doesn't fix
      it. I you just scroll using the up/down buttons and the track, you'll never
      it to scroll back to the top!


        • 1. Re: scrollPane bug
          ORAN6E98
          Moxie,

          Everything works for me. Don't quite know why you might be having a problem on your end. The scroll pane works as expected on my browser.

          :)
          • 2. Re: scrollPane bug
            Level 7
            Perhaps you didn't understand the issue. I'll put it in step by step
            format:

            1. Load this example page with the scrollpane, or make your own:
            http://www.galaxybeing.com/flash/scrollPane.html

            2. Do not click on the thumb slider during this test.

            3. Click once on the track below the thumb slider. The thumb slider moves
            down, but the text DOES NOT scroll up.

            4. Click once on the track above the thumb slider. The thumb slider moves
            back to the top, and the text scrolls UP so the words "being rolled out" are
            now at the top.

            RESULT: The text should have scrolled up when you clicked on the track below
            the thumb slider, but it doesn't. When you click on the track above the
            thumb, the text scrolls up, which is what it should have done when you
            clicked the first time.

            I've verified this on two different machines, and I've gone back and checked
            a project I did a year ago that used scrollPane, and it has the same
            problem.




            "ORAN6E98" <webforumsuser@macromedia.com> wrote in message
            news:fhb9c8$ael$1@forums.macromedia.com...
            > Moxie,
            >
            > Everything works for me. Don't quite know why you might be having a
            > problem on your end. The scroll pane works as expected on my browser.
            >
            > :)


            • 3. Re: scrollPane bug
              Dirck Level 1
              Works as I would expect.