14 Replies Latest reply on Feb 23, 2013 1:45 PM by Peter Spier

    Problems with laying out text in InDesign CS6

    Petar_MK

      While working on a book I encuontered some problems with InDesign CS6. Maybe these probles could be found in earlier versions, also.

       

       

      1. Nested paragraph styles (parent/child) does not work properly (let's say - the font is always taken from the parent style, and so on). I have to change the font using Find Font very often.
      2. Every last line on any page (within document witn continious text) can not be manually hyphenated (I think that InDesign treats every page as separate one).
      3. The user must decide if the master page elements should be locked or editable on the pages, not InDesign. Please, remove that restriction from the master pages (like QuarkXPress).
      4. A new page should be automatically opened when there is no more room for the text on the previous page. No, please, I don't want to use Story Editor or InCopy. I want to layout text directly in InDesign.
      5. I start a new document (only one page, with facing pages option activated). I <shift> click on the upper left corner and InDesign opens as much pages as needed. But, sometimes there is a problem that a lot of (left) pages are left blank. No, there is not page break setting in Word document or something else. The problem is in InDesign.
      6. There is no Macedonian hyphenation dictionary. So, can you tell me if there is an option, like in PagaMaker, to create an user dictionary and to put word by word hyphenated with tildas (or something else) for future use?
      7. Sometimes I have to change some glyphs with new ones. But, when I <alt> click on a paragraph style to reformat it, new glyphs are replaced with the old ones. Can this be fixed somehow? QuarkXPress in its new version offered us some interesting trick on this subject.
        • 1. Re: Problems with laying out text in InDesign CS6
          Peter Spier Most Valuable Participant (Moderator)

          1. may be caused by having applied a character style (which would not show as an overrride) or local formatting to the text...

           

          2. is a setting in your hyphenation options

           

          3. ID is not Quark, and you need to stop thinking like a Quark user to get the most out of it. Master frames are mostly usesless, but if you insist on using them they can be overridden by holding down the Cmd(Mac) or Ctrl(Windows) and Shift keys and clicking on them. Master frames do not need to be overridden, and should not be, for placing external content, especially text, as that removes them from the master threading.

           

          4. Enable Smart Text Reflow

           

          5. Sounds like you have a text frame on the right master page that is not threaded to the left.

           

          6. You can create a USer Dictionary, though it may not do what you want. You can also look into whether there is a Hunspell dictionary for Macedonian.

           

          7. Alt Click on a paragraph style is the command to remove local overrides. If you want to simply change the style to a different one, slect the style without using the Alt key.

          • 2. Re: Problems with laying out text in InDesign CS6
            Petar_MK Level 1

            1. No style was applied.

            2. it is not about the last word, but about the whole line.

            3. I don't think nor Quark user, neither InDesign user, simply -- user.

            4. how to enable smart text reflow?

            5. you haven't read it carrefully. I starts new document with only one

            page. The other pages are added by InDesign.

            6.

            7. I don't want to change the patagraph style. simply to reapply it without

            changing the glyphs.

            • 3. Re: Problems with laying out text in InDesign CS6
              Joel Cherney Adobe Community Professional & MVP

              7. I don't want to change the patagraph style. simply to reapply it without changing the glyphs.

              Can you describe this with a little more detail?  Do you mean that you are manually selecting contextual alternates by going to the Glyphs panel and clicking-and-holding on a glyph to select an alternate?  Because there may be better ways for you to get the alternate glyphs you want, that do not induce overrides. It sounds like you may be inducing overrides simpy by selecting alternate glyphs - so of course when you clear overrides (by alt-selecting a paragraph style), your manually-selected glyphs disappear.

               

              E.g. you go into the Glyphs menu to manually select small caps alternate glyphs, then when you clear overrides by alt-clicking you lose your smallcaps, because your paragraph style overtly specifies Normal in the Case: area in Basic Character Formats. (In this example, you'd be best served by making a character style called SmallCaps that only applied this one feature you need.)

               

              But that's just a guess - if you can go into more detail I'm sure we can figure out some way for you to get what you want.

              • 4. Re: Problems with laying out text in InDesign CS6
                John Mensinger Adobe Community Professional & MVP

                1. No style was applied.

                Then you may need to state the problem more clearly. Why do you have to use Find Font?

                2. it is not about the last word, but about the whole line.

                What does hyphenation have to do with a whole line? Are you saying you can't type a hyphen anywhere in the line?

                3. I don't think nor Quark user, neither InDesign user, simply -- user.

                In any event, InDesign gives you full control over whether an item on the Master is editable from the document page.

                4. how to enable smart text reflow?

                Read help: http://helpx.adobe.com/indesign/using/threading-text.html#use_smart_text_reflow

                5. I starts new document with only one page. The other pages are added by InDesign.

                That's one possible scenario. There are many others you can initiate.

                7. I don't want to change the patagraph style. simply to reapply it without changing the glyphs

                Why does it need re-application? If you add something to a paragraph, that isn't part of the applied style, (local formatting), then you reapply the style, it is you disposing of the local formatting, not InDesign. Just click without Alt.

                • 5. Re: Problems with laying out text in InDesign CS6
                  Petar_MK Level 1

                  Microsoft made a mistake when implementing Macedonian language. When I want

                  to swich to italic font, some characters turn into Bulgarian. So I use

                  Find/Replace/Glyphs to make the changes throughout the document, but when I

                  want to reaply the paragraph style (for some reason) the glyphs turn back

                  into Bulgarian again.

                  • 6. Re: Problems with laying out text in InDesign CS6
                    Petar_MK Level 1

                    1. When I use the nested paragraph style for the first time, it is OK. But

                    when I reopen document, the formating dissapears. Instead of Bold font for

                    Heading it is formated with regular font and in the Heading style the font

                    is still Bold.

                    2. When the words of the last line of the page are too loose, I try to

                    hyphenate the first word of the next page, but it does not work. I must use

                    to the part of the word to cut it and that word to go to

                    the previous page and then manually add hyphen sign at the end of the line.

                    3. I don't agree, but it doesn't matter.

                    7. Sometimes reapplying paragraph style is needed for a lot of reassons.

                    • 7. Re: Problems with laying out text in InDesign CS6
                      Petar_MK Level 1

                      1. When I use the nested paragraph style for the first time, it is OK. But

                      when I reopen document, the formating dissapears. Instead of Bold font for

                      Heading it is formated with regular font and in the Heading style the font

                      is still Bold.

                      2. When the words of the last line of the page are too loose, I try to

                      hyphenate the first word of the next page, but it does not work. I must use

                      (shift) (enter) to the part of the word to cut it and that word to go to

                      the previous page and then manually add hyphen sign at the end of the line.

                      3. I don't agree, but it doesn't matter.

                      7. Sometimes reapplying paragraph style is needed for a lot of reassons.

                      • 8. Re: Problems with laying out text in InDesign CS6
                        Joel Cherney Adobe Community Professional & MVP

                        Microsoft made a mistake when implementing Macedonian language. When I want

                        to swich to italic font, some characters turn into Bulgarian. So I use

                        Find/Replace/Glyphs to make the changes throughout the document, but when I

                        want to reaply the paragraph style (for some reason) the glyphs turn back

                        into Bulgarian again.

                         

                        I suspect that the answer for your issue is "use a font that is well-built" but I can't say that until I actually know what you are doing. Despite their extensive array of glyphs, that really can't be said of most Microsoft fonts. I mean, they draw some nice glyphs at Ascender, but the advanced font features seem to be designed to work in Microsoft applications only. 

                         

                        Are you picking contextual alternates from within the same font? Or are you picking them from another font? If the latter, then obviously you'd need a character style. You sound knowledgable enough to already know that, so I suspect you are picking alts from the same font. Which font(s) are you using? What letter(s) are rendering incorrectly? It's very useful if you open up the Glyphs menu and tell us the official Unicode name from the mouseover popup.

                         

                        Is it oblique Cyrillic ghe? (I'm just guessing - I do some Bulgarian typesetting, but I can't tell you the last time I handled Macedonian. Are you using a Greek gamma instead?)

                        • 9. Re: Problems with laying out text in InDesign CS6
                          [Jongware] Most Valuable Participant

                          Petar_MK wrote:

                           

                          2. When the words of the last line of the page are too loose, I try to

                          hyphenate the first word of the next page, but it does not work. I must use

                          (shift) (enter) to the part of the word to cut it and that word to go to

                          the previous page and then manually add hyphen sign at the end of the line.

                           

                          The last line of a page gets too loose because you disallowed automatic hyphenation of the last line on a page.

                          From the online InDesign Help on Hyphenation:

                           

                          Hyphenate Across Column
                          To prevent words from being hyphenated across a column, frame, or page, deselect this option.

                           

                          -- and you must have exactly that in your style(s). Look here:

                           

                          hyphenate.png

                           

                          Message was edited by: [Jongware]

                          • 10. Re: Problems with laying out text in InDesign CS6
                            Petar_MK Level 1

                            I am doing DTP for almost 20 years. I started with PageMaker, then

                            QuarkXPress and finally with InDesign (and only because QXP does not

                            support footnotes).

                            The problem is not in Microsoft fonts, but in that how Microsoft implement

                            MK language in Windows. BTW I am using Adobe Minion Pro and Myriad Pro. If

                            you want to see the "problematic" letters, please install Macedonian

                            Cyrilic keybord with US support and type these letters on your keyboard: *g

                            d p t*. When you select each one of them, in glyphs pallete you can see

                            their alternatives. Remember you must use italic font (just italic, or bold

                            italic, or black italic...). Their unicode numbers are 0433, 0434, 043F and

                            0442 respectivelly.

                            Once again, the problem is not in the fonts or glyphs, it is in reapllying

                            paragraph style that I have to do in some cases, not always. This problem

                            can not be solved with character styles, only manually with

                            Find/Replace/Glyphs or if Adobe wants to do something about this. But they

                            are not interested in country that has 2 milion people. We are too small

                            market. And the solution is Microsoft. They must implement MK language

                            correctly.

                            • 11. Re: Problems with laying out text in InDesign CS6
                              Petar_MK Level 1

                              Automatic hyphenation does not work. There is no Macedonian dictionary, so

                              we can not use automatic spelling checker and hyphenation at all. Nothing

                              happens when auto hyph or spelling checker is turned on. We must do

                              everything manually. when we used TTF fonts where MK letters were in the

                              place of english ones, Italian hyphenation rules worked fine. But, nowadays

                              when using OTF it is a biiiiiiiig problem. No others languages rules work.

                              • 12. Re: Problems with laying out text in InDesign CS6
                                Peter Spier Most Valuable Participant (Moderator)

                                Please see http://helpx.adobe.com/indesign/kb/add_cs_dictionaries.html

                                 

                                There are Macedonian language Hunspell dictionaries, but not being a user of Hunspell it's not clear to me if these dictionaries include hyphenation rules.

                                • 13. Re: Problems with laying out text in InDesign CS6
                                  MW Design Level 4

                                  @Peter Spier

                                   

                                  From the first paragraph of the page you linked to:

                                   

                                  Support for Hunspell dictionaries in InDesign CS6, to verify spelling and to hyphenate words, extends the number of languages shipped with the product...

                                   

                                  Take care, Mike

                                  • 14. Re: Problems with laying out text in InDesign CS6
                                    Peter Spier Most Valuable Participant (Moderator)

                                    I believe I saw a note further down the page not to repalce the exisiting dictionaries for hyphenation, so, having no direct experience, I can't say one way or the other.