7 Replies Latest reply: Aug 13, 2015 8:31 AM by jag_512 RSS

    Accents over French/Spanish letters InDesign

    Daliah Community Member

      I have a French document with lots of accented letters. I was trying to type those letters with accents on them, but I was unable to. I know how, I've done it in the past. I even looked it up online to get the correct keystrokes for the correct direction and accent. I get the accent and then the letter. InDesign is not allowing me to have the accent over the letter. Is this something that broke in CS5 and just needs to be fixed? Any ideas? I thought maybe this function was removed since now there is the handy Character Viewer at the top of the monitor. It is handy, but not convenient if you have a lot to type.

        • 1. Re: Accents over French/Spanish letters InDesign
          jmlevy Community Member

          Did you try to use the glyph panel? Or, you could switch temporarily to French or Spanish keyboard (system preferences on a Mac, I don't know how to do this on Windows).

          • 2. Re: Accents over French/Spanish letters InDesign
            Joel Cherney MVP

            I thought you just bumped an old thread with a post of a solution that doesn't involve typing accents.

             

            In your shoes, I might uinstall a French keyboard. Not hardware, mind you, but software. I'm not sitting at my Mac so I can't recall the precise steps but it's in the same menu area as the Character viewer. THis might not work for you because for all such keyboards you wind up needing to memorize that e.g. the backslash on your English-hardware keyboard has been replaced with the cedilla.

             

            I even looked it up online to get the correct keystrokes for the correct direction and accent. I get the accent and then the letter. InDesign is not allowing me to have the accent over the letter. Is this something that broke in CS5 and just needs to be fixed?

             

            Probably not. Can you tell us what keystroke(s) you're using, what operating system you're using, and what font you are using? InDesign CS5 is occasionally flaky about "combining accents" but if your font doesn't have the combining glyphs I think it simply won't work. I think.

            • 3. Re: Accents over French/Spanish letters InDesign
              Daliah Community Member

              Well the font could very well be the issue, but I just tried with Minion Pro with the same problem. Font is DIN Pro. System is 10.6.8. CS5. Yeah, not sure I'd want to install a keyboard for one file. I guess it could be helpful to know about though. Usually I have 1 or 2 letters I need to put an accent on and Character Viewer work fine for that. Not super conveninet and the keyboard, but helpful, especially for those characters that you don't know.

               

              Option + Shift + e then e again to get that accent on the e.

               

              So you saw me on that old thread. I ran into it while looking for something to solve this issue. I had already resolved that issue, which for me wasn't an InDesign problem.

               

              I opened the glyph window/panel, but that doesn't help with while typing. It is more convenient than Character Viewer I think.

              • 4. Re: Accents over French/Spanish letters InDesign
                Daliah Community Member

                I saw this website yesterday, but apparently didn't follow the keycomands very well. I tried it again and it worked. User error. For some reason I put a shift in there when it was just  "option + e + letter to be accented".

                 

                http://symbolcodes.tlt.psu.edu/accents/codemac.html

                • 5. Re: Accents over French/Spanish letters InDesign
                  Joel Cherney MVP

                  My whole job revolves around squeezing 40+ languages into InDesign, so I'm likely to reply to any post that is at all related to non-English stuff.

                   

                  Minion Pro has an acute accent, which is what you get with option-shift-e, but it looks to me like Minion does not have a combining accent, which is what you'd need. Your method did not work for me with Minion Pro, but it does work with Times New Roman. (Note that I'm not not not suggesting that you use TNR in your layout, I just picked it because it's a font that I know everybody has that also contains combining accents.) But if you use your method to type an acute accent on a font that actually has a combining accent, and then select that combined e-plus-combining-acute glyph and change it to Minion Pro, then in the glyphs menu it'll show up as a precomposed e-with-acute. 

                   

                  I handle a vast amount of Vietnamese text, so I run into this kind of issue all the time. You may want to look at this thread if you want to make your own special-character-input scripts, or maybe at this page of this book if you want to memorize all of the special-input key combos so you can specify e-with-acute and a-with-acute and whatever-with-cedilla directly, rather than trying to use combining accents. I think those instructions will work but I once again have to offer my at-work, no-Mac, I-didn't-test disclaimer.

                  • 6. Re: Accents over French/Spanish letters InDesign
                    RockstarBruski Community Member

                    Joel, thanks for that link as that led me to search for windows commands (I'm using a PC) and found Windows Alt Key Codes which worked for me

                    • 7. Re: Accents over French/Spanish letters InDesign
                      jag_512 Community Member

                      I'm using InDesign CC on a Mac, and there you go to TYPE and then select GLYPS. If you've already typed your character in INDD, such as an "e" for example, highlight it, and then go to the Glyphs chart, make sure the font you're using is showing up in the bottom window (mine says Minion Pro, for example), and then find the e with the accent in the panel, and click on it, and it should add the accent to your already-highlighted e in your INDD copy , like this - é. Good luck!