1 Reply Latest reply on Mar 11, 2013 2:34 PM by Willam van Weelden

    Context sensitive help not opening to bookmark (tough one)


      I have a Robohelp 9 HTML project with multiple topics. Each topic has multiple bookmarks. I have created a map file with mappings from a map id to a bookmark within a topic.


      An example of a map id is Change_SSN, the map # is 70, and this is mapped to a book mark.

      The .ali entry is <alias name="Change_SSN" link="Change_SSN\TCRS_Concord_Project_-_Change_SSN_User_Guide-FINAL.htm#3_Change_SSN">,

      BCCSDefault.h has this entry: #define Change_SSN 70

      whcsddata has this entry: SetCsh(15,"Change_SSN",70,"Change_SSN/TCRS_Concord_Project_-_Change_SSN_User_Guide-FINAL. htm#3_Change_SSN");


      I am using the standard RoboHelp_CSH.js file in my web application. Within that web application I call to RH_ShowHelp(0, <path to the index.htm file>,HH_HELP_CONTEXT,70). The help file will be displayed but it does not go directly to the book mark within the topic, instead the default topic is displayed. I have multiple topics and when the help file is displayed all topics are displayed in the TOC, the correct topic is not even opened let alone the bookmark within the appropriate topic.


      If I just open my browser and enter path/index.html#<id=70 again the help file is displayed but to the default topic. This leads me to believe there is not an issue with the coding of my web application but something odd with the help file.


      I have tried everything and I can not figure out why this is not working. Any help would be greatly appreciated.

        • 1. Re: Context sensitive help not opening to bookmark (tough one)
          Willam van Weelden Level 5



          • Is your help always opening the default topic regardless of whether you call a link to a bookmark or does it go to the default topic for every CSH call?
          • Are you using local help or is it placed on a server?
          • What browsers have you tried?
          • If you enter the entire path with two pound signs in the address bar, do you then see the correct topic/bookmark location? (example: http://example.com/index.htm#Change_SSN/TCRS_Concord_Project_-_Change_S SN_User_Guide-FINAL.htm#3_Change_SSN)


          My first guess would be that you have to enable all map files for your output. But you seem to have done that as whcshdata contains information. *For anyone reading this thread: To enable CSH in WebHelp: Open your SSL, expand Content Categories, select the category and check the map files you want to use under Map files.


          Please answer the questions and we’ll dive some deeper.