16 Replies Latest reply on Mar 18, 2013 10:04 PM by FranTod

    ADE and Kobo reader

    FranTod

      I have been using ADE successfully with my Kobo Glo. Suddenly I am unable to open DRM files on my Kobo. I keep getting the message that the documents are not currently authorised for use with my Adobe ID. Both my PC and my Kobo are authorised. Can anyone help?

        • 1. Re: ADE and Kobo reader
          sjpt Level 4

          Did you change version of ADE recently?

          Which Kobo?

           

          Sometimes authorization gets confused.  May be worth deauthroizing and reauthorizing.

          For ADE, ctrl-shift-D, restart ADE and reauthorize.

          For Kobo, ctrl-shift-E when running ADE with Kobo plugged in, restart and reauthorize.

           

          Sometimes the authorization goes even more wrong and it is necessary to delete some files on the Kobo;

          try the others first and post back if they don't help, and I'll check more details.

          • 2. Re: ADE and Kobo reader
            FranTod Level 1

            I've tried those and no change. I did restore my Kobo Glo to factory settings and start it again, I also uninstalled ADE and reinstalled it. I still get that same message. Still at a loss. When I restarted ADE I transferred the Getting Started with ADE document to my Kobo and it opens. It is just library books and books I've purchased that won't open. The books I've purchased from Kobo and have loaded by synching with Kobo Desktop open without any trouble.

            • 3. Re: ADE and Kobo reader
              rpdragon

              I am having the very same problem and have tried the same solutions and nothing is working either. I have been at this for days trying to find a solution. I am so frustrated. Did you resolve the issue?

              • 4. Re: ADE and Kobo reader
                FranTod Level 1

                No I haven't resolved it yet. I'm hopefully waiting for someone to come up with a new idea. Sorry to hear that you are having the same problem but pleased to find I am not alone.

                • 5. Re: ADE and Kobo reader
                  rpdragon Level 1

                  I  finally had success downloading a library book from my public library. Here is what worked for me....

                   

                  I de-authorized and re-authorized as per sjpt's instructions...(even though I had already done that several times with no previous success).

                   

                  ( I have the Adobe Digital Editions v2.0...Windows 7...Internet Explorer 9...Kobo Glo....Ontario Public Library: Overdrive. )

                   

                  I then reset the factory settings on my Kobo Glo, but when I restarted it, I did so via the usb method instead of the wireless method which I had done before. I followed the prompts to re set up the Kobo Glo. I then connected the wireless under 'settings'on the Kobo. I also made sure all the settings were correct....the time was incorrect, so I corrected it. I checked the 'account' under 'settings' and saw that Adobe was not signed in, despite the fact that I was signed in on their website and I had re-authorized both the computer and the Kobo just previously.

                   

                  With the Kobo connected to the computer with the usb cable and connected to manage files, I opened my Adobe Digital Editions and checked to make sure the authorizations were still there. The computer (click the' help'button to check )was authorized still, but the Kobo (click the button next to 'device' that shows your Kobo to check. Remember to click the kobo device line first.) was not authorized any longer. I authorized it...again.

                   

                  Then I chose a library book I had previously downloaded to ADE, clicked and dragged it to the Kobo device line....saw that it downloaded....safely ejected the Kobo...and there it was on my Kobo home page!!!! Also, under 'accounts' in 'settings', Adobe was signed in.

                   

                  Let's hope this is solved now.

                   

                  FranTod, I know you have tried all this...so had I.... but this time it worked with a few subtle differences in the way I did it. I wanted to share this result, in case it will work for you too.

                  Good luck.

                  • 6. Re: ADE and Kobo reader
                    sjpt Level 4

                    Try the following two options.

                     

                    ~~~~~~~~~

                    Try the older v1.7.2.  ADE 2.0 is riddled with bugs.  In particular, it doesn't like Library books in conjuction with certain eReaders.

                    (With the Sony PRS-350, I found that having the Sony plugged in would stop ADE2.0 even reading library books from ADE on the PC).

                    Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

                    http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

                    The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

                     

                    ~~~~~~~~~

                    I've never had to try this; just read about it elsewhere.  It seems to be a situation where the authorization get confused, and even removing it doesn't really remove it.

                    Looks like it isn't applicable to all devices: my Sony RPS-350 does not have a directory as in step 6.

                    On my Bookeen Opus the directory is named '.adobe-digital-editions' as below.

                    Also, I would have expected a factory reset to clear this directory, but ...???


                    1. Make sure any books you have on the Kobo are safely backed up elsewhere, just in case.
                    2. Deauthorize the ereader (ctrl-shift-E  to ADE while device plugged in)
                    3. Close ADE
                    4. Look at the ereader device showing up as a drive on a file manager such as Windows Explorer
                    5. Make sure you are showing hidden files/directories.
                    6. You may see a (hidden) file or directory with a name like '.adobe-digital-editions'
                      Not the directory 'Digital Editions' which probably contains all the books.
                    7. Delete it.
                    8. Restart ADE
                    9. Try to reauthorize the device.

                     

                    Horrid.  Good luck.

                    • 7. Re: ADE and Kobo reader
                      FranTod Level 1

                      It worked!! Thanks for all your help.

                      • 8. Re: ADE and Kobo reader
                        rpdragon Level 1

                        I am so glad! Just curious...what did you end up doing that got it to work?

                        • 9. Re: ADE and Kobo reader
                          FranTod Level 1

                          I removed the file as suggested and then went back through the process of resetting my Kobo to factory settings and restarting from scratch. I was using the USB option anyway as I wanted to charge my eReader. When I opened ADE it said my Kobo was authorised but I noticed that when I transferred a library book it authorised it again and then everything just worked. I can only assume that it was removing that file that made the difference.

                          • 10. Re: ADE and Kobo reader
                            sjpt Level 4

                            Excellent.  As a matter of interest (it always helps to know a little more of what is going on), I assume that the reauthorization has create a new copy of the '.adobe-digital-editions' directory.  Is that true?

                            • 11. Re: ADE and Kobo reader
                              slm64 Level 1

                              I had a similar problem recently and it seems that Kobo needs to have wi-fi turned on when you're adding the book.  I normally leave wi-fi off.  Of course, many other people may leave wi-fi on all the time, but perhaps this will help someone.

                              • 12. Re: ADE and Kobo reader
                                newgirl3

                                I have had similar problems and am selling Kobo because when I finally got a library onto the device message came up' OOps!this document couldn't be opened by ADE Right Management DRM. It is not authorised to use with your Adobe ID', which I have not changed so don't know how to progress further.

                                • 13. Re: ADE and Kobo reader
                                  rpdragon Level 1

                                  That was the message and issue I had had, but it is now resolved.

                                   

                                  Before selling your Kobo, consider doing the solutions outlined in this thread. Myself and Fran Tod had success in doing them. I now love my Kobo and am enjoying lots of library books as well as purchased books.

                                   

                                  Good luck...

                                  • 14. Re: ADE and Kobo reader
                                    rpdragon Level 1

                                    FYI...I was able to keep the ADE 2.0 version rather than having to resort to the older version.

                                    • 15. Re: ADE and Kobo reader
                                      FranTod Level 1

                                      Sorry, meant to get back. Yes it did.

                                      • 16. Re: ADE and Kobo reader
                                        FranTod Level 1

                                        I was very frustrated but the Kobo is working well now. Just make sure that you remove that '.adobe-digital-editions' file from the list in Windows Explorer, reset your Kobo to factory settings and then plug in the eReader to your computer and everything will reset. I kept well away from Wifi. I'm not sure whether that makes any difference but it does seem to simplify things.