0 Replies Latest reply on Mar 4, 2013 4:08 PM by naff89

    Support for HTC Droid DNA?

    naff89

      Though the only requirement for the Android version is 4.0+, which the HTC Droid DNA meets, Google Play says it's not compatible with my phone.

       

      Any idea why, or when a compatible version will be released? I'm excited to use it on this big, beautiful screen!