5 Replies Latest reply on Mar 6, 2013 5:35 PM by DustinMCHD

    Mouse Pointer Stuck CS5.1

    DustinMCHD

      Hello,  I have a pressing issue that I cannot seem to solve. 

       

      Windows 7 Home Premium

      Design Premium 5.5

       

      I have used Fireworks many times, but not within the last few weeks.  Now whenever I open it, the mouse pointer is stuck in an area of the screen, usually in the upper right side and isolated to maybe a 20x20 pixel area.  It is not frozen and the hot keys still work.  I can alt-tab out and back in with no change as well as minimize, maximize, reposition with the windows hot keys, etc.  I have disabled almost all of my startup programs as well aside from Avast, no change.  I also tried renaming my Fireworks preferences folder so it is forced to create a new one.  I uninstalled Fireworks and reinstalled.

       

      What does work?  All other apps in the Deisign suite work without issue.  If I log out of my windows account and log into a newly created account.  It is following my Windows profile.  It would be exremely difficult to switch back and forth so I'm looking for a solution within the same account.  Also, I have not recently added any hardware and as far as I know all my Windows updates are up to date and video drivers(ATI) and other hardware are up to date.

       

      Any help is greatly appreciated.

       

      Thanks,

       

      Dustin

        • 1. Re: Mouse Pointer Stuck CS5.1
          groove25 Level 4

          Here are a few troubleshooting links, but they're really "laundry lists":

           

          http://helpx.adobe.com/x-productkb/global/troubleshoot-system-errors-freezes-windows.html

          http://helpx.adobe.com/creative-suite/kb/troubleshoot-launch-issues-problems-cs5.html

           

          It sounds like you're on the right track if you've traced the problem to your particular user account or profile. This suggests that it's either a Fireworks file associated with that profile, another application being run, or a system preference of some type.

           

          But it's a weird-sounding bug, too. This may sound stupid, but if you're on a desktop system, have you tried unplugging the mouse?

          • 2. Re: Mouse Pointer Stuck CS5.1
            John Dunning

            I've sometimes seen Flash panels hide the mouse to show a custom cursor when over a panel, but then fail to reshow the normal cursor when the mouse moves out.  So it looks like your cursor's disappeared.  This has mainly been on Mac, though.

             

            You might try temporarily renaming the C:\Program Files (x86)\Common Files\Adobe\APE directory to something else and restart FW.  APE is a platform for using AIR to build panels, and it's possible that it's interfering with the cursor somehow.  I've seen FW get into a state where it would hang on launch, and disabling APE for a bit fixed it.  But that's pretty much a shot in the dark.

            • 3. Re: Mouse Pointer Stuck CS5.1
              DustinMCHD Level 1

              Thanks much for the information you provided.  I have gone down the lists of things to try in the links with, unfortunately, no fix.  I did create a new user account and ran Fireworks there and it runs just fine.  So then I went through the process of copying the C:\users\username dir to the new user folder (per microsoft instructions to fix corrupted user profiles) and the problem comes right back.  So, to me, this pretty well proves it is something there.  If only I could find out where!  I may just have to reconfigure everything from scratch under a new account which is extremely time-consuming, but it may be my only recourse.

              • 4. Re: Mouse Pointer Stuck CS5.1
                DustinMCHD Level 1

                John, thanks for the suggestion.  I tried renaming that folder and the problem is still there.  The mouse pointer doesn't actually disappear, but it locks itself inside a tiny area of confinement, sometimes within fireworks or depending on where I have FW placed, outside the window on an empty area of the desktop.

                • 5. Re: Mouse Pointer Stuck CS5.1
                  DustinMCHD Level 1

                  I have found the solution to this odd problem.  I started going through and killing processes in task manager one by one except for obvious Windows processes.  I killed the process for the Wacom Intuos 4 and voila, the mouse pointer freed up.  I hardly ever use the thing and it was covered up by some papers with the little Wacom mouse sitting on the input pad.  For whatever reason, Fireworks was overriding my logitech mouse inputs to where the Wacom mouse on the pad was sitting.  After killing the process and re-siging into the account it no longer showed the behavior.  It's pretty funny to think about after the fact, but I spent hours figuring this out

                   

                  Thanks again for the suggestions!