12 Replies Latest reply on Mar 7, 2013 3:10 PM by Jeff Schewe

    Adobe Photoshop Elements 10, RAW update 6.7 EOS 5D mk3 support. (MAC OSX 10.8.2)

    Gadget[_Al!

      My system tells me that the update file failed bacuse it is not applicable (ElementsCameraRaw-6.7-mul-AdobeUpdate) - is this the correct file, if not where can i get the correct file. If it is what do i need to do to get around this problem?