16 Replies Latest reply on Aug 8, 2013 11:03 AM by judyn1

    RH 10: Cannot browse images

    judyn1

      I'm on Windows 8 (no I cannot downgrade).

       

      RH10 installed fine and seems to work ok except that when I try to add an image to the project by browsing, it hangs. It does it in a way that doesn't even trigger the Windows <application> is not responding msg. Only thing I can do is End Task in Task Manager.

       

      Also, RH10 doesn't recognize Word 13, again, can't downgrade.

       

      Bah humbug.

       

      Anybody have any ideas about the image problem, I'm hoping adobe comes out with a patch for the Word problem.

        • 1. Re: RH 10: Cannot browse images
          RoboColum(n) Level 5

          Is it just the dialog when adding an image that hangs or other dialogs as well (e.g. adding a hyperlink)? Can you add an image that resides inside your project already? Where are the images located that you want to add?

           

          BTW RH10 was not tested against Word 2013 because it didn't exist back then!

          • 2. Re: RH 10: Cannot browse images
            judyn1 Level 1

            Well I crashed Robohtml or you again.

             

            To answer:

            Adding a hyperlink does not crash it.

            Adding captivate and trying to browse for a file does crash it. On a very limited sample size, it seems to be crashing when it tries to access windows explorer when I try to find a file.

            I can type the file name in, instead of browsing for it, and it adds it just fine.

            The files are in the root RH project folder for the help set.

            Adding files that are already in the project is fine, I don't need windows explorer to access them.

             

            I knew about the Word 2013 from looking it up. I'm still hopeful they'll offer an update soon. It's kind of crippling. Some people have had success producing print with Word2013 anyway, sadly I'm not one of the fortunate. Fingers crossed.

             

            And thank you very much for responding.

             

            Judy

            • 3. Re: RH 10: Cannot browse images
              Peter Grainge Adobe Community Professional (Moderator)

              I'm wondering if it is worth trying an uninstall and reinstall. Was Rh installed by someone with admin rights? That is vital.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

               

              @petergrainge

              • 4. Re: RH 10: Cannot browse images
                judyn1 Level 1

                I installed it, I have admin rights, but I'm learning that Windows 8 admin right are not the same as xp admin rights.

                 

                I own the laptop, I'm the only account on it, but I learned recently that I must be protected from myself and my zealous desire to install work tools on a work tool. What was I thinking.

                 

                Peter, do you know what kind of wand waving I have to do to get RoboHTML installed properly on Windows 8?

                • 5. Re: RH 10: Cannot browse images
                  Jeff_Coatsworth Adobe Community Professional & MVP

                  Turn off UAC and give yourself full rights to your local c:\ drive - when Vista came in, MS started "protecting" you from yourself. Win7 only made it worse IMHO.

                  • 6. Re: RH 10: Cannot browse images
                    Peter Grainge Adobe Community Professional (Moderator)

                    I take it that nothing has changed after reinstalling.

                     

                    Word can be made to work in printed documentation by starting the process with a right click on Properties.

                     

                    All I did was a straightforward install, nothing special.

                     

                    Exactly what point does browsing to images fail? Is it when you start to browser or when you home in on a specific folder. Wondering if you are going to a folder with lots of images.

                     

                    Do you get the same problem with one of the sample projects? Click Open on the RoboHelp Starter page and then click Samples in the ribbon on the left.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                     

                    @petergrainge

                    • 7. Re: RH 10: Cannot browse images
                      judyn1 Level 1

                      Agreed. Windows 8 is definitely a consumer product, not a development product. And I hate the overprotective hoops they've shoved down our throats. Sigh.

                      • 8. Re: RH 10: Cannot browse images
                        judyn1 Level 1

                        Word: yes, I'd read that, but have not been able to get it to recognize Word at all, maybe after the re-install.

                         

                        I have been advised by the tools wiz at my client site to try the re-install - run as admin, which I probably did, but can't remember for sure, so will do again.

                         

                        Browsing in RH10 fails on this Win8 system. Anything that requires browsing for a file hangs. Open (both File>Open and Open on the RH start-up page), Insert Image is fine until I hit the browse icon, captivate does the same. Import a document does the same.

                         

                        I'm about to try the re-install. If this does not work, I'm not sure what I will try.

                         

                        Thanks for looking at this stuff.

                        • 9. Re: RH 10: Cannot browse images
                          judyn1 Level 1

                          Ran into a hickup - no re-install until tonight or tomorrow. I will post what the result when I can get to it. Thx all.

                          • 10. Re: RH 10: Cannot browse images
                            Amebr Level 4

                            This "hang" sounds like the old chestnut of the dialog box falling into the crack between the screens.

                             

                            I'm not sure if this still works on Win8, but can't hurt to try.

                             

                            1. Perform a browse action, and make sure you don't click on anything afterwards (to ensure the browse dialog box has focus) .

                            2. Press Alt+Spacebar, M

                            3. Press any arrow key.

                            4. Waggle the mouse until the dialog box shows on screen, then left-click to drop it where you want.

                             

                            HTH,

                            Amber

                            • 11. Re: RH 10: Cannot browse images
                              bds2012

                              That worked like a charm, Amebr!!! Thank you so much!

                               

                              BTW, I'm on Windows XP and Robohelp 10. So the issue is not specific to Windows 8.

                               

                              But I'm eager to know the cause and solution because it used to work fine all this time and all of a sudden, it started to hang after clicking browse!

                              • 12. Re: RH 10: Cannot browse images
                                bds2012 Level 1

                                Update - I tried disabling the additional monitor and worked with only one screen. It works fine without hanging! But I'm still not clear of the reason for this issue since I've worked with 2 screens most of the time without facing this.

                                • 13. Re: RH 10: Cannot browse images
                                  Captiv8r Adobe Community Professional & MVP

                                  Hi there

                                   

                                  So here's a quasi technical explanation of the situation.

                                   

                                  For many years an elusive bug has existed in the RoboHelp code. I say that it's elusive because I'm unaware of any clear way to cause it to happen in order to report it to the development team.

                                   

                                  Ameber pointed you to a solution involving blindly opening the system menu of the unseen dialog and moving it to the visible area of the application. However, I have to politely disagree with her assessment of saying it "fell through the crack" between monitors. I say this because long before multiple monitors were common I would see the dialog go missing. Prior to Ameber sorting the cool keyboard navigation to coax the dialog into view, my own solution involved mucking about with the Windows Registry. Ameber's solution is much safer and more straightforward.

                                   

                                  Here's why I disagree with the bit about falling through the crack.

                                   

                                  I know that the screen X and Y coordinates that determine the placement for the dialog are stored in the Windows Registry in a couple of specific keys and location. Prior to Ameber's solution, I would instruct folks to open the Windows Registry Editor and change a couple of values in these keys that would place the dialog in a known location when RoboHelp next tried to present it.

                                   

                                  In the cases where the dialog went missing, I noted the values that were appearing in the registry keys for the dialog. I commonly joked that the values were representative of the computer's relationship to pluto! Meaning they were astronmically high. Hence my disagreement with "falling between the crack". If that were the case, I might expect to see some odd value that was indicative of a reasonably proximity to the main monitor resolution as opposed to some bizarre and astronomically high value.

                                   

                                  Cheers... Rick

                                  • 14. Re: RH 10: Cannot browse images
                                    Amebr Level 4

                                    Oi! Poetic license here!

                                     

                                    Also, for those interested, here's a slightly related article from one of my favourite computer journalists (from 2006!)

                                     

                                    http://www.dansdata.com/gz070.htm

                                    • 15. Re: RH 10: Cannot browse images
                                      Captiv8r Adobe Community Professional & MVP

                                      LOL, thanks for the great read!

                                      • 16. Re: RH 10: Cannot browse images
                                        judyn1 Level 1

                                        I had to set this aside for a bit. Came back to it and am very pleased to find a solution. Thank you very much for the suggestion, it worked a treat.