1 Reply Latest reply on Mar 11, 2013 7:09 AM by kTamanaha

    How to disable ThrottleEvent slowing down

    kTamanaha

      Hi,

      I am making original media player using OSMF 2.0.

       

      But, I have a problem with my media player when ThrottleEvent fired (moved to hidden tab on browser), the video's sound skips.

       

      I read references, and this article http://help.adobe.com/en_US/as3/mobile/WS4bebcd66a74275c36cfb8137124318eebc6-8000.html ,

      but I couldn't find how to disable the minimizing CPU usage feature on Flash Player, or simply playback video without sound skips.

       

      Some video player like YouTube doesn't have the same problem, I think there is a solution for this problem.

       

      If anyone know the answer, please let me know.

       

      Thanks

        • 1. Re: How to disable ThrottleEvent slowing down
          kTamanaha Level 1

          SOLVED.

           

          I increased stage framerate to 60 fps, the problem not occured anymore.

           

          I have set my stage framerate as 1 fps before so that the video's framerate itself doesn't matter stage framerate.

           

          Then, I increased the framerate to 15 fps sound better, and 30 fps almost fine, 60 fps doesn't have any problem.

           

          Thanks for reading,, and I hope this will help someone in the near future.