5 Replies Latest reply: Jun 20, 2013 9:43 PM by ComDoc1 RSS

    PSE 11 Editor won't open


      Just received a new PC w/ PSE 11 pre-installed.  OS is Windows 8.

      Was editing a photo in LR 4 and wanted to go into PSE 11 Editor to do more editing.  When I tried to open PSE editor, Adobe required product registration, which I did.  LR created a duplicate TIFF file and everything, and the window popped up asking if I wanted to Edit a Copy with Lightroom Adjustments, etc., and then PSE 11 Editor opened up fine the very first time.  (However it didn't seem like some of the tools were working properly, but that's another question for another time.)

      Subsequent attempts to open the PSE Editor either from Elements itself and LR4 have failed.  Editor will not open.  Why is this happening with a brand new product?

        • 1. Re: PSE 11 Editor won't open
          ~V Adobe Employee

          Try these solutions to see if any of these work.

          If none of them works, let me know.



          Close Elements. Launch the Photoshop Elements Welcome Screen and hold down ctrl + alt + shift as you click Editor. Continue to hold the keys until you see a message box asking if you want to delete Photoshop Elements settings file. Click Yes. Elements will open with default preferences.



          In case any network printer is attached try to launch without network or printer uninstall or make different printer as default.



          In case that does not work too, you may try this.

          Try launching with anti-virus off or removing PSE from conflicting list.




          • 2. Re: PSE 11 Editor won't open
            Anizor7082 Community Member

            Not sure if others are having this problem, but all I had to do was check for updates. 

            • 3. Re: PSE 11 Editor won't open
              ComDoc1 Community Member

              My PSE11 Editor stopped launching after updating the Adobe Application Manager. Will launch if I restart the computer OR if I stop the PSE Editor.exe PROCESS in the Task Manager. All this after running normally for over a month UNTIL I DID THE AAM UPDATE. Re-install X2 did not help. Can't uninstall AAM- tried the Adobe Creative Suite Cleaner Tool-no help. Also, reset preferences/d/c  printer and Anti-Virus soft ware-no help. Thoughts? BTW- checking for updates only showed AAM and Raw updates. NO Help either. Yuck!

              • 4. Re: PSE 11 Editor won't open

                I have the same problem...ready to return the whole package.

                • 5. Re: PSE 11 Editor won't open
                  ComDoc1 Community Member

                  Adobe help provided direction by CHAT Response that SOLVED my PSE11 Editor problem (Win  7 Pro 64 bit): C:/Program Files (X86)/Adobe/PSE11/PSE11Editor.exe-RT Click/Properties/compatibility/ check -Run as Administrator. Check the -use these Settings for all users -click- the change that to Run as Administrator - which is on the next screen.


                  Do the same for PSE Elements11.exe and PSE Organizer.exe (in order for the Organizer and the Splash screen to work too.


                  After this exercise- PSE11 Editor and Organizer has run flawlessly.


                  It is such an improved program-it is worth the effort.


                  Good luck.