5 Replies Latest reply on May 3, 2014 8:58 AM by dg2727

    Hide filename ext when saving?

    JIMCJ1301

      This might be a simple prefrence setting but I can't seem to make it work. In CS5 and I go to "save for web" like I would when I was on CS4. A lot of times I will click on an exsiting file so that file name will auto fill the new save name and then i'll add to it. But now when I click on a file I get the filename and ext, how can I get just the filename to show in the input box and not add the file ext to the name?

       


      sample2.jpg

        • 1. Re: Hide filename ext when saving?
          Curt Y Level 7

          You can hide file extensions by opening Windows Explorer and clicking on Tools/folder options.

          • 2. Re: Hide filename ext when saving?
            JIMCJ1301 Level 1

            That doesn't seem to hide the ext from the input field of Photoshop when saving files. Only when you are viewing thumbnails, and as you can see from my sample image I have the option turned on. Theres is no ext on my thumbnail but when I click it the sample thumbnail, filename+ext shows up in the new filename spot. Now if I wanted to call my new file "Sample2" I would have to retype it or backspace the ext. This seems minor but im usually saving lots of files and they usually consist of long filenames with numbers so retyping tends to slow me down.

            • 3. Re: Hide filename ext when saving?
              conroy Level 5

              You don't need to type the entire name sample2 or press backspace multiple times.

               

              Immediately after clicking on the thumbnail to get sample.jpg into the file name field, you still have the mouse in hand, so click in front of the period then drag the mouse over the .jpg characters to highlight them then type 2 to overwrite the highlighted characters.

              • 4. Re: Hide filename ext when saving?
                Curt Y Level 7

                In CS5 in clicked Save for Web and optimized but I do not have the extension added to file name.  In the OS I have show extension turned ON.

                 

                Did another test and I do get an extenstion added if I change the save directory.

                • 5. Re: Hide filename ext when saving?
                  dg2727

                  I have this issue as well and it appeared out of nowhere yesterday in Photoshop CS6.

                   

                  Previously, when I tried to "save as" I got "filename." Starting yesterday I get "filename.jpg."

                   

                  I have another installation of CS6 and on that one I get simply "filename."

                   

                  This has nothing to do with file/folder options in Windows Explorer. I don't see extension names anywhere but in the Phootshop 'save as' input field.

                   

                  There must be a fix for this.

                   

                  It is highly annoying.