1 Reply Latest reply on Mar 19, 2013 8:42 AM by jaykay

    Coldfusion upgrade, dates not being read properly

    jpcar

      Hi guys,

      We upgraded our server from Coldfusion 8 to 10 not too long ago and there were problems initially but most of them got fixed. Now the issue is that  dates are not getting retrieved properly when, prior to the upgrade, it was.

       

      Let's say that on the database for a particular person, it shows the date as 8:34 AM but when you try to display the date, it only shows up as 00:00 AM (or 12:00 AM depending on how we changed the format in the output). The strange thing is that the information is getting passed TO the database properly (Oracle 11g), its just not retrieving it right and what's stranger is that the days, months, and year is getting retrieved ok, just not the seconds, minutes and hours.

       

      I've tested using different types of functions for the output (timeformat, datetimeformat), used -Doracle.jdbc.J2EE13Compliant=true and -Doracle.jdbc.V8Compatibile=true, updated our ojdbc14.jar to ojdbc6.jar (since our JDK was 1.6), and tried various other solutions that were on the web and on the discussion but they all haven't worked so far. Even when I cfdump the query, it gives me {ts 'xxxx-xx-xx 00:00:00'} for every entry.

       

      Any help or direction would be very appreciated

        • 1. Re: Coldfusion upgrade, dates not being read properly
          jaykay

          I too am experiencing the same problem.

           

          My company upgraded our development environment from Coldfusion 8 to Coldfusion 10 ... we then proceeded straight to install ColdFusion Update 8  (since it was a cumulative update) via the new Server Update in the Administrator.  (10.0.8)

           

          We are using the JDBC thin client oracle driver from Oracle corporation.. ie . ojdbc14.jar or ojdbc6.jar.

           

          So far we cannot retrieve any time from any Oracle Date/Time columns as the previous poster stated.

           

          Without fixing this problem in our dev environment, i'm not sure how we'll be able to upgrade our production environment.   Any workarounds/advice/ideas to try would be great.

           

          Thanks in advance.