15 Replies Latest reply on Mar 18, 2013 6:49 AM by codonvirginia

    Replicating

    codonvirginia

      do you know why i got "no such agent: publish" when i click on view log after I do replication?

      Agent is not active. Replicating to http://localhost:4503/bin/receive

      Queue is not active

       

      Thanks,

       

      Jenny

        • 1. Re: Replicating
          berliant Level 1

          This error indicates that you have a replication agent by the name “publish” and it’s not enabled. Try to get to http://host:port/etc/replication/agents.author.html, click on Default Agent (publish), then Edit. On Settings Tab click on “Enable” checkbox and OK. You might want to verify connection by clicking on “Test Connection”

          • 2. Re: Replicating
            codonvirginia Level 1

            Thanks for reply but I have checked the Enable box. I tried to click on "Test Connection" but It does not do anything . I dont see any popup. I am new in CQ . Can you help me

             

            Thanks,

            • 3. Re: Replicating
              berliant Level 1

              Jenny,

              In the agent settings under transport tab verify the URL. It has to be http://host:port/bin/receive?sling:authRequestLogin=1 where host is host name or IP of your publish instance and port is publish instance port. For example if you run CQ publish on the same server as your CQ author and port is 4503 you can use http://localhost:4503/bin/receive?sling:authRequestLogin=1

              • 4. Re: Replicating
                codonvirginia Level 1

                I check that is ok.. I dont know why I can not check the " test connection". I click on that button but does not do anything.

                 

                Thanks,

                Jenny

                • 5. Re: Replicating
                  codonvirginia Level 1

                  when I click on "view log" link. I got "no such agent: publish".

                   

                  Thanks

                   

                  Jenny

                  • 6. Re: Replicating
                    berliant Level 1

                    How do start your CQ? Is it possible that no run mode is set? Did you name jar like cq-author-p4502.jar?

                    If you start CQ via script make sure that CQ_JVM_OPTS includes -Dsling.run.modes=author.

                    • 7. Re: Replicating
                      codonvirginia Level 1

                      berliant,

                       

                       

                      I start CQ by scritpt . I will add CQ_JVM_OPTS and find out. I will let you know.

                       

                      Thanks,

                      Jenny

                      • 8. Re: Replicating
                        codonvirginia Level 1

                        Hi Berliant,

                         

                        I add -Dsling.run.modes=author to CQ_JVM_OPTS but I got the same error.

                         

                        Thanks,

                        • 9. Re: Replicating
                          berliant Level 1

                          Jenny,

                          Most likely the issue is due to sling runmode is not picked up. If you are using crx-quickstart/bin scripts just make sure that runmode is setup properly:

                          ::* runmode(s) set CQ_RUNMODE=author

                          You might want to contact CQ support and the issue can be fixed on screen share session.

                          • 10. Re: Replicating
                            codonvirginia Level 1

                            Hi Berliant,

                             

                            Thanks for your help. It is working now.. if you dont mind can I have your email so I can ask you some question in future because I am new in CQ5 5.5. This is my email lethuhong20122012@yahoo.com

                             

                            Thanks,

                             

                            Jenny

                            • 11. Re: Replicating
                              codonvirginia Level 1

                              15.03.2013 15:30:04 - ERROR - publish : Replication (TEST) of /content not successful. Conversation follows

                              15.03.2013 15:30:04 - ERROR - publish : ------------------------------------------------

                              15.03.2013 15:30:04 - ERROR - publish : Sending message to localhost:4503

                               

                              15.03.2013 15:30:04 - ERROR - publish : >> POST /bin/receive HTTP/1.0

                              15.03.2013 15:30:04 - ERROR - publish : >> Action: Test

                              15.03.2013 15:30:04 - ERROR - publish : >> Path: /content

                              15.03.2013 15:30:04 - ERROR - publish : >> Handle: /content

                              15.03.2013 15:30:04 - ERROR - publish : >> Content-Length: 0

                              15.03.2013 15:30:04 - ERROR - publish : >> Content-Type: application/octet-stream

                              15.03.2013 15:30:04 - ERROR - publish : --

                              15.03.2013 15:30:04 - ERROR - publish : << HTTP/1.1 401 Unauthorized

                              15.03.2013 15:30:04 - ERROR - publish : << Connection: Close

                              15.03.2013 15:30:04 - ERROR - publish : << Server: Day-Servlet-Engine/4.1.32

                              15.03.2013 15:30:04 - ERROR - publish : << Date: Fri, 15 Mar 2013 19:30:04 GMT

                              15.03.2013 15:30:04 - ERROR - publish : << WWW-Authenticate: Basic realm="Sling (Development)"

                              15.03.2013 15:30:04 - ERROR - publish : <<

                              15.03.2013 15:30:04 - ERROR - publish : Message sent.

                              15.03.2013 15:30:04 - ERROR - publish : ------------------------------------------------

                              15.03.2013 15:30:04 - INFO - publish : Replication (TEST) of /content not successful.

                               

                              Do you know why I click on "Test connection" I got these message in log..? why  the content not successfull.?

                               

                              Thanks

                               

                              Jenny

                              • 12. Re: Replicating
                                berliant Level 1

                                The reason is: 15.03.2013 15:30:04 - ERROR - publish : << HTTP/1.1 401 Unauthorized

                                Put user name and password of the account on publish, for example admin/admin

                                • 13. Re: Replicating
                                  codonvirginia Level 1

                                  I have done that step in " Agent setting " dialog.

                                   

                                  Thanks,

                                  • 14. Re: Replicating
                                    berliant Level 1

                                    Ok, but is it really admin/admin or the admin password has been changed?

                                    • 15. Re: Replicating
                                      codonvirginia Level 1

                                      Admin password has been changed.I create and admin user name and password.But I still got the

                                      18.03.2013 09:48:10 - Sending message to localhost:4503

                                      18.03.2013 09:48:10 - >> POST /bin/receive HTTP/1.0

                                      18.03.2013 09:48:10 - >> Action: Test

                                      18.03.2013 09:48:10 - >> Path: /content

                                      18.03.2013 09:48:10 - >> Handle: /content

                                      18.03.2013 09:48:10 - >> Content-Length: 0

                                      18.03.2013 09:48:10 - >> Content-Type: application/octet-stream

                                      18.03.2013 09:48:10 - --

                                      18.03.2013 09:48:10 - << HTTP/1.1 401 Unauthorized

                                      18.03.2013 09:48:10 - << Connection: Close

                                      18.03.2013 09:48:10 - << Server: Day-Servlet-Engine/4.1.32

                                      18.03.2013 09:48:10 - << Date: Mon, 18 Mar 2013 13:48:10 GMT

                                      18.03.2013 09:48:10 - << WWW-Authenticate: Basic realm="Sling (Development)"

                                      18.03.2013 09:48:10 - <<

                                      18.03.2013 09:48:10 - Message sent.

                                      18.03.2013 09:48:10 - ------------------------------------------------

                                      18.03.2013 09:48:10 - Replication (TEST) of /content not successful.

                                       

                                      Thanks,