3 Replies Latest reply on Mar 18, 2013 5:14 PM by Anit_Kumar

    No TOMCAT listed in ISAPI Filter after CF10 install

    srushing

      Hey

       

      I just installed CF10 STANDARD on a Windows 2003 server with IIS6.   Twice actually.  The first time I installed is side by side with CF7 (yeah, I know..old) and I recalled seeing TOMCAT listed in the ISAPI Filters section of the IIS website.  But after I uninstalled 7, had some funky things going on and uninstalled and reinstalled CF10 by itself, I now do NOT see anything listed under the ISAPI Filters section of IIS.    In reading the IIS Config document from Adobe, I see that it looks like it (and other things) should have been there, see below:

       

      Verify your IIS configuration

      1. Verify that the following folder was created: cf_root/config/wsconfig/number.
      2. To set the connectionpooltimeout and reuseconnectioncount click on Advanced Setting tab. The option to enable buffering  and verbose debugging is available on the same page.

      Configuring IIS:

      • Creates a folder 1 in cfroot\config\wsconfig, that contains all connector-related files. 
      • Creates a virtual directory Jakarta in cfroot\config\wsconfig (in IIS). 
      • Adds an entry, tomcat, under the ISAPI FILTERS. This points to cfroot\config\wsconfig\1\isapi_redirect.dll.
      • Adds an entry, tomcat, to  cfroot\config\wsconfig\1\isapi_redirect.dll with permission allowed under ISAPI and CGI Restrictions. It is applicable for global sites in IIS manager.
      • Adds the following isapi handlers: cfcHandler, cfmHandler, cfmlHandler, cfrHandler, and cfswfHandler.
      • For debugging issues, set the log level to debug, in the isapi_redirect.properties file present in the cfroot\config\wsconfig\1\ directory.
      • To disable webserver buffer,  change the is_buffer_enable to false in the cfroot\config\wsconfig\1\isapi_redirect.properties file. Disable webserver buffer if you want cfflush to work over an IIS connector. If your application does not use cfflush, set it to true for increase in the performance.

       

      So I'm curious whether I should punt CF off the server again and reinstall of if there are any detailed instructions for how to do these steps manually above?  Adding the entry to the filter area seems straightforward but the steps following that do not seem quite so defined.

       

      The issue I'm seeing which I think  is related to this is that my website doesn't redirect to the index.cfm if it's NOT on the URL.  I get access denied, so I'm thinking its that this process didn't get done correctly.


      Thanks for any thoughts.

      S

        • 1. Re: No TOMCAT listed in ISAPI Filter after CF10 install
          Anit_Kumar Adobe Employee

          Hi,

           

          srushing wrote:

           

          The issue I'm seeing which I think  is related to this is that my website doesn't redirect to the index.cfm if it's NOT on the URL.  I get access denied, so I'm thinking its that this process didn't get done correctly.

           


           

          Are you able to broswe to the pages, after adding index.cfm at the end of the url. If yes, then it can't be problem with CFM pages. It would be related to redirection to index.cfm.

           

          Regards,

          Anit Kumar

          • 2. Re: No TOMCAT listed in ISAPI Filter after CF10 install
            srushing Level 1

            Yes, if I include the /index.cfm on the URL i can run the application fine.  Login, interact with all the pages, etc.   I just didn't know if the fact I don't have TOMCAT listed in the ISAPI Filter page might be indicative of a installation issue.

             

            I have 3 sites on my server that do this, and 2 sites that work fine.  Scratching my head.  I can get around the issue by placing an index.html file with a javascript redirect to the fully qualified index.cfm URL and all works fine.  I just do not understand why this doesn't work they way it's supposed to.  All was fine before the install of CF10.

            • 3. Re: No TOMCAT listed in ISAPI Filter after CF10 install
              Anit_Kumar Adobe Employee

              Hi,

               

              Please ensure all of these IIS features are enabled:

              • ASP.NET
              • CGI
              • ISAPI Extensions
              • ISAPI Filters

               

              The Default Document list (this list will be created when the configuration is added) is mentioned in web.config file at C:\inetpub\wwwroot\. Just rename the web.config to web.config_old and restart IIS.

               

              Regards,

              Anit Kumar