4 Replies Latest reply: Mar 18, 2013 8:39 PM by jennbenn RSS

    fixing line break with hanging indent, tabs

    jennbenn Community Member

      Issue: InDesign sometimes squeezes the first line wordspacing instead of moving content to the next line (see red arrows) with hanging indent and nested style controlled by tabs in TOC. I believe this has something to do with the tabs. Changing the Justification settings (Adobe Paragraph Composer, Adobe Single-line Composer; and Minimum/Maximum Word/Letter Spacing) does not help.

       

      The current workaround is to insert a soft return at the end of the first line, but I'd like to avoid. Is there a better way to set this up?

       

      1. Paragraph style is set for hanging indent (left indent: 72 pt, first line indent: -72pt). This style also includes two tab positions.

      2. Number style (TOC #) is a character style.

      3. A nested style controls the position of the TOC number via two tab characters, which correspond to tab locations set in the paragraph style -- a right align tab for the number, and a left align tab for the text.

       

      Thanks in advance!

       

      InDesign CS5, Mac OS 10.7.5.

      hanging indent and nested style.jpg

        • 1. Re: fixing line break with hanging indent, tabs
          Peter Spier ACP/MVPs

          I'm not certain it's pertinent, but waht method have you used to drop the first tab and digit below the baseline?

          • 2. Re: fixing line break with hanging indent, tabs
            jennbenn Community Member

            Thanks for your quick response! Negative baseline shift is used to specify this in the Number character style.

            • 3. Re: fixing line break with hanging indent, tabs
              Peter Spier ACP/MVPs

              What happens if you don't use baseline shift?

               

              Can you show us the justificattion settings? Is hyphenation allowed?

              • 4. Re: fixing line break with hanging indent, tabs
                jennbenn Community Member

                If I don't use baseline shift for the TOC number style, the number aligns with the text baseline instead of at the text cap height as desired in the original post (the number is larger than the text). I initially tried using a drop cap for the number, but it seemed like the wrong approach for what I was trying to accomplish, with less control (the TOC number matches other items in the document).

                 

                Justification settings are shown in the revised image on the right. I tried using Word Spacing options of 100/100/100%, and Single-Line Composer, but neither changed the result.

                Hyphenation is not allowed. You can also see Letterspacing settings in the General Paragraph Style Dialogue box snippet (Style Settings) at the bottom.

                 

                After several additional hours, I have successfully fixed the problem, but I'm not sure what the culprit was exactly. Differences are highlighted on the attached images.

                • Drop Caps and Nested Styles dialogue box: Removed Character Style: TOC# from Drop Caps. It was set to 0.
                • Started from scratch with a new text box, unformatted text and a newly created style. (Changing the style sheet alone was not enough, nor was starting with unformatted text — there was something going on with the text box as well.)

                 

                I will report back if the issue crops back up. Thanks for your help and prompting me to dig a little deeper!

                 

                original.jpgrevised.jpg