6 Replies Latest reply on Mar 22, 2013 1:03 AM by rob_ashcroft

    Why does 'run as Administrator' fix my Silver Efex problem?

    rob_ashcroft Level 1

      I have had a problem with the Nik Software Silver Efex Pro (SEP) plugin running extremely slowly, but only at certain times. It's been pretty good for the past few months, but it suddenly took a nose-dive a few days ago. It takes ages to load the presets and to process the image in Photoshop once I have made my selections in SEP. I just thought that as SEP is a direct plugin to CS6 Photoshop then perhaps it's something to do with the way Photoshop itself runs. I switched the running of Photoshop to 'Run as administrator' (just right click the program in the start menu and go to compatability tab) and SEP now runs extremely fast. No problems at all. I also think (but have no way of measuring it) that Photoshop is running faster in general. Does anyone know why running as Admin should make such a difference? Are there any problems in running in Admin mode?

       

      I run Norton Internet Security, and thought that as I'm now OK in Admin mode it might be a virus-checker problem, and running in Admin mode was getting around the problem. I do have both versions of Photoshop (32 and 64 bit) incuded to 'allow' access in Norton.

       

      Here is my system config. My PC runs very well in all other respects.

       

      System Information

      ------------------

      Time of this report: 6/27/2012, 17:44:57

      Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)

      System Manufacturer: Acer

      System Model: Aspire M5811

      BIOS: Default System BIOS

      Processor: Intel(R) Core(TM) i5 CPU         650  @ 3.20GHz (4 CPUs), ~3.2GHz

      Memory: 12288MB RAM

      Available OS Memory: 12216MB RAM

      Page File: 5813MB used, 18614MB available

      Windows Dir: C:\Windows

      DirectX Version: DirectX 11

      DX Setup Parameters: Not found

      User DPI Setting: 120 DPI (125 percent)

      System DPI Setting: 96 DPI (100 percent)

      DWM DPI Scaling: Disabled

       

      ---------------

      Display Devices

      ---------------

      Card name: ATI Radeon HD 5570

      Manufacturer: Advanced Micro Devices, Inc.

      Chip type: ATI display adapter (0x68D9)

      DAC type: Internal DAC(400MHz)

      Device Key: Enum\PCI\VEN_1002&DEV_68D9&SUBSYS_E142174B&REV_00

      Display Memory: 2761 MB

      Dedicated Memory: 1006 MB

      Shared Memory: 1755 MB

      Current Mode: 1920 x 1080 (32 bit) (60Hz)

      Monitor Name: SyncMaster P2450H(Digital)

      Monitor Model: SyncMaster

      Monitor Id: SAM05CC

      Native Mode: 1920 x 1080(p) (60.000Hz)

      Output Type: DVI

      Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.d ll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

      Driver File Version: 8.17.0010.1114 (English)

      Driver Version: 8.930.0.0

      DDI Version: 11

      Driver Model: WDDM 1.1

      Driver Attributes: Final Retail

      Driver Date/Size: 12/6/2011 04:16:00, 933888 bytes

      WHQL Logo'd: Yes

      WHQL Date Stamp:

      Device Identifier: {D7B71EE2-2B99-11CF-A170-48C1BEC2C535}

      Vendor ID: 0x1002

        • 1. Re: Why does 'run as Administrator' fix my Silver Efex problem?
          Level 7

          Most likely just another bug in Nik's code.

          Check with them for updates.

          • 2. Re: Why does 'run as Administrator' fix my Silver Efex problem?
            rob_ashcroft Level 1

            Thanks, Chris. I know that it's probably something like that, or a problem with Norton. Running as Admin is probably just getting around whatever the problem is. The only trouble with these weird problems is they are so hard to pin down. I'm still puzzled as to why Photoshop seems much more responsive in Admin mode. But it might just be my perception of it running faster.

            • 3. Re: Why does 'run as Administrator' fix my Silver Efex problem?
              Noel Carboni Level 8

              I'm not saying Norton is your problem, but I haven't heard good things about Norton software in a long time, unfortunately.

               

              I always recommend Avast! antivirus to people.  The free version is very good in itself, and they offer a more comprehensive Internet Security version as well.

               

              I don't know how technically-oriented you are, but if you do understand how things work fairly well and have taken measures and adopted good practices to avoid running malware, there is the possibility of just shutting off UAC (MIcrosoft User Account Control) if its operation continually gets in the way of your completing your work.  Typically, most people just get in the habit of confirming whatever prompts come up anyway, which defeats most of the protection UAC can afford.

               

              -Noel

              • 4. Re: Why does 'run as Administrator' fix my Silver Efex problem?
                rob_ashcroft Level 1

                I just discovered something very weird. I normally invoke Photoshop (CS6) by going to Bridge and selecting an image and double-clicking it. CS6 will load and load the image I selected. If I then invoke the Silver Efex Pro (SEP) plugin (from within CS6 using the FILTER menu) it takes a nose-dive on performance and takes about 5 times as long to process. If however I load Bridge, then load CS6 manually from the taskbar (not in Admin mode) Ithe SEP process runs extremely fast. I just tried this several times and it's the same evey time - it works fine when I load CS6 manually.

                 

                Is there a difference or any issues around how Photoshop is loaded? Is Bridge perhaps failing to do something when it invokes CS6 for you?

                • 5. Re: Why does 'run as Administrator' fix my Silver Efex problem?
                  Mylenium Most Valuable Participant

                  As Noel said, your Norton software may contribute to your issue, but on a more general level these are probably simply local port issues that affect communication between the various processes. Both Bridge and SEP may unintentionalyl be using the same port connections and this creates a bottleneck. Naturalyl it won't happen when you launch PS outside such a local loopback connection because then eitehr never a port connection is even established or a different port may be used.

                   

                  Mylenium

                  • 6. Re: Why does 'run as Administrator' fix my Silver Efex problem?
                    rob_ashcroft Level 1

                    Thanks, Mylenium. I'll load it manually in future. I like your 'brief bio'