4 Replies Latest reply: Mar 21, 2013 11:41 AM by ConEmu.Maximus5 RSS

    Wierd problem with test movie AIR application




      I've got a very wierd problem with Test Movie (ctrl+enter) option on AIR applications. I've got Flash Professional CS5, but I've tested it on CS6 at it ends with the same effect.


      To reproduce this:


      Create new AIR application (Flash CS5 - Adobe AIR 2, CS6 - AIR)

      Save it where you want.

      Draw simple shape animation (this is to check if script worked)

      Add script on frame:

      "stop();" - it doesn't matter which frame.

      Test movie (hit ctrl+enter)

      flash starts building swf file, and when it completes "nothing" is happening.


      I typed "nothing" becouse flash is running adl.exe (in task manager appears proces adl.exe) but it looks like it is waiting for signal to show itself. The adl window appears only when I close Flash IDE.


      when I tried to test movie second time (without killing the adl process) i've got message:

      "Error creating SWF movie file.


      Be sure the destination file is not read-only or opened by another application. Also, check that the file name is not to long."


      It's obvious becouse the adl runned in background blocks the swf file.


      And the funniest thing - when you remove script it works fine.


      It looks like the scripts are making this problem - but I don't know why:


      For tests I added script "//" a blank line comment - with the same result,


      I tried this on Flash CS5 and Flash CS6, air sdk 2, 3.2, 3.4, 3.6 even i've downloaded newest flex sdk (4.6) - all with the same result.


      I've tested it on two different PC's with the same result. (both windows 7 x64)


      When I runned the adl from command line - it works fine - so swf and xml files are correct I think it is something between adl and flash IDE.

      About three monts ago it worked fine - so I think it could be some update that I've made in this time.


      I'll be greatful for any help.