2 Replies Latest reply on Aug 1, 2006 11:13 AM by SlickZ

    GoToNetPage

    SlickZ
      IHi everyone. I have been working on a project with Director MX 2004, and i have a problem with GoToNetPage script that only works in author mode. Does not work at all when published, and does not work on any machine that i have tried it on. Doesnt matter wether the user has IE, or Firefox, or netscape as their browser. I have searched the forums and found numerous posts, but none of them has helped me as of yet. I tried to use the "baOpenURL" but that doesnt even work. I got the plug in, tried to put it in my Xtras folder, and then go to script, but the script text is black, letting me know that its not going to work, and sure enough, DIrector has no idea of what im trying to do. Is there a specific folder to put the plug in into?ried putting it in Net Support, no luck. And do you have to put it in the Director Program Files Xtra folder, or your projects Xtra folder? I do appreciate anyones advice on this. Thank You.

      Chris
        • 1. Re: GoToNetPage
          Level 7
          Hi Chris,

          Are you trying to create a projector or a Shockwave file? From the way
          that you describe the problem, I'm guessing its a projector.

          Your Xtras folder is inside the Configuration folder that's inside the
          application folder. If you have a copy of buddyAPI then you can place it
          in there. But you really don't need it for this problem.

          You need to include the network xtras with your projector. You can
          either package the Xtras inside the projector, or you can create an
          Xtras folder and place copies of the needed Xtras into that folder. This
          folder needs to be next to, either the projector, or the Director movie
          is you are using a stub projector.

          Look in the online help for more information on how to work with Xtras.

          --
          Rob
          _______
          Rob Dillon
          Adobe Community Expert
          http://www.ddg-designs.com
          412-243-9119

          http://www.macromedia.com/software/trial/
          • 2. Re: GoToNetPage
            SlickZ Level 1
            Rob

            Thank you very much for your reply. That helped me out tremendously. It's working now. I was using the wrong plug-in. I didnt have buddy API xtra in the folder, I had one called OpenURL. Thank's again for helping me out.

            Very nice site you have by the way. I see you are in Pittsburgh. I Just got back from a visit there not too long ago, love that town. No relevance, just thought I share that with you.