1 Reply Latest reply on Mar 22, 2013 5:49 PM by chris.campbell

    firefox and flash player

    tattas

      trying to load farmville   don't know if it is the flashplayer or farmville but..... since i use firefox it is telling me to download the older 10.3   finally got that done.... now it tells me that will not work and wants to update to the 11   i am ready to pull my hair out!!!!