38 Replies Latest reply on Oct 16, 2017 4:18 AM by D Fosse

    Banding at magnification lower than 64%

    LeoNeon51


      Seriously I cant figure this out. When I'm viewing photo at zoom lower than 64% banding kicks in. At zoom higher than 63% everything smoothed out. It's giving me a hard time when I'm trying to retouch big files at lower magnification because actually I cant know until I zoom in do I'm removing something what exist or actually not!


      I know it's an issue regards do displaying preview of 16bit image as 8bit image. I was checking this in many ways and it appears only in 16bit mode. I'm quite a quality maniac so I always retouch in 16bit mode and ProPhoto color space to give myself a bit more room to play with post production.


      Please take a look at snaps made using windows snipping tool. All images are in ProPhoto color space but I also have tried this in RGB and it looks quite the same.


      1. With banding.

      16bit mode

      ProPhoto color space

      Zoom: 63%

      https://dl.dropbox.com/u/2234179/1banding.PNG

      1. Without banding.

      16bit mode

      ProPhoto color space

      Zoom: 64%

      https://dl.dropbox.com/u/2234179/1bandingno.PNG


      Can you guys let me know is it normal, does everybody suffers the way I am? If not how to fix it?


      I'm on windows 7 ultimate 64bit, 64GB memory, Intel I7 processor, geforec GTX680 GPU.


      Thnx.

        • 1. Re: Banding at magnification lower than 64%
          LeoNeon51 Level 1

          There is one more crazy think which I cant understand. Again would be great to know do other ps users have the same problems and it's impossible to fix it or there is a way.

           

          Banding in ProPhoto color space has some weird colors which doesn't appear in RGB.I have read on forum that disabling OpenCL and changing cache levels to 1 can halp. In my case it helps but only regards to banding colors in Prophoto, it doesn't make any difference when became to seeing banding when changing zoom.

           

          ProPhoto OpenCL Advanced

           

          https://dl.dropbox.com/u/2234179/prophoto_16bit_ogl_enabled_advanced.PNG

           

          ProPhoto OpenCl Basic

           

          https://dl.dropbox.com/u/2234179/prophoto_16bit_ogl_enabled_basic.PNG

          • 2. Re: Banding at magnification lower than 64%
            Noel Carboni Level 8

            You have a good eye.

             

            1.  Photoshop composites layers using a speed-optimized process on downsized 8 bit data for zoomed-out resolutions when the Cache Levels setting is 2 or higher in the Performance preferences.  Thus, at zoomed out sizes you see posterization.  You can force an egregious level of it with a couple of extreme curves operations.  A workaround, which comes with downsides, is to set your Cache Levels preference to 1, which forces all compositing to be done at full resolution.  This does work, and I use it when I do astrophotography processing myself, because I often use extreme Curves operations, but the downsides are 1) that it slows things down (maybe not a problem if you have a rompin' stompin' computer), and 2) that it may destabilize Photoshop and require you to work with the Basic drawing mode.

             

            2.  There is a long-standing bug in the color-management logic that Adobe runs in the GPU in Normal and Advanced modes, which gives rise to the slightly colored banding you see.  Adobe has known about this since way back, and as you have correctly shown, the problem does not exist in the Adobe Color Engine that runs in the CPU, which is what Basic mode causes.

             

            Since the CPU does more work that would normally be done in the GPU when you configure Basic mode, it may change the performance you see.  However, it's not bad and can represent a good workaround if the accuracy of what you see on your screen is highly important to you.

             

            -Noel

            • 3. Re: Banding at magnification lower than 64%
              Noel Carboni Level 8

              By the way just for clarity, OpenCL is not the same as OpenGL.  OpenCL is not involved in this.

               

              The key for the ProPhoto RGB workaround is that the color-management not be done in the GPU, but rather in the CPU, and using either Basic mode or disabling the use of the GPU entirely is what makes that happen.

               

              And it's also worth noting that these are both problems with the DISPLAY of your image in Photoshop while editing - they do NOT cause inaccuracies in the image itself, unless you're doing screenshots (which of course would be data that's been through Photoshop's color-management).

               

              -Noel

              • 4. Re: Banding at magnification lower than 64%
                LeoNeon51 Level 1

                Thnx Noel for your reply making it more clear for me.

                 

                Mostly bothers me problem with seeing posterisation at magnification lower than 64%. It is a problem when I do a skin retouch for example. On a big image I need to zoom out to see from a bigger perspective what I'm doing to the image and than I see posterization  don't knowing should I remove something or not ...

                 

                Even if I disable OpenCl and set cache levels to 1 it's steel happening. Problem appears in ProPhoto but as well in RGB (a bit less but steel). Your work around seems not working for me, is there any other?

                • 5. Re: Banding at magnification lower than 64%
                  conroy Level 5

                  LeoNeon51 wrote:

                   

                  Even if I disable OpenCl

                   

                  As Noel said, OpenCL has nothing to do with this.

                   

                  Go into the Advanced Settings for the graphics processor, found in Preferences > Performance, and set it to "Basic".

                   

                   

                  and set cache levels to 1 it's steel happening. Problem appears in ProPhoto but as well in RGB (a bit less but steel). Your work around seems not working for me, is there any other?

                   

                  In addition to using Cache Levels of 1, or even if you use more cache levels, try a low-level noise layer at top of stack. It can be made not visible when not required, such as when generating a file for print.

                  To make a noise layer...

                   

                  Create a new top layer with Overlay blending mode and fill it with 50% gray.

                   

                  If you use the New Layer dialog then never do a 16 bpc 50% gray fill with it because that creates RGB (16448, 16448, 16448) instead of the correct RGB (16384, 16384, 16384).

                   

                  Edit > Fill command is one way to get the correct 50% gray fill.

                   

                  Use Add Noise filter to add 25% uniform monochrome noise to the new layer.

                   

                  Reduce the new layer's opacity to about 5% then lock the layer so it cannot be accidentally disturbed. Remember, the layer should have Overlay blending mode.

                  • 6. Re: Banding at magnification lower than 64%
                    LeoNeon51 Level 1

                    I have already tried with advanced processor settings set to basic as well as cache levels set to 1. Noise doesn't help as well, I have tried this action http://nomorebanding.com/  and have played with noise in general but there is steel big difference in banding at different zooms.

                    • 8. Re: Banding at magnification lower than 64%
                      Noel Carboni Level 8

                      You need to restart Photoshop after making the settings changes, or you will not be testing what you think you're testing.

                       

                      -Noel

                      • 9. Re: Banding at magnification lower than 64%
                        LeoNeon51 Level 1

                        Seriously I would like it to work but as I sad it doesn't help in my case - or I'm steel missing something? You can see it appearing on the left and a bit under letter "e". On a skin usually it's a problem but even here it annoys me as those "artefacts" sometimes I don't know are there for real or not ...

                         

                        https://dl.dropbox.com/u/2234179/sample.PNG

                        • 10. Re: Banding at magnification lower than 64%
                          conroy Level 5

                          The noise layer doesn't help hide display banding when zoom is below 64% unless Cache Levels is 1. Are you absolutely sure that you set CL to 1 then relaunched Ps before testing the noise?

                          • 11. Re: Banding at magnification lower than 64%
                            LeoNeon51 Level 1

                            Yes, I'am. I was trying this few times. With graphic processor settings set to basic as well.

                             

                            https://dl.dropbox.com/u/2234179/sample2.PNG

                            • 12. Re: Banding at magnification lower than 64%
                              Noel Carboni Level 8

                              It's worth noting that the bike images you're posting are nearly black (the levels are in the single digits).

                               

                              If you're seeing posterization in them directly, without enhancement (e.g., via a Curves layer), could it be that your monitor is well out of calibration, and you're just seeing more in the shadows than you should be seeing?

                               

                              -Noel

                              • 13. Re: Banding at magnification lower than 64%
                                LeoNeon51 Level 1

                                Well, it could be a monitor calibration. I'm on Dell U2412M monitor which is not calibrated using any hardware, I have calibrated it using this site http://www.lagom.nl/lcd-test/black.php and here I cen see just small difference between background and the darkest square. On other side, when I flatten the image banding goes away. Please see below. When I lighten shadows a bit it's easier to see. Left image with banding at 50% zoom and the same image without banding at 66.67% zoom.

                                 

                                 

                                https://dl.dropbox.com/u/2234179/sample3.PNG at

                                • 14. Re: Banding at magnification lower than 64%
                                  Noel Carboni Level 8

                                  Sounds like your monitor is displaying the lowest luminance levels brighter than most - usually folks don't start seeing a difference until level 4 or 5; many can't see any squares in the first fow at all.  That your system is more sensitive to level changes at small values than most probably says your gamma response is a bit on the high side. 

                                   

                                  However, that still doesn't seem to describe why you should see a lower quality compositing of layers at zoomed-out resolutions.

                                   

                                  It could be a color-management issue somehow I guess...  Monitor color profiles have been known to be faulty.  Using the Windows Color-Management dialog, Devices tab, what profile is associated with your monitor?  Does anything different happen if you add the sRGB IEC61966-2.1 profile to the list and make it the default for your monitor?

                                   

                                  I have not seen, with Cache Levels 1, Photoshop show a difference in compositing quality between zoomed-out and 100% resolutions, but that doesn't mean it can't happen.  It may be specific to individual video drivers, and more complex under the covers than any of us give it credit for.

                                   

                                  -Noel

                                  • 15. Re: Banding at magnification lower than 64%
                                    LeoNeon51 Level 1

                                    Well, I don't see there any profiles. Please take a look below. My graphic drivers are up to date. I just have build my computer and bought a monitor...

                                     

                                    https://dl.dropbox.com/u/2234179/profile1.PNG

                                     

                                    https://dl.dropbox.com/u/2234179/profile2.PNG

                                     

                                    https://dl.dropbox.com/u/2234179/profile3.PNG

                                    • 16. Re: Banding at magnification lower than 64%
                                      Noel Carboni Level 8

                                      It's using the default sRGB IEC61966-2.1 profile already then, so that's probably not the issue.

                                       

                                      With my monitor calibration I can (barely) make out the level 1 square, and the level 2 square is just slightly more visible.  I don't sense a distracting level of banding in the images you posted up above unless I enhance your images quite a bit.

                                       

                                      If display accuracy is that critical to you, perhaps you might want to investigate what it would take to get 30 bit color (that's an extra 2 bits each for red, green, and blue).  With a full 30 bit signal path (i.e., where video card, cable, and monitor are capable of 30 bit color and the Photoshop 30 bit color setting enabled) the number of discrete levels of gray available goes from 256 to 1024.  I doubt you'd be able to sense those transitions.

                                       

                                      I just remembered something I had forgotten about...  As I recall the 13.1 Photoshop release had a bug in at least some of the color-management logic that could cause a slight inaccuracy and 2 level output jumps in what should be single level changes, effectively reducing your color capablity to 7 bits per color.  I wonder if you could be seeing that...  If you download this 16 bits/channel smooth gradient test file and load it into Photoshop, do you see evenly spaced level changes from center to edge?

                                       

                                      http://Noel.ProDigitalSoftware.com/temp/DarkGrayGradientTestImage.psd

                                       

                                      -Noel

                                      • 17. Re: Banding at magnification lower than 64%
                                        LeoNeon51 Level 1

                                        I have in plan to buy in near future a monitor for professional photographic purposes. I just keep fingers crossed it will help as on this stage I'm loosing faith in fixing this I will try 30bit but I wonder where is a problem? Could you post this link one more time? It's seems to be broken.

                                        • 19. Re: Banding at magnification lower than 64%
                                          LeoNeon51 Level 1

                                          I can see clearly every single step, just one in the center could be divided into two (maybe). Besides this I can also see that those steps are divided into four groups. Every group is a visible, bigger step.

                                          • 20. Re: Banding at magnification lower than 64%
                                            Noel Carboni Level 8

                                            I think we've nailed down the problem.  I don't know if it's a software issue or a hardware issue on your system, but the best possible performance would be where your system would display every single step with an equal jump in brightness, and there would be no appearance of grouping - the gradient would just be even all the way from corner to edge (I see it that way).  Where you see the groups divided up by what look like bigger steps, it's because there is a 2 level grayscale jump instead of a 1 level jump.

                                             

                                            My system displays that gradient all in one smooth transition, with 1 level jumps at every transition.

                                             

                                            Capture your screen showing that gradient, please, save it as a PNG, and post it here.  I will be able to tell you, by looking for 2 level jumps in your screen grab, whether the problem is occurring in the software or at your video card and monitor.

                                             

                                            I'm not that familiar with the settings in nVidia drivers, but as I recall there's a section for adjusting desktop color settings.  Have you changed any of the color controls there?

                                             

                                            -Noel

                                            • 21. Re: Banding at magnification lower than 64%
                                              LeoNeon51 Level 1

                                              Cool, looks like we getting somewhere Yes, I was playing with nVidia settings to adjust monitor gamma, contrast and brightness while looking on those images for monitor callibration which I linked before.

                                               

                                              https://dl.dropbox.com/u/2234179/nvidia.PNG

                                               

                                              Here's a capture in png format. I have market where I see those groups.

                                               

                                              Capturegrad.PNG

                                              • 22. Re: Banding at magnification lower than 64%
                                                conroy Level 5

                                                There is no 2-level jump in your screenshot.

                                                 

                                                I'm puzzled by your sudden appearance of banding when zooming at 63.75% or lower when Cache Levels is 1.

                                                 

                                                Please do the following:

                                                 

                                                Set Cache Levels to 1

                                                Set GPU mode to Basic (which shouldn't matter with sRGB, but do it anyway)

                                                Relaunch Photoshop

                                                Open the test gradient image

                                                Add a Curves Adjustment Layer with "Lighter" preset

                                                Zoom to 64%

                                                Grab screenshot

                                                Zoom to 63%

                                                Grab screenshot

                                                Post both screenshots

                                                 

                                                 

                                                My screenshots below show highly obvious banding appear at zoom 63% when Cache Levels is 4, but not when CL is 1.

                                                 

                                                 

                                                cl1-64.png

                                                 

                                                cl1-63.png

                                                 

                                                cl4-64.png

                                                 

                                                cl4-63.png

                                                 

                                                 

                                                In the distinctively banded screenshot, there is the same quantity of bands as the other screenshots, each band being 1 level different from its neighbours. However, each 4th or 5th band is so narrow that the appearance is very similar to a gradient with fewer steps and with level jumps of  1-2-1-1-1-2-1-1-2-1-1-1-2-1-1-2-1-1-……..

                                                • 23. Re: Banding at magnification lower than 64%
                                                  LeoNeon51 Level 1

                                                  So here it is. That banding steeps in groups I can see only on my monitor, even I see them in your images. I was checking this today on a another monitor and there are no grouping ...Single steps appears for me evenly distributed.

                                                   

                                                   

                                                  https://dl.dropbox.com/u/2234179/63.PNG

                                                   

                                                  https://dl.dropbox.com/u/2234179/64.PNG

                                                   

                                                  https://dl.dropbox.com/u/2234179/63c4.PNG

                                                   

                                                  https://dl.dropbox.com/u/2234179/64c4.PNG

                                                  • 24. Re: Banding at magnification lower than 64%
                                                    Noel Carboni Level 8

                                                    I agree that there are not multi-level jumps in LeoNeon51's screen grab, which says that digitally the data is clean.

                                                     

                                                    Seems to me we have potentially two issues here that conpsire to make the banding visible.

                                                     

                                                    1.  The 8 bit lower-quality compositing that occurs with cache levels > 1 at zoomed-out magnifications.

                                                     

                                                    2.  An issue where the monitor signal is being quantized between the video card and monitor somewhere.

                                                     

                                                    LeoNeon51, do you have the 30 bit color setting enabled?  It's possible that might help, as it instructs the video card to do higher accuracy work.  But that's dependent on specific hardware and driver capabilities.

                                                     

                                                    EDIT:  I just saw the response you submitted while I was typing, LeoNeon51.  Try the 30 bit color setting.

                                                     

                                                    Also, how do you have your video card cabled to your monitor?  Different signal paths have different characteristics, and you may have capabilities you're specifically not taking advantage of.

                                                     

                                                    -Noel

                                                    • 25. Re: Banding at magnification lower than 64%
                                                      conroy Level 5

                                                      OK, your screenshots make it clear that something is peculiar about your system.

                                                       

                                                      You are correctly getting good gradients when zoom is 64% regardless of Cache Levels setting, and correctly getting a poor gradient when zoom is 63% and Cache Levels is 4.

                                                       

                                                      You are incorrectly getting the poor gradient when zoom is 63% and Cache Levels is 1. The failure of CL 1 to be effective in your system explains your frustration with the bike image and the failure of a noise layer to hide display banding when zoomed out.

                                                      • 26. Re: Banding at magnification lower than 64%
                                                        conroy Level 5

                                                        Noel Carboni wrote:

                                                         

                                                        The 8 bit lower-quality compositing that occurs with cache levels > 1 at zoomed-out magnifications.

                                                         

                                                         

                                                        Yes, something is definitely wrong when Cache Levels 1 is failing to give LeoNeon51 full-quality compositing when zoom is 63.75% or lower.

                                                        • 27. Re: Banding at magnification lower than 64%
                                                          LeoNeon51 Level 1

                                                          Trust me it's a nightmare to work with this issue. I have to flatten image all the time to see what's happening.

                                                           

                                                          I'm using DVI cable. In my nVidia settings I have color depth set all the time to 32-bit, monitor is set to true color (32 bit). Now I just have switched in Photoshop to 32bit by going to image -> mode -> 32bit per channel. By doing this switch to 32bit in Photoshop I have fixed an issue with banding. Now it looks the same on all zooms but I don't know anything about working in 32bit. Probably is a lot slower but the worst is that there is no curves option available and some filters ... I just cant work without curves Anyway so now we know something more, it's working on 32bit mode but how to make it work on 16bit mode?

                                                           

                                                          ps: I was checking this with exposure adjustment layer.

                                                          • 28. Re: Banding at magnification lower than 64%
                                                            conroy Level 5

                                                            Yes, 32-bit mode always uses full-quality compositing as far as I've noticed, but a great many tools, adjustments and filters are unavailable in that mode.

                                                            • 29. Re: Banding at magnification lower than 64%
                                                              Noel Carboni Level 8

                                                              I'm not familiar with your particular hardware, but my current theory is that your video card and monitor, to achieve the calibration you desire, is limiting the range of signals to a set smaller than the maximum possible range from 0 to 255 for each of the three colors, so some levels simply cannot be displayed.  In short, you're getting slightly less than 24 bit color.  This causes 2 level jumps between certain adjacent colors. 

                                                               

                                                              This alone might be tolerable, but in addition, some part of the color-managment logic within your setup is also conspiring to cause 2 level jumps between certain colors, and possibly these are combining so that you see a 3 level jump in certain cases.

                                                               

                                                              That said, I have Dell monitors (older ones) connected via DVI and I don't see any multiple level jumps in a gradient that runs all the way from black to white - and I do use my display driver settings to calibrate.  This might be a difference between ATI and nVidia, or just the particular choices we've made in hardware.

                                                               

                                                              Did you see the problem before changing the display driver calibration settings?

                                                               

                                                              Just to be certain your system is using the sRGB IEC61966-2.1 profile, you could try adding it and making it the default in the Devices tab of your OS color-management dialog.

                                                               

                                                              Do you have the ability to connect the monitor to the video card by DisplayPort or HDMI?  It might be worth seeing if that uncovers more capability than DVI.

                                                               

                                                              I assume you tried the 30 bit color setting (making sure to restart Photoshop after setting it) and saw no improvement.

                                                               

                                                              -Noel

                                                              • 30. Re: Banding at magnification lower than 64%
                                                                LeoNeon51 Level 1

                                                                Regards to the cable. There is only DVI option as my monitor can be connected only by DVI or VGA. VGA is old and my card doesn't support it. Monitor doesn't have HDMI port.

                                                                 

                                                                Actually I'm using two monitors. One is really old, DELL 2407WFP and newer DELL U2412M. On booth problem appears so it could mean that monitors are ok and there is a problem with graphic card or some system settings. I will uninstall all graphic drivers and install older versions to see if it changes anything. I have also been changing nVidia settings do default and it haven't helped.

                                                                 

                                                                Photoshop set to 30bit doesn't change anything :/


                                                                • 31. Re: Banding at magnification lower than 64%
                                                                  LeoNeon51 Level 1

                                                                  I have uninstalled and installed drivers from an original GTX 680 CD. It doesn't help, I have tried three version of drivers. What I have found out is that "grouping" of steps in gradient is caused because of changing contrast, brightens and gamma in nVidia settings. It it's set to default than groping doesn't happen. Problem with banding at magnification lower than 64% steel appear :/

                                                                   

                                                                  I have also set in color management sRGB as a default profile. No changes.

                                                                   

                                                                  profile.PNG

                                                                  • 32. Re: Banding at magnification lower than 64%
                                                                    conroy Level 5

                                                                    Leo, in case you return to this thread, your failure to get Cache Levels 1 behaviour despite the setting in Preferences could be explained by the following quote from thread http://forums.adobe.com/message/5255798?tstart=0#5255798

                                                                     

                                                                     

                                                                    Chris Cox wrote:

                                                                     

                                                                    There is a bug with the cache level preferences on Windows.

                                                                    Try changing it in the 32 bit app, then quit and relaunch the 64 bit app.

                                                                     

                                                                    • 33. Re: Banding at magnification lower than 64%
                                                                      LeoNeon51 Level 1

                                                                      Thnx for info.

                                                                       

                                                                      I have noticed a while ago that trick witch cache level set to 1 works but only with 32bit ps version. For me it doesn't make any difference, whatever I do it always doesn't work with 64bit.

                                                                      • 34. Re: Banding at magnification lower than 64%
                                                                        ジョルダーノ

                                                                        Updated to CC 2017, and the bug is still there. Besides, I can't set the cache levels lower than 2.

                                                                        Not bad for a graphics software.

                                                                        • 35. Re: Banding at magnification lower than 64%
                                                                          postrophe Level 4

                                                                          Hi @giaponese

                                                                           

                                                                          You might get more help about this matter by starting your own thread/post, because this one is kinda 3 years old, and many things have changed since then.

                                                                           

                                                                          Also, when you post, please supply pertinent information for quicker answers.

                                                                          The more information you supply about your situation, the better equipped other community members will be to answer. Consider including the following in your question:

                                                                          Adobe product and version number.

                                                                          Operating system and version number.

                                                                          The full text of any error message(s).

                                                                          What you were doing when the problem occurred.

                                                                          Screenshots of the problem

                                                                          Computer hardware, such as CPU, GPU, amount of RAM.

                                                                          Pierre

                                                                          • 36. Re: Banding at magnification lower than 64%
                                                                            ジョルダーノ Level 1

                                                                            Thank you Pierre for your message,

                                                                            I didn't start a new thread because I also wanted to point out that, even after 3 years have passed, the bug still persists.

                                                                            There isn't much to add to the info that the original poster supplied, the problem (banding) is exactly the same and my configuration is pretty similar:

                                                                            I'm on windows 7 ultimate 64bit, 32GB memory, Intel I7 2600K processor, geforce GTX770 GPU.

                                                                             

                                                                            And being on windows, I cannot even try the fix suggested in (32.)

                                                                            • 37. Re: Banding at magnification lower than 64%
                                                                              julianc76180794

                                                                              After lots of forum threads and experimenting, I have finally found the answer for me.

                                                                               

                                                                              Inside my NVIDIA Control Panel I changed the dynamic range to full - which removed all banding.

                                                                               

                                                                              2017-10-16_20-27-22.gif

                                                                              • 38. Re: Banding at magnification lower than 64%
                                                                                D Fosse Adobe Community Professional & MVP

                                                                                Julian, the "limited" setting is for video, where blacks are clipped to level 16 and whites are clipped to 235. This is not a setting you should ever! use for normal editing, and if you had it there you most certainly would have had problems.

                                                                                 

                                                                                BTW, I noticed something in Noel Carboni's last post (I wasn't there at the time):

                                                                                I'm not familiar with your particular hardware, but my current theory is that your video card and monitor, to achieve the calibration you desire, is limiting the range of signals to a set smaller than the maximum possible range from 0 to 255 for each of the three colors, so some levels simply cannot be displayed.  In short, you're getting slightly less than 24 bit color.  This causes 2 level jumps between certain adjacent colors.

                                                                                 

                                                                                Yes. This happens with video card calibration, if you use the video LUT to knock down brightness. This reduces the available bit depth. If your display is at 240 cd/m², and you set calibrated brightness to 120 - that's one bit off right there, and you're left with 7.

                                                                                 

                                                                                You should always use the monitor's OSD controls to get as close as possible to your targets first. That applies both to brightness and white point color (and black point for that matter). The video LUT should do as little as possible, only what you can't achieve manually in the OSD.