1 Reply Latest reply on Nov 5, 2007 8:19 PM by yoav@cyteam.com

    After Fressh Install Program Crush

    yoav@cyteam.com Level 1
      Hi,
      I just downloaded and installed the Flex Builder 3 Beta, windows version. Installation was successfully, as I checked in the log file.
      I don't have eclipse installed ( Version 2 of Flex Builder seemed to load and run OK )
      However when I tried to start the App it crushes on initialization with the following info in the log file:
      !SESSION 2007-11-01 16:05:29.531 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_11
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.equinox.app 2007-11-01 16:05:33.109
      !MESSAGE Product com.adobe.flexbuilder.standalone.product could not be found.

      !ENTRY org.eclipse.osgi 4 0 2007-11-01 16:05:33.125
      !MESSAGE Application error
      !STACK 1
      java.lang.RuntimeException: No application id has been found.
      at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer. java:229)
      at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:92)
      at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:129)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064)
      at org.osgi.util.tracker.ServiceTracker$Tracked.track(ServiceTracker.java:1042)
      at org.osgi.util.tracker.ServiceTracker$Tracked.serviceChanged(ServiceTracker.java:967)
      at org.eclipse.osgi.framework.internal.core.FilteredServiceListener.serviceChanged(FilteredS erviceListener.java:94)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.dispatchEvent(BundleContextImp l.java:1224)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
      at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue. java:141)
      at org.eclipse.osgi.framework.internal.core.Framework.publishServiceEventPrivileged(Framewor k.java:1603)
      at org.eclipse.osgi.framework.internal.core.Framework.publishServiceEvent(Framework.java:157 8)
      at org.eclipse.osgi.framework.internal.core.ServiceRegistrationImpl.<init>(ServiceRegistrati onImpl.java:103)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.createServiceRegistration(Bund leContextImpl.java:657)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.registerService(BundleContextI mpl.java:609)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.registerService(BundleContextI mpl.java:675)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:359)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1169)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1144)

      !ENTRY org.eclipse.osgi 2 0 2007-11-01 16:05:33.156
      !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2007-11-01 16:05:33.156
      !MESSAGE Bundle update@plugins/org.eclipse.jdt.junit_3.3.0.v20070606-0010.jar was not resolved.
      !SUBENTRY 2 org.eclipse.jdt.junit 2 0 2007-11-01 16:05:33.156
      !MESSAGE Missing required bundle org.eclipse.jdt.ui_[3.3.0,4.0.0).
      !SUBENTRY 1 org.eclipse.osgi 2 0 2007-11-01 16:05:33.156
      !MESSAGE Bundle update@plugins/org.eclipse.jdt.launching.macosx_3.1.100.v20061211.jar was not resolved.
      !SUBENTRY 2 org.eclipse.jdt.launching.macosx 2 0 2007-11-01 16:05:33.156
      Any ideas ?

      Thanks,

      Yoav