16 Replies Latest reply on Jan 21, 2016 1:25 AM by Willam van Weelden

    RoboHelp 10 WebHelp search feature not working?

    jamesm0671

      Hi all,

       

      I am using the Adobe Technical Communication Suite 4 and cannot get RoboHelp 10 to generate a WebHelp product with search capabilities.

      I have created a RoboHelp 10 WebHelp project and imported FrameMaker 11 files.

       

      Everything seems okay, but when I search in Internet Explorer 10, nothing happens.  I can even be on the same page as a term and enter the term in the box,

      but then nothing happenns. I also tried:  Opera, Firefox, Chrome and Safari browsers and still no results in the WebHelp search results.

       

      Actually, I get one word by default and that word is:  "null".

       

      Any idea on what is causing this?  I have a deliverable due soon, and I need to get this search capability working.

       

      Thanks in advance for your suggestions.

       

      I am using the latest patch too - RoboHelp 10.0.0.287

       

      Regards,

       

      Jim

        • 1. Re: RoboHelp 10 WebHelp search feature not working?
          Jeff_Coatsworth Adobe Community Professional & MVP

          Sounds like you have your JavaScript controls set really high - search uses JavaScript to do the work. Are you seeing any other issues?

          • 2. Re: RoboHelp 10 WebHelp search feature not working?
            jamesm0671 Level 1

            Hi Jeff,

             

            Thanks for the reply.  I am not sure if it is Java, although I did download Java to make sure I had the latest update.  I am running on a Windows 7 64 Bit Dell Laptop with Adobe TCS 4.

             

            I just saw a different post - but related to this post on the topic and I think it has to do something with the XML files that are created during the normal generation process.

             

            I have a feeling that there is something wrong with my XML files and the reason I say that is because I can generate one of the sample RoboHelp projects to WebHelp and then use IE 10 to search and the results
            come up right away, but when I do a WebHelp generate on my project the search does not work.

             

            Here is that related thread:

             

            http://forums.adobe.com/thread/798369

             

            Search Error: Failed to initialize database

            Mar 1, 2011 12:33 PM

             

             

            That thread dealt with RoboHelp 8 and I am using RoboHelp 10, but I think the problem is probably the same.

             

            My questions are as follows:

             

            1. I have a customer deliverable on Monday with several hundred files and a search mechanism that does not work at all.  Can I copy the search mechanism from the sample project and then put it into my project?
              Are the XML files generic or specific to each project?
            2. How many XML, Javascript and other RoboHelp type files are used to make the search functionality work?  I was thinking of populating one of those sample files, that has already been started with my files to see if that would get things going in the right direction - with the idea of removing all the sample files from that project and replacing them with my files, but, I have over 400 files, including references to foldout drawings and vendor manuals (baggage files) and it would probably take too much time to make that happen.

             

             

            With that said, if you or anyone else has ideas on how I could get this search engine working, I would really, really appreciate it.

             

            My current file structure is like this:

             

            Main Project Folder

                !ScreenLayout

                My Project File1

                My Project File2

                My Project File3

                resource

                whdata

                whgdata

                whxdata

                Frnt_Cov.htm

                Frnt_Cov_csh.htm

                Frnt_Cov_rhc.htm

                All RoboHelp graphics, javascripts and .htm files

             

             

            There does NOT seem to these folders that are in the sample:

             

            !Language!

            !SkinSubFolder!

            !SSL!

             

            The !ScreenLayout! folder is the only one present.  Does this have anything to do with only having MultiScreen HTML5 and WebHelp (Primary Layout) for my project settings?

             

            Again the most notable difference I see, is between the folders NOT included in my project (!Language!, !SkinSubFolder! and !SSL!).  I am not sure why these folders are not included in WebHelp.

             

             

            Thanks for taking the time to read this, as well as for any suggestions that can be offered.  I really need to get the search feature working by tomorrow.

             

            Regards,

             

            Jim

            • 3. Re: RoboHelp 10 WebHelp search feature not working?
              Captiv8r Adobe Community Professional & MVP

              Hi Jim

               

              You would most definitely NOT want to copy content from the sample project to the live project. When WebHelp is generated, the search part of  the content is broken up into the little "byte size" segments and many XML files are created. So the number and content of XML files from project A will differ from project B, as different words were used and the words are on different pages that are likely named totally differently. What would ensue would be a broken mess.

               

              It would likely prove helpful if you could use ScreenR or Jing or SnagIt to record a video of you stepping through the process and showing us the different settings you have enabled in the Single Source Layout recipe. Then post the link to view the video here.

               

              That might reveal something you are overlooking that we might notice.

               

              Cheers... Rick

              • 4. Re: RoboHelp 10 WebHelp search feature not working?
                jamesm0671 Level 1

                Hi Rick,

                 

                Thanks for the words of wisdom and the suggestion.  Unfortunately, I cannot share this type of data.  I could probably put together some dummy data, but right now I am up against a Monday 8AM deadline and it does not look good here at the moment.

                 

                I had seen in the past where it was suggested to uninstall and reinstall RoboHelp 10, and I would consider doing that, but now I know that I can generate a sample project and make it searchable.  Also now, I just did a generic LoremIpsum one topic, added in one of my FrameMaker files and now that is searchable too.

                 

                Based on this new discover, my question now becomes:

                 

                Can I take all the existing (topic) folders that contain the graphics and .htm files (in other words the original FrameMaker content) and copy it to a new test directory on my C drive and then somehow get the TOC to read in that data,

                as if it was imported into that folder using the normal File>Import process?

                 

                That would be great if I could do that, as it will save me having to redo it all from scratch again - not knowing if the search will suddenly stop working.

                 

                Also, I have been creating TOC books and then dragging the topics up from the topic list and putting them into my TOC structure.  Is there a way to get at the file that contains the TOC information, so that I can do a find and replace on my original TOC?  My original TOC is based on the physical file name of the file and I need it to be based on the Heading on the first page of each of these files.  I know this is probably a question for another post, but thought I would throw it in while I had your ear.

                 

                Thanks again for the suggestions.

                 

                Jim

                • 5. Re: RoboHelp 10 WebHelp search feature not working?
                  jamesm0671 Level 1

                  Hi all,

                   

                  It looks like I have it working at the moment, with a new project.  This time around, I did not delete all the Single Source Layouts from the pod, but left them there with WebHelp as Primary Layout.

                  I am not sure if that had any thing to do with it or not, but I am early in the game trying to re-add in 400 files.

                   

                  There may be a breaking point, such as when I was trying to live link back to FrameMaker files (400 of them earlier last week) and my CPD reached a very high number causing RH to give me a database error, and all the links I had established (more or less broken).  That process involving backing up often, but still the CPD caused so many problems that I abandoned that single source link approach and have gone the route of importing FrameMaker files into a RH project.  And now, I am dealing with the issue with search engine functionality in WebHelp output.  Well, for now, it is now working, but I am not sure if that will be the case after I have imported everything into the project (FM files and PDF baggage files).

                   

                  As you can imagine, I have not been to happy with Adobe RoboHelp 10 this past week.  Anyway, I digress.  Thanks for the feedback in these forums and perhaps the issues I have seen will help someone else out with the same problem, or maybe the root cause of the bug will be chased down and removed.

                   

                  Thanks,

                   

                  Jim

                  • 6. Re: RoboHelp 10 WebHelp search feature not working?
                    Peter Grainge Adobe Community Professional (Moderator)

                    Have you tried going into Tools > Options and ticking the Clear Cache option? That deletes the CPD file before opening any project and ensures it does not get bloated.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                     

                    @petergrainge

                    • 7. Re: RoboHelp 10 WebHelp search feature not working?
                      jamesm0671 Level 1

                      Hi Peter,

                       

                      I was not aware of that option, I will check it out today.

                      I was supposed to deliver a product today, but the search function is broken.

                       

                      I get the "Failed to Initialize Database" if I click on the Search box first thing (in WebHelp).

                      Other than that, if I run a search, I always get the "null" response.

                       

                      Actually, I had it working up to a certain point, but with all 400 of my chapter files in the project and all the baggage files (PDFs) added to the project - well RH did not like something.

                       

                      It is critical that I get this search feature working as soon as possible.  Thanks for this suggestion and any others you can provide.

                       

                      Regards,

                       

                      Jim

                      • 8. Re: RoboHelp 10 WebHelp search feature not working?
                        Peter Grainge Adobe Community Professional (Moderator)

                        Have you tried generating to a new folder? See this thread. http://forums.adobe.com/message/4864208#4864208

                         

                        Also search on Failed to Initialize Database in the RoboHelp HTML and WebHelp forums.

                         


                        See www.grainge.org for RoboHelp and Authoring tips

                         

                         

                        @petergrainge

                        • 9. Re: RoboHelp 10 WebHelp search feature not working?
                          jamesm0671 Level 1

                          Hi Peter,

                           

                          Thanks for the reply.

                          I had one of software developers dig into the output code.

                           

                          He said that the "whxdata/whfts.xml" files appears to be missing
                          and I guess that is used for FTS or Full Text Search.

                           

                          A couple times when trying to get this WebHelp project to output correctly, I would see a .FPJ error, but it would successfully complete the process.  Perhaps that somehow broke the search capabilities.

                           

                          I am going to run through and develop a fresh WebHelp project from my FrameMaker files and baggage files and save the component after each batch of files, so that I have a log of when the error might get induced.

                           

                          Thanks,

                           

                          Jim

                          • 10. Re: RoboHelp 10 WebHelp search feature not working?
                            jamesm0671 Level 1

                            That is a great link you sent.  I would say I am having similar issues.

                            Hopefully, I can copy and paste any missing js files and fix the broken search feature.

                             

                            Thanks,

                             

                            Jim

                            • 11. Re: RoboHelp 10 WebHelp search feature not working?
                              Shishirjerry

                              Hi Peter,

                               

                              I am also facing this issue, where the whfts files are not getting generated for both the Webhelp and Webhelp Pro outputs. Earlier I too was getting this "Error: Failed to initialize database" error, but after reinstalling Robohelp, I am facing a different problem. The package_xml files are getting generated, because of which I am not getting this error, but the whfts_xml files are not, due to which I am not able to search any topic. Whenever I search a term I recieve "Topic not found error".

                               

                              Please let me know how to resolve this problem.

                               

                              Regards,

                              Shishir

                              • 12. Re: RoboHelp 10 WebHelp search feature not working?
                                cquesada27 Level 1

                                Tried to contact Adobe RH support to no avail.

                                 

                                Version: RoboHelp 10 (recent upgrade from RH 9)

                                 

                                Issue: When I generate output locally, click Search, I get "null" in the results pane. I tried with an existing project (sample), a new project. A colleague on RH9 generated her project, tested the help and it worked fine. I took the same project, upgraded it to 10, generated the help, and again got the "null". Result.

                                 

                                This is from the log:

                                Processing Full-text-search data...

                                 

                                 

                                Finished processing Full-Text-Search data in 0 sec(s)

                                From the browser, I get an "error on page" with the following:

                                Webpage error details

                                 

                                User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

                                Timestamp: Thu, 12 Sep 2013 23:47:26 UTC

                                 

                                Message: Invalid character

                                Line: 1

                                Char: 1

                                Code: 0

                                URI: file:///C:/Program%20Files/Adobe/Adobe%20RoboHelp%2010/RoboHTML/Samples/en_US/Salesbuilde r/SalesbuilderProject/!SSL!/WebHelp/developers/whxdata/whfts_xml.js

                                 

                                 

                                I've searched this forum and other Google searches.

                                 

                                Anyone experience this and/or have a solution?

                                 

                                thanks,

                                Claudia

                                • 13. Re: RoboHelp 10 WebHelp search feature not working?
                                  Jeff_Coatsworth Adobe Community Professional & MVP

                                  @cquesada27 - Sorry, did you say you had tried with a brand new project? Was the whxdata\whfts_xml.js file present in a brand new dummy project?

                                  • 14. Re: RoboHelp 10 WebHelp search feature not working?
                                    charles.c

                                    Late to the party but just had an experience that may assist.

                                     

                                    Using RH9 and realized that for the last month or so fulltext search was no longer being generated. Instead I got the dreaded "finished in 0 sec(s)."

                                     

                                    Eventually I realized that MSXML 4 had been removed from my workstation.

                                     

                                    I added the 3 required files to SysWOW64 (msxml4.dll, msxml4a.dll, msxml4r.dll) and I registered msxml4.dll using regsvr32 (only this one needs registering).

                                     

                                    Presto - FTS is back.

                                     

                                    It seems that in RH9 at least, the FTS generator requires this specific version of msxml while all the rest of the product is happy with one of the other versions that were already present (3 and 6).

                                    • 15. Re: RoboHelp 10 WebHelp search feature not working?
                                      matthewdorma Level 1

                                      Hi Charles,

                                       

                                      I am having that same issue (full text search not working) on only SOME of the computers that we use. Furthermore, it appears to be working fine on Chrome, but not at all on some of the IE11 computers. Text constantly says "Searching 0%" and comes up with no results.

                                       

                                       

                                       

                                      Where can I go to download MSXML 4?