7 Replies Latest reply on Dec 14, 2014 9:17 AM by drimi

    Can't install latest Flash version v11.6

    bigDuh

      Failed install of latest Adobe Flash on Mac OS 10.8.3   Installer says to "quit Safari" but Safari is NOT open.  I normally use Firefox of Google Chrome.  Please help.

        • 1. Re: Can't install latest Flash version v11.6
          Sunil_Bhaskaran Adobe Employee

          There is a chance that Safari is running in the background.

          Could you please go to Applications > Utility and then double-click Activity Monitor.

          See if there is any process of Safari. If yes, select it and click Force Quit.

           

          Thanks,

          Sunil

          • 2. Re: Can't install latest Flash version v11.6
            Evan (from Manhattan) Level 1

            I am all-of-a-sudden now having the exact same problem installing Flash.  It will not install, saying that Safari is open, when it is not.

             

            Indeed, I have closed down every single browser, iTunes, iPhoto etc., and Flash still keeps mistakenly saying that Safari is open.  And, yes, I checked Activity Monitor and there is no Safari process running at all.

             

            Does anyone from Adobe (or elsewhere) have a fix for this Flash installation bug?

             

            Thanks!

             

            Best regards,

            Evan Katz

            (New York)

            • 3. Re: Can't install latest Flash version v11.6
              Evan (from Manhattan) Level 1

              Q:  Did you reboot your Mac?  I can't do so now (in the middle of too much stuff), but please let me know if you tried rebooting.  Thanks.

              • 4. Re: Can't install latest Flash version v11.6
                Evan (from Manhattan) Level 1

                *** PROBLEM SOLVED! ***  

                 

                I have solved the problem, at least on my system.

                 

                After rebooting did NOT solve the problem, I figured out the solution by quickly realizing which programs I run on my Mac (on which Flash would not install) and on my wife's Mac (on which Flash installed just fine).

                 

                And, after doing so, and also thinking about the types of programs that might use some Safari or other browser code, I found the "culprit", which was/is FIPLAB's otherwise excellent MenuTab Pro for Facebook, and which runs automatically, by default, on my Mac (but not also on my wife's Mac).

                 

                And when I closed MenuTab Pro, Adobe Flash installed perfectly.  And then I could restart MenuTab Pro.  So, as Inspector Clouseau used to say, "Problem Sol-ved"!  

                 

                Question for bigDuh (the original poster of this problem):  Are you too running a FIPLAB program?  If so, does the above solution work for you too?

                • 5. Re: Can't install latest Flash version v11.6
                  julianpearcey

                  Good detective work - Menu Tab Pro stops the installation, although Adobe is not able to tell the unsuspecting user what's wrong. What a waste of time and energy. At least the Adobe Community sorts out this sort of thing. The problem hasn't gone away on OS X 10.9 either.

                  • 6. Re: Can't install latest Flash version v11.6
                    Mike M Level 6

                    Because MenuTab connects to facebook, it will keep a process (and an active connection - using Flash) open for Safari of Firefox, depending on which is your default browser. 
                    I'd never know this because I've been banned (by IP address) from Facebook for not providing them (and likely the NSA) with a cell phone number in order to keep my account open, so I don't use Menu Tab.

                    • 7. Re: Can't install latest Flash version v11.6
                      drimi

                      solved:

                      1,quit all apps

                      2. restart your machine, uncheck "open all windows when login"

                      3. first thing you do open the flash adobe installer (you downloaded before)

                       

                      have fun