3 Replies Latest reply on Apr 14, 2013 8:12 PM by Sham HC

    Error while processing /libs/commerce/content/import.html

    marouanenent

      hello every body;

      I wanna import a catalog from hybris to cq5, I fill the form when I click import catalog; it gives me this error:

      Error while processing /libs/commerce/content/import.html

      thanks for your help;

        • 1. Re: Error while processing /libs/commerce/content/import.html
          Sham HC Level 7

          Hi marouanenent,

           

            Please let us know which version of

                *  CQ

                *  Hybris package you are using

                *   What is the calue of property jsLibs @ /etc/importers/hybris

               

          Thanks,

          Sham

          • 2. Re: Error while processing /libs/commerce/content/import.html
            marouanenent Level 1

            thanks sham;

            ok; it's resoleved now, it was a problem in the version of cq,i was using cq5.4,it dosn't work with this version;

            but I have an other problem here where I imported a catalog from hybris; the function getProductPrice(product) doesn't work;in the file /apps/geometrixx-outdoors/components/nav_products/listitem_product.jsp

            i the line: final String price = session.getPriceInfo(product); anit gives me the error:

             

             

            Caused by: java.lang.NullPointerException

                      at com.adobe.cq.commerce.hybris.impl.HybrisSessionImpl.getProductPriceInfo(HybrisSessionImpl .java:184)

                      at com.adobe.cq.commerce.hybris.impl.HybrisSessionImpl.getProductPrice(HybrisSessionImpl.jav a:211)

                      at com.adobe.cq.commerce.hybris.impl.HybrisSessionImpl.getProductPrice(HybrisSessionImpl.jav a:207)

             

            thanks for your help;

            • 3. Re: Error while processing /libs/commerce/content/import.html
              Sham HC Level 7

              Hi marouanenent,

               

                  AFAIK the latest package should have Patched PriceInfo to handle null prices which are not specified in products.

                  If you are using 5.6 please make sure right version of package is used. If you are using right hybris package please file a daycare to troubleshoot the issue. 

                 

              Thanks,

              Sham