3 Replies Latest reply on Apr 4, 2013 3:51 PM by stokesbento

    Default Publish folder

    stokesbento

      Hi all!

       

      currently,

      any publishing defaults to publish/web.  I want to change the name of this "web" folder on a default basis. Is there any way I can do this?

       

      Here's what I have tried. I can choose a new folder with my new name and it will publish to this folder. However, if I save the edge file with this new Publish path, Edge refuses to open the .an file again. It tells me I'm missing the html file even thought it's in there.

       

      Thanks for your help.

        • 1. Re: Default Publish folder
          elainecc Adobe Employee

          Hi, stokesbento-

           

          I was just about to answer your last question, but the post disappeared... anyway, you should be able to change the directory name in your publish settings dialog.  Don't resave your file into the new folder; the best thing for you to do is to keep your save and publish directory separate.  Whenever you're ready to update those files, just select "File" > "Publish" and your new output files will be saved to the destination directory.

           

          targetdirectory.png

           

           

           

          -Elaine

          • 2. Re: Default Publish folder
            stokesbento Level 1

            Thank you Elaine,  I guess what I'm saying is that once I have changed the target directory as you mention above, I can no longer hit save on my current .an file as it won't open again.   I need to save the current .an file because I use it as a template that's used over and over again.

            • 3. Re: Default Publish folder
              stokesbento Level 1

              As I continue to look at this I do believe there's a bug in EDGE. Anytime I change the path in publish to web, my .an file no longer sees it's .html equivelent if I save it and reopen it. I know some of you say to just open the html file but you lose the preferences you have set in your .an file. You lose locked images among other things. Kind of frustrating.

               

               

              Anyone care to see if this happens to you? Try this real quick:

               

               

              1. create a new edge file.

               

              2. save into a new folder on your desktop

              go into same folder and create a new folder titled "test"

               

              3. go to publish settings with web checked, open folder next to Target Directory and choose the "test" folder you just made.

               

              4. save publish settings

               

              5. publish the file.

               

              6. now SAVE your edge file

               

              7. close EDGE

               

              8. go to desktop, and open the EDGE file you just made

               

              9. Edge tells you it can't open the file because it's missing an .html file

               

              ! FUDGE