28 Replies Latest reply: Apr 10, 2013 8:13 AM by Laubender RSS

    Non-optimal hyphenation

    r-j-f

      I'm using CS5.5 on a PC and have the following entry in a bibliography (top):

       

      hyphenation.jpg

        

      I don't want the extra hyphen in 'Plessis', so I put in the 'nonbreaking hyphen' in front of it, which gives me the middle version.   

       

      But I get much better spacing if I put a normal word space after the 'Plessis-', which gives me the bottom version.

       

      Why isn't InDesign doing that without the word space? I'd rather not put it in, in case I later reformat the text in some way.

       

      I'm perplexed, so any thoughts would be very welcome. Thanks.

        • 1. Re: Non-optimal hyphenation
          PrintFusion45 Employee Hosts

          It seems like you've applied full justification to those paragraphs. You may get rid of extra spacing if you apply left justification to those paragraphs.

          • 2. Re: Non-optimal hyphenation
            r-j-f Community Member

            I should have shown more of the page - but full justification is part of the spec, and I'm stuck with it.

            • 3. Re: Non-optimal hyphenation
              Peter Spier CommunityMVP

              I'd try using a non-breaking space between Le and Plessis- and use the method of your choice to keep Plessis from hyphenating.

              • 4. Re: Non-optimal hyphenation
                Joel Cherney CommunityMVP

                Peter's on the right track, I think. If you allow hyphenation at all here, then it's going to be funky - I hate Proximity hyphenation.

                 

                You might need to share your file to get a perfect answer for this one. When I typeset your example, simply applying No Break to "Plessis" gets the result you want. If I had to, I might use a zero-width space somewhere (I love those things) but it doesn't seem necessary here.

                • 5. Re: Non-optimal hyphenation
                  Mary Posner Community Member

                  What happens if you turn off hyphenation on capitalized words? (Or are there capitalized words that you *do* want to hyphenate?)

                  • 6. Re: Non-optimal hyphenation
                    r-j-f Community Member

                    Thank you for your suggestions.

                    If I put a non-breaking space between Le and Plessis, the Le goes over to the next line and spacing is worse!

                    It's interesting that Joel doesn't get the same result as I do when he typeset the example. The forum doesn't allow me to upload a file but I'd be happy to email anyone a version if they are interested.

                    There are capitalised words I want to hyphenate and turning that off or on doesn't affect the outcome.

                    If I stretch the text frame arbitrarily wider, at some point the whole of 'Plessis-Robinson' goes over, never 'Plessis-' on its own, which is the nub of the problem.

                    • 7. Re: Non-optimal hyphenation
                      rob day CommunityMVP

                      If I put a non-breaking space between Le and Plessis, the Le goes over to the next line and spacing is worse!

                      Try Joel's No Break suggestion. Instead of using non-breaking spaces or discretionary hyphens, select Plessis and choose No Break from the Character panel.

                      • 8. Re: Non-optimal hyphenation
                        Peter Spier CommunityMVP

                        I suspect the paragraph composer, in conjuction with your justification settings, is trying to make a better looking paragraph (which it can't really do if you take away the tools by forcing things not to break). You might want to try the single line composer on this one.

                         

                        I'd be interested in seeing the text as might others. You can put a sample file on a server -- your own or a service like dropbox or yousendit (send it to yourself) -- and then put a link to it here to share withthe world, or send the link to us via Private Message individually.

                        • 9. Re: Non-optimal hyphenation
                          r-j-f Community Member

                          Thanks again for the interest and suggestions. The 'no break' didn't work, nor the single line composer.

                          Thanks to Peter for pointing what is probably the obvious (I did try earlier on Dropbox and couldn't see a way of making the folder public).

                          Here is an idml if anyone would care to play with it: https://www.yousendit.com/download/UVJpNWNnYTI1UjZLRmNUQw.

                          My original fount was Galliard, but I swapped it for Garamond, which I imagine more people will have, and it produces the same effect. Try moving the right-hand side of the text frame -- 'Plessis-' never goes over by itself. Why wouldn't it? Still flummoxed!

                           

                          Ralph 

                          • 10. Re: Non-optimal hyphenation
                            MW Design CommunityMVP

                            This isn't going to help, I am afraid.

                             

                            non-breaking space between Le and Plessis, typing a hyphen between Plessis and Robbinson produces this, here:

                             

                            capture-000214.png

                            Mike

                            • 11. Re: Non-optimal hyphenation
                              Peter Spier CommunityMVP

                              If you turn on H&J violation hightlighting in the prefs you'll see that as soon as you start trying to force the line to break where you want it to ID is unable to figure out a way to do it without having a violation. I find it odd that ID won't break after the hyphen, though, because if you add a forced line break after the hyphen ID is perfectly happy to do your bidding (and the line count reduces by 1, though there's still a violation in the second line.

                              • 12. Re: Non-optimal hyphenation
                                Peter Spier CommunityMVP

                                MikeWenzloff wrote:

                                 

                                This isn't going to help, I am afraid.

                                 

                                non-breaking space between Le and Plessis, typing a hyphen between Plessis and Robbinson produces this, here:

                                 

                                capture-000214.png

                                Mike

                                That's really odd, because the ONLY way I can get that is with a forced line break.  I even tried changing the justification settings and changing the frame width.

                                • 13. Re: Non-optimal hyphenation
                                  MW Design CommunityMVP

                                  Tis why I didn't find my "contribution" helpful myself.

                                   

                                  Mike

                                  • 14. Re: Non-optimal hyphenation
                                    Peter Spier CommunityMVP

                                    Well, I'd like to know what you did that I didn't try.

                                    • 15. Re: Non-optimal hyphenation
                                      [Jongware] CommunityMVP

                                      Bad news: it behaves the same on CS6.

                                      Good news: it does not on CS4! There you get exactly what one would expect: as soon as there is enough room on the line, it is broken on that hyphen.

                                       

                                      So the bad news seems to be Adobe 'changed' (broke, IMO) something in CS5.5 -- or possibly earlier, if anyone cares to check this in CS5.

                                       

                                      I tested with a variety of Hyphenation settings, Word Spacing, fonts, Paragraph Composers, and even languages; just to rule out the possibility that CS5.5 (and newer) picked up some previously ignored font or hyphenation parameter.

                                      • 16. Re: Non-optimal hyphenation
                                        MW Design CommunityMVP

                                        My post #10. Now, I did delete the present hyphen before Robinson and type a new one. that's all.

                                        • 17. Re: Non-optimal hyphenation
                                          Peter Spier CommunityMVP

                                          I tried replacing that hyphen, too...

                                           

                                          I did my testing in CS6, though.

                                          • 18. Re: Non-optimal hyphenation
                                            Joel Cherney CommunityMVP

                                            Well, I can see that the various composers of the different versions of ID are handling this differently. As Mr. Ware reports, it renders correctly in CS4. In CS5.5 and CS6, it opens up with the bad hyphenation, and sticks until I turn hyphenation off

                                             

                                            UNTIL

                                             

                                            I put a zero-width space after the dash in "Plessis-". Then it rendered as r-j-f wanted.

                                             

                                            Obviously a ZWS should not be necessary here, but it's a functional workaround.

                                            • 19. Re: Non-optimal hyphenation
                                              [Jongware] CommunityMVP

                                              .. inserting a Discretionary Break right after the hyphen makes it work. 'Tis a curious thing you encountered here.

                                               

                                              (Are those your default Hyphenation settings? "At least: 12 letters long", "Hyphen limit: 1"? Not that it appears to have anything to do with the problem at hand...)

                                              • 20. Re: Non-optimal hyphenation
                                                Joel Cherney CommunityMVP

                                                So the bad news seems to be Adobe 'changed' (broke, IMO) something in CS5.5 -- or possibly earlier, if anyone cares to check this in CS5.

                                                 

                                                It was CS5.5 - in CS5, it looks just like it does in CS4:

                                                 

                                                broken.png

                                                • 21. Re: Non-optimal hyphenation
                                                  Peter Spier CommunityMVP

                                                  OK, somebody said Discretionary Line Break (I had used a force line break). That works, too, in CS6, but strangely if composes diffently thant he forsce line break. Forced break brings the year up to the second line, discretionary leaves it on the third.

                                                  • 22. Re: Non-optimal hyphenation
                                                    r-j-f Community Member

                                                    Again, thanks for the interest and contributions. It's a bit of a relief to find it is the program and not me, as it were.

                                                    I did set the hyphenation to 12 letters long and 1 limit on this book, which did actually prove a bit too restrictive, but I tire of tidying up the hyphenation in a lot of what InDesign does.

                                                    I like the work-around of turning off the hyphenation (isn't that ironic?), as it avoids adding in any extraneous characters.

                                                    I did try Mike's suggestion in posts 10 and 16, but it didn't work....

                                                    Just to sum up then, is this about right? --

                                                    It is a glitch in CD5.5 and later, that wasn't there before, and you can get around it by turning the hyphenation off.

                                                    • 23. Re: Non-optimal hyphenation
                                                      Laubender CommunityMVP

                                                      @r-j-f – There must be something else at work:

                                                       

                                                      As already stated:
                                                      If one opens your IDML in InDesign CS5 all works fine.
                                                      If opened in CS5.5 or CS6 the hyphenation is bad (broken).

                                                       

                                                      But:

                                                       

                                                      If I save your IDML as InDesign CS5 file and then open it in CS5.5 I cannot recreate the bad hyphen situation. Even not if I expand the width of the text frame and shrink it back to its former value. It's hyphenation is still the same. Even if I edit the text before the hyphenation.

                                                       

                                                      And further with the opened IDML in InDesign CS5.5:

                                                      If I copy/paste the text frame with the questionable hyphen to the document I saved with InDesign CS5 and opened with InDesign CS5.5, I get the right (wanted) hyphenation!

                                                       

                                                      (All tests in InDesign CS5 v7.0.4 and CS5.5 v7.5.3)

                                                       

                                                      Uwe

                                                      • 24. Re: Non-optimal hyphenation
                                                        rob day CommunityMVP

                                                        It is a glitch in CD5.5 and later, that wasn't there before, and you can get around it by turning the hyphenation off.

                                                         

                                                        I was able to fix it by adding a hyphenation exception to the dictionary—like this:

                                                         

                                                        Screen shot 2013-04-10 at 9.30.47 AM.png

                                                        • 25. Re: Non-optimal hyphenation
                                                          rob day CommunityMVP

                                                          Also, with the dictionary hyphenation exception the Justification setting seems to  work correctly:

                                                           

                                                          Screen shot 2013-04-10 at 10.06.10 AM.png

                                                          • 26. Re: Non-optimal hyphenation
                                                            Laubender CommunityMVP

                                                            @Rob – in the meantime I found a different workaround to force hyphenation in InDesign CS5.5 to the wanted one:

                                                             

                                                            Instead of the applied Language: "English GB", use another language setting.

                                                            [No Language] will work…

                                                            What is not working is:

                                                             

                                                            "French" [!?? (what the…)],
                                                            "French (Canadian)" [!?? (what the…)],

                                                            "Estonian",
                                                            "Croatian",
                                                            "Latvian",

                                                            "Lithuanian",

                                                            "Polish",

                                                            "Romanian",

                                                            "Slowakian",

                                                            "Slovenian",

                                                            "Czech",

                                                            "Turkish"

                                                            or (!!!):

                                                             

                                                            "English GB";

                                                             

                                                            Uwe

                                                            • 27. Re: Non-optimal hyphenation
                                                              rob day CommunityMVP

                                                              I wonder if using the wrong language dictionary would cause new problems somewhere else?

                                                              • 28. Re: Non-optimal hyphenation
                                                                Laubender CommunityMVP

                                                                @Rob – usually in this case I would recommend using "French" as language setting of "English GB", but I found, that it's not working here as expected…

                                                                 

                                                                As a quick workaround: using "[No Language]" for the single name "Le Plessis-Robinson" obviously forces InDesign to the wanted behaviour.

                                                                 

                                                                Uwe