9 Replies Latest reply on May 1, 2013 2:07 AM by mgrist

    authorisation of second computer

    mgrist Level 1

      I have a Kobo e-reader and have installed Adobe Digital Editions on my PC running Win7 and it all works fine with my Adobe ID. However I also installed ADE on my Macbook Pro (Mountain Lion) and although this is also authorised to the same Adobe ID, I am unable to see any of my purchased books on it. When I check the Authorisation Information on the PC, there is a string of numbers after my email address. On the Mac, there's only the email address.

      How can I get my Mac to see my bought books? I tried to de-authorise it using Cmd Shift D (found this by googling) but it didn't do anything at all.

      thanks!

        • 1. Re: authorisation of second computer
          sjpt Level 4

          Have you explicitly copied books to the Mac?

          The authorization system allows books to be read across multiple devices authorized to the same ID, but does not automatically synchronize/copy the books.

           

          On authorization: I can't verify what the Mac versions does, but v1.7.2 on a PC shows just the email address as authorization,

          but V2.0 shows the email address and also the internal id (urn:uuid:xxxxxx) where xxx is a string of numbers, hyphens and letters a to f.

          • 2. Re: authorisation of second computer
            mgrist Level 1

            Thank you sjpt. When I open ADE and plug in my Kobo, the Kobo is not seen by ADE. There's no button or menu item in ADE that I can find which would enable me to sync. So I am still not sure where to go from here.

            • 3. Re: authorisation of second computer
              sjpt Level 4

              I'm not sure exactly how far you got or were trying to do, so a couple of clarification questions.

               

              I was trying to answer the main part of your question: how to get the Mac to see your bought books.

              I was thinking that you would copy the books direct from PC to Mac; but I didn't exactly say that?  Did you try that?

              Or were you trying to use the Kobo and copy the books already on the Kobo onto the Mac?  That should work as well.

               

              Are you saying that the Kobo works fine with your PC ADE, but will not work with the Mac ADE?

              (So you can't even try to copy the books with it).

               

              ~~~

              As well as showing up on the Mac under ADE, the Kobo should show up on the Mac as an external drive.

              You can copy books that way using the Mac file manager (Finder),

              though you need to know which folders to use on the Kobo ond on the Mac so it is a little fiddlier than doing it with ADE..

               

              ~~~

              Have you perhaps got ADE1.7.2 or similar on the PC, but the more recent and very buggy ADE2.0 on the Mac?

              That would explain your early comment of the id's showing up in a different format; and bugs in ADE2.0 could be why the Kobo isn't showing up.

              If so, try installing v1.7.2 on the Mac.

               

              Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

              http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

              The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

              • 4. Re: authorisation of second computer
                mgrist Level 1

                Sorry I have been busy the past few days. Just having another look at this problem.

                What I am really mostly having problems with, is opening books that I have borrowed from the library on my Macbook. These come from the library in .ascm format, and in my Macbook the file is greyed out and I can't click on it.
                Also, when I open ADE in my PC and plug the Kobo into the USB, the Kobo shows up on the left-hand side of ADE and I can browse all of the books on the Kobo.

                However, on my Macbook the Kobo does not show up. I can see "Bookshelves" on the left hand side but the Kobo is simply completely absent. I copied some of the books manually using Add Item to Library, and navigated to my Kobo using Finder. These books do show up now on ADE Macbook. However, the Kobo still does not show up on the left hand side of ADE in Macbook and therefore I am unable to browse the Kobo or add new books to it using ADE.

                I can't see where to find out which version of ADE is on the Macbook. However it is only recently that I installed it.

                So, adding books to the Kobo can be done on the Macbook but only through the Macbook Finder, not through ADE. And if I want to install an ASCM file then it's not possible through Macbook Finder. This file appears to have to go through ADE or it won't work.

                I uninstalled ADE and re-installed it using the file from the link you provided. However, there was no change, and the identical problem is still happening.

                Thank you for your help.

                • 5. Re: authorisation of second computer
                  sjpt Level 4

                  You should be able to find ADE version in menu/Libary/About Digital Editions

                  Check if you have the same version on PC and on Macbook.

                  It could well be as I suggested that you have the older version 1.7.2 on PC and buggy new version (2.0) on the Mac.

                   

                  The .acsm file needs to be handled by ADE, which will convert it to a drm .epub file.

                  It is the .epub file you must copy to the Kobo.

                  • 6. Re: authorisation of second computer
                    mgrist Level 1

                    I have version 2 on my PC (the one that works) and version 1.7.2 on the Mac (this doesn't work).

                    On my Mac, if I double click the .acsm file it doesn't open. Even if I drag the file onto the ADE window it doesn't open. So I am unable to open .acsm files on my Macbook at all.

                    • 7. Re: authorisation of second computer
                      sjpt Level 4

                      Clearly not exactly what I suspected.  Two possibilities ...

                       

                      1) Sometimes ADE gets confused registration.  Try deregistering (cmd-shift-D to ADE on the Mac), restarting ADE, reregistering your Adobe ID, and trying again with .acsm files.

                       

                      2) Try installing V2.0 on the Mac.

                      • 8. Re: authorisation of second computer
                        mgrist Level 1

                        When I press Cmd Shift E on the Mac nothing happens. I tried this initially after googling the problem and it didn't do anything then either. Next I removed ADE 1.7.2 and re-installed ADE2 for Mac (which I am pretty sure I had on my machine at the beginning of this discussion) and now, finally, the .acsm file is loading. It's late so tomorrow I will try connecting my Kobo to see if it shows up in ADE. I would like to thank you for your patience with this problem.

                        • 9. Re: authorisation of second computer
                          mgrist Level 1

                          Yes! The Kobo is showing up at last! Thank you for your excellent help sjpt.