6 Replies Latest reply on Apr 16, 2013 10:45 AM by Peter Grainge

    Duplicate Search Results (RH HTML v10)

    KathrynJackson

      RoboHelp HTML V10: The following issue happens after generating to Microsoft HTML Help and opening the chm file on my desktop.  I go to search tab, enter the keyword, click on list topics, and in the display window there is a duplicate topic.  Let’s say I searched on “Computer.”  There are two “Computer” topics in the topic display.  When I click on the first “Computer” to display the topic it displays the topic content perfectly. When I click on the second topic in the display window it says (in the topic window) “This program cannot display the webpage.” I have searched for the topic throughout the project.  In the project .hhc folder there is one instance, in the project .hhk folder there are 4 references.  In the project htm folder there is one reference.  How do I find the reference in the project that is causing the duplicate topic to show in the search results with the error message?  There is only one topic in the TOC and when I search the index there is also only one occurance.  Thanks for any help you can provide.

        • 1. Re: Duplicate Search Results (RH HTML v10)
          Peter Grainge Adobe Community Professional

          Welcome to the forum.

           

          To save waiting for answers it is always worth a search. If then you cannot find anything, the next trick is to look at the side panel More Like This. Against this thread you will see "re Duplicate Topics in Search" and that may well contain the answer to your problem. Post back if it does not.

           

          The thread takes you to my site and the first link in the answer there is not working. However the information you need is in the "text" link.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

           

          @petergrainge

          • 2. Re: Duplicate Search Results (RH HTML v10)
            Peter Grainge Adobe Community Professional

            I just checked and the text file contains a link to the Helpware.net site but the target file is no longer there. However the file may be sufficient to solve the problem.

             

            Take a look and let us know how you get on.

             


            See www.grainge.org for RoboHelp and Authoring tips

             

             

            @petergrainge

            1 person found this helpful
            • 3. Re: Duplicate Search Results (RH HTML v10)
              KathrynJackson Level 1

              Thank you for your welcome!  I was trying to be so good in my search and posting - I didn't want to get scolded .  Thank you for the "More Like This" recommendation.  You are my hero! 

               

              Based on what I read in the other posts, I thought I would try generating to a new folder under C:/My Project (to a folder C:/My Project/Compile) to see what happened.  Interestingly, the error goes away.  I did find that I had other chm files in the SSL folder so I clearned them out and I tried generating to the SSL folder again. The error remained.  Is there any danger in generating to the "Compile" folder under my project file?  It seems as if you did not recommend this in your other answer. 

               

              Thank you for your patient help.

              • 4. Re: Duplicate Search Results (RH HTML v10)
                Peter Grainge Adobe Community Professional

                No scolding intended, comments just meant to help you.

                 

                As written I suspect the Compile folder will show in Project Manager and, as a result, when the search is created next time it too will get searched. Prior to your test, that folder was empty. You can create folders in Windows Explorer and add an exclamation mark before and after. That will hide the folder from Project Manager. When you generate the help however the folder will be visible so that you can point to it in the layout.

                 

                Did you delete all files and folders from the !SSL! folder?

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                 

                @petergrainge

                1 person found this helpful
                • 5. Re: Duplicate Search Results (RH HTML v10)
                  KathrynJackson Level 1

                  I know you meant to help...thank you.

                   

                  You are a genius.  The issues was that I had deleted all the files under !SSL! folder but not the other folders (because I thought it would not interfere because there were no files in the folders).  Once I deleted the empty folders and generated the chm the error was cleared.

                   

                  I'm assuming by this experience that before I re-generate I need to delete the current files/folders in Explorer prior to generating.

                   

                  Thank you.  Problem solved!

                  • 6. Re: Duplicate Search Results (RH HTML v10)
                    Peter Grainge Adobe Community Professional

                    I wouldn't have thought you need to do that everytime. If it were the case, there would be a lot more posts here about the problem.

                     

                    I'm thinking that somewhere there was a remnant of a path that was giving some grief. See how it goes in the short term. If the problem recurs, then try deleting the other layouts within Rh followed by closing the project. Maybe that will clear the remnant if it does still exist.

                     

                    Post back to this thread if it happens again.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                     

                    @petergrainge