1 Reply Latest reply on Apr 16, 2013 8:16 PM by pwillener

    How do I update flash on a mac version 10.5.8?

    Nysee3333

      I am using a Mac  OSX version 10.5.8. Most websites require flash versions 11 or higher. Whenever I try to update to version 11 it directs me to version 10.3 , but version 10.3 DOESN'T work on a lot of sites. How do I download flash player 11?