10 Replies Latest reply on Nov 1, 2007 7:28 AM by Ben Minson

    RH7 Trial HTML View

    Ben Minson Level 2
      This discussion started with this thread. I am using the RH7 trial on a Windows XP SP2 machine and looking at a project with Japanese text in the topics. The project language is now set to Japanese. In Design view, the characters display properly, but in HTML view, all I get are squares. The encoding is utf-8, which must be RH7's default, so I would think it would work. If I open a topic in Notepad, the characters are showing up correctly.

      I am also getting squares in the TOC, glossary, and index panes. I was hoping when I heard about double-byte support that double-byte characters would render correctly throughout the interface in RH7, so I'm hoping this is something I can somehow change. Thanks for any help,

        • 1. Re: RH7 Trial HTML View
          Ben Minson Level 2
          I just realized there is another factor in this. In Notepad and my stylesheet in RH, Arial Unicode MS is my font. But the HTML View is in Courier. I think the problem is the font in HTML view. Is there a way to change the RoboHelp display fonts in HTML view and other places like the TOC bar so double-byte characters show up?
          • 2. Re: RH7 Trial HTML View
            Peter Grainge Adobe Community Professional (Moderator)
            Following up on the other thread, I got the same in the editor but when I generated an output, I got the correct characters. What do you see in outputs?
            • 3. Re: RH7 Trial HTML View
              Ben Minson Level 2
              Actually, the output looks great. This is just a concern with being able to see the correct characters while working in RoboHelp itself, which would make working with the files easier (even when I can't read Japanese or other languages like Russian). The fact that RH7 will code in UTF-8 is a big step forward that will eliminate a lot of "babysitting" of files that I was having to do before.
              • 4. Re: RH7 Trial HTML View
                Peter Grainge Adobe Community Professional (Moderator)
                OK. You are getting the same result as I am. I will make some enquiries.

                • 5. Re: RH7 Trial HTML View
                  Peter Grainge Adobe Community Professional (Moderator)
                  Select the squares and change the font to Arial Unicode MS or any other unicode font. Worked for me.

                  • 6. Re: RH7 Trial HTML View
                    Ben Minson Level 2
                    In HTML view, if I choose Arial Unicode MS out of the font dropdown, the whole page of code changes and the Japanese does show up, but the formatting is messed up (any space looks like about five). I also get strange behavior in that wherever I click in the code, the text on that line shifts. I'm probably better off with Courier unless there is a unicode font that's better than Arial Unicode MS. I have only a couple of unicode fonts on my machine.

                    My TOC, glossary, and index palettes are still showing squares for the entries. I tried changing display fonts in Windows with no luck. English shows in what looks like Tahoma, but I found no way to change it to Arial Unicode MS in my Japanese project.
                    • 7. RH7 Trial HTML View
                      Peter Grainge Adobe Community Professional (Moderator)
                      Don' t know. I'll see if I can get someone to come in on this.

                      • 8. Re: RH7 Trial HTML View
                        Ben Minson Level 2
                        Just a note: Russian is showing up in the code in Courier New, but this is probably because Cyrillic is single-byte and Courier handles it. Russian also shows up in the TOC, glossary, and index pallettes. Japanese is the only double-byte character language I'm using at this point and seems to be the only real problem child.

                        Thanks for your help, Peter.
                        • 9. Re: RH7 Trial HTML View
                          Akshay Madan Adobe Employee
                          Probably the PC that you are working on doesn't have the Langugae Pack installed for working with complex scripts. For installing Langugae Pack on a XP machine, follow these steps:
                          1) Access Control Panel and then select "Regional and Language Options"
                          2) In the Regional and Language Option Dialog, select Languages Tab
                          3) Check the two check boxes at the below frame of “Supplemental language support” and click apply
                          4) This will require installation of language Packs with WinXP SP2 CD required

                          Restart RoboHelp application.
                          • 10. RH7 Trial HTML View
                            Ben Minson Level 2
                            I am pretty certain that my computer does not have language packs installed. I looked into those some time ago as a way to have menus, etc. displayed on my machine in other languages, but we went with a different method.

                            I followed Akshay's steps 1-3 but checked only the East Asian checkbox. My machine installed some files and asked to restart. When it booted back up and I opened my Japanese project in RH7, the Japanese characters show up in the TOC, glossary, and index pallettes and in HTML view with Courier New as my code font. In HTML view, the Japanese text doesn't all seem to display between tags and slides around a bit when I highlight it, but it looks like this is the closest I'll get and it should make things easier.

                            Unless it would help with this strange behavior in HTML view, it looks like installing the language packs using the Windows XP SP2 CD is not necessary, which I was hoping because I would have to go through our tech support reps (who issue our workstations and manage the configuration) to get one. Thanks very much for the help!