30 Replies Latest reply on Jul 1, 2008 2:45 PM by SeanAitken

    RH 7 Install "Rolling back action"

    darchib Level 1
      Has anyone had this happen yet? I've installed the trial version of RH 7, just when the progress bar gets to the end, it rolls back the action. I can see it actually installing, places the icons on the desktop, only to remove everything after it gets to the end. When it finally uninstalls it, I get the an alert box that says "The wizard was interrupted before Adobe Robohelp 7 could be completely installed." I've tried this numerous times, w/o RH 6 on the machine, cleaning up the registry... I've followed two generic resolutions from the Knowledgebase with no luck. I was able to install it on an older Compaq laptop without any problems.

      I have a Dell Latitude D820, with 1 gig of memory, over 30 gigs of disk space...

      Thanks for your help!
        • 1. Re: RH 7 Install "Rolling back action"
          HKabaker Level 2
          Dan,

          Is your laptop going to sleep after x minutes? Check your power saving settings.

          It shouldn't shut down the processor while it's running the installation, one would think. But just maybe . . .

          Harvey
          • 2. Re: RH 7 Install "Rolling back action"
            darchib Level 1
            I have watched the install through it's entirety several times, so doesn't appear to power down during those times. My settings are "Always On" while plugged in too.
            • 3. Re: RH 7 Install "Rolling back action"
              RoboColum(n) Level 5
              Have you tried it with your firewall turned off? This may be the issue.
              • 4. Re: RH 7 Install "Rolling back action"
                darchib Level 1
                Hi Colum, I just tried it and no luck. It was one thing I hadn't tried yet and did seem promising. I wish the event viewer gave a little more information as to why it doesn't complete the installation.
                • 5. Re: RH 7 Install "Rolling back action"
                  RoboColum(n) Level 5
                  Hi Dan. Do you/did you have a copy of a previous version on the PC? If so, maybe this knowledge base article may help in ensuring the old version has been removed.
                  • 6. Re: RH 7 Install "Rolling back action"
                    darchib Level 1
                    Colum, thanks for the quick reply. I originally installed RH 6 from a disk. Two months ago my laptop crashed while on the road and I re-downloaded RH6 from ESD. No install problems with either of those. I read the articles you linked to and followed them as described but still get the same rollback. Some of the final messages before rolling back, are "Registering product, Publishing products, Publishing info." It goes fairly quickly so not sure if that's the exact message.
                    • 7. Re: RH 7 Install "Rolling back action"
                      RoboColum(n) Level 5
                      Maybe the RH7 download file is corrupted somehow? Could you try downloading again and giving that a go? Not sure what else to suggest as others have no problem installing RH7.
                      • 8. Re: RH 7 Install "Rolling back action"
                        CraigCC Level 2
                        Hi Dan,

                        What is the name, size and date stamp of the file that you downloaded ?
                        Do you any other Adobe Products installed on your PC?
                        Are you opting to install all elements of the trial version?

                        thanks
                        Craig

                        • 9. Re: RH 7 Install "Rolling back action"
                          Akshay Madan Adobe Employee
                          Hi,

                          There are two things that you can try.

                          Step 1:
                          As suggested by Colum, download a fresh build of Adobe RoboHelp 7 from the Adobe website and give it a try. In case this fails, try step 2.

                          Step 2:
                          This may happen because of wrong msi file in C:\WINDOWS\Installer folder.
                          <to view C:\WINDOWS\Installer , please enable view hidden files and folder in explorer>

                          One workaround that might solve the problem is:
                          Explore to C:\WINDOWS\Installer folder
                          You may find multiple msi files in this folder.
                          Check for the file that corresponds to Adobe RoboHelp. You can do that by double clicking the msi file. A welcome screen generally comes up giving information about the product etc.
                          Delete this msi that corresponds to the Adobe RoboHelp 7 installer.
                          Run your original msi or setup.exe and install the application.
                          Hopefully you should be able to install and run the application.

                          Regards,
                          Akshay



                          • 10. Re: RH 7 Install &quot;Rolling back action&quot;
                            darchib Level 1
                            Hi Craig,
                            file name is AdobeRobohelp7_WWEFGJ.exe
                            file size is 434,514,024 bytes
                            date is Oct 25th, 8:04 pm
                            I'll re-download as you and Colum recommended and, if no luck, try Akshay's suggestion.

                            Thanks everyone.
                            • 11. Re: RH 7 Install &quot;Rolling back action&quot;
                              darchib Level 1
                              OK, I've deleted the old package from the 25th as well as the files it had unpackaged. I also looked for the msi file that Akshay recommended but couldn't find it in the "installer" or "installshield" folder in c:/windows. I rebooted and attempted to reinstall with the same rollback action.
                              • 12. Re: RH 7 Install &quot;Rolling back action&quot;
                                Captiv8r Adobe Community Professional & MVP
                                Hi Dan A

                                I'm not sure if what I'm about to post will help any, but here goes. We saw a similar thing happen when Captivate 3 arrived. Someone named Greg posted the following info that seemed to work for him. Hopefully it will help here.

                                =====> Snip <=====
                                Hi everyone - after trying for two weeks to get v3 to install, we finally got it working this past Friday. When we would try to install it on two of our machines, it would get to the end of the install process as though it had completed successfully, and then would give the message "Rolling Back Action", uninstall everything, and then leave a message that "Installation was Interrupted...". We tried on two machines at least 10 times each, cleaned out registry keys for Captivate 1 and 2, ran diagnostics, etc, and got the same action everytime.
                                One of our IT guys said that he had encountered the same exact issue when installing QuickBooks on one of our Finance dept's PC's, and sure enough, the solution he used for it worked for Captivate 3:
                                1) Log out
                                2) Log in as administrator
                                3) Turn off any scripting
                                4) Turn ON the Windows Firewall
                                5) Install Captivate and enter serial number
                                6) Reboot - log back in as admin
                                7) Turn back on any scripting
                                8) Log out admin and back in as user
                                I won't even pretend to be 100% certain why this worked, but it did without a hitch on both PC's where previous attempts had failed. I spent over 2 hours on hold with Adobe "Tech Support", only to find out that they didn't have a clue what was happening with this. Just another example of how anti-pirating measures penalize paying customers while those using unauthorized copies are unaffected .
                                Greg
                                =====> End Snip <=====

                                Cheers... Rick
                                • 13. Re: RH 7 Install &quot;Rolling back action&quot;
                                  darchib Level 1
                                  Hi Rick, thanks for your reponse. I just tried everything as described from your post but can't get to the point of entering a serial number. I am at such a loss with this. Does anyone know Installshield have some sort of an event viewer perhaps?
                                  • 14. Re: RH 7 Install &quot;Rolling back action&quot;
                                    HKabaker Level 2
                                    It doesn't ask for the serial number until you launch the app.
                                    • 15. Re: RH 7 Install &quot;Rolling back action&quot;
                                      darchib Level 1
                                      OK, can't seem to get that far in either case. Thanks for everyones help. Not sure what else to do...
                                      • 16. Re: RH 7 Install &quot;Rolling back action&quot;
                                        maxpouliot Level 1
                                        When i start the program, i can't get past the serial screen here... No option to try the software for 30 days!
                                        • 17. Re: RH 7 Install &quot;Rolling back action&quot;
                                          darchib Level 1
                                          Hi Max, are you able to get to the point where it allows you to enter serial numbers?
                                          • 19. Re: RH 7 Install &quot;Rolling back action&quot;
                                            darchib Level 1
                                            I have opened a trouble ticket and have since found this from my temp folder:

                                            *******
                                            amtconfig STARTED
                                            payload is a driver
                                            path: C:\Program Files\Adobe\Adobe RoboHelp 7\AMT\application.xml
                                            payload: {7961C367-4C84-4B42-8642-3B3B021B5B8E}
                                            driver: {7961C367-4C84-4B42-8642-3B3B021B5B8E}
                                            override: C:\Documents and Settings\Dan\Desktop\Adobe RoboHelp 7\RoboHelp\
                                            Master PCD not writable
                                            ******
                                            Can anyone tell me if this is a bug related to licensing?

                                            Thanks, Dan
                                            • 20. Re: RH 7 Install &quot;Rolling back action&quot;
                                              darchib Level 1
                                              Just an FYI, I have changed permissions on the Temp folder from the "Read Only" state but doesn't seem to make any difference.
                                              • 21. Re: RH 7 Install &quot;Rolling back action&quot;
                                                Akshay Madan Adobe Employee
                                                I need some more information in order to help you:

                                                1.Is Pcd.db getting created? Do you get to see this file?
                                                PCD File Location: ProgramFiles\CommonFiles\Adobe\PCD\Pcd.db
                                                2. If yes, what are your log in permissions on this machine
                                                3. Also, it would be great if you could mail me the AMT.log file in the system temp folder (%temp%) to amadan@adobe.com

                                                Thanks,
                                                Akshay
                                                • 22. Re: RH 7 Install &quot;Rolling back action&quot;
                                                  Linux Rules Level 2
                                                  Hello Dan -

                                                  Seeing as this thread has been going on for a while, I'll take a GUESS at it...this is a guess only!

                                                  GUESS ONLY -

                                                  You have a nice laptop there - I'll guess it has MS Vista as the OS.

                                                  I'll also guess your company enabled the Wave Embassy Trust Suite security software.

                                                  I'll guess that you MAY have the Not Tested For Security (NTFS) hard drive encripted.

                                                  I'll guess your company enabled the TPM feature in the BIOS.

                                                  Now then, Vista on your Dell MAY use the Trusted Platform Module (TPM) services. This assumes that trusted mechanisms are being used to boot and run the platform. It is important to remember that the Tusted Computing Group has explicitly stated in its specifications that using the TPM is not mandatory. Users take advantage of the TPM and Windows Vista TPM services on an opt-in basis. This means if the user of the platform wants her system to load just like PCs have loaded in the past—where no trust assurance is provided—she can do that. She can leave the TPM disabled in the BIOS, and not take advantage of TPM functionality.

                                                  As you can see, Vista, TPM hardware and Wave software, not to mention various anti-virus programs, all combine to protect you from potentially dangerous actions. One of those actions is writing to the Master Boot Record of your hard drive.

                                                  Note that all Adobe software, including RoboHelp, write to the Master Boot Record as part of the installation routine. Some AV programs as well as TPM settings COULD view this as a direct threat and not allow it. Thus when Vista sees RoboHelp trying to write to the MBR, it initiates the rollback feature to restore your system to the pre-installation-routine state.

                                                  What to do? Have your IT folks log in as Admin and:

                                                  First, disable the TPM in the BOIS.
                                                  Second, disable the Wave Embassy Trust Suite.
                                                  Third, turn off all anti-virus software and services.
                                                  Fourth, install RH7.

                                                  I hope my guess works out for you.

                                                  Regards,
                                                  GEWB
                                                  • 23. Re: RH 7 Install &quot;Rolling back action&quot;
                                                    darchib Level 1
                                                    Gary, thanks for your response. I actually have XP instead of Vista but thought I'd give the rest of it a shot. BIOS did have TPM ability but wasn't enabled. Even though I had disabled NAV and Windows Defender, I decided to completely uninstall them. Still no luck. Anyway, thanks for the reply. At least it's documented for others to try.
                                                    • 24. Re: RH 7 Install &quot;Rolling back action&quot;
                                                      Linux Rules Level 2
                                                      Hello Dan -

                                                      Well, I tried. As I said, this was a guess - but an educated guess as I personally have had installation failures due to anti-virus programs and BIOS protection prohibiting RH from writing to the master boot record.

                                                      Regards,
                                                      GEWB
                                                      • 25. Re: RH 7 Install &quot;Rolling back action&quot;
                                                        HKabaker Level 2
                                                        Dan,

                                                        At a point like this I wonder if the Registry has something left over from an older version of RH.

                                                        I don't like to muck about in the Registry except as a last resort, and when I do so, I resist the urge to do too much.

                                                        But it doesn't cost anything to search. From the Sttart menu, Run Regedit. Select Edit|Find and look for eHelp, RoboHelp and RoboHTML. Make notes and report back. Ask Adobe for advice on what to delete.

                                                        Good luck,

                                                        Harvey
                                                        • 26. Re: RH 7 Install &quot;Rolling back action&quot;
                                                          HKabaker Level 2
                                                          Dan,

                                                          Another possibility is anything left over from RoboPDF, if it ever was installed on your machine. Even if you uninstalled it.

                                                          Adobe has a technical note and cleanup utility here:


                                                          http://www.adobe.com/support/robopdf/downloads.html


                                                          H
                                                          • 27. Re: RH 7 Install &quot;Rolling back action&quot;
                                                            darchib Level 1
                                                            Harvey, thanks... I actually did have RoboPDF as well as that toolkit they once sold separately. I'll give that a try as well and post my results. Thanks for your help.

                                                            Dan
                                                            • 28. Re: RH 7 Install &quot;Rolling back action&quot;
                                                              darchib Level 1
                                                              Well, no luck. I'm tempted to save a backup of everything and completely wipe my laptop and and reinstall XP. Thanks everyone for your help.
                                                              • 29. Re: RH 7 Install &quot;Rolling back action&quot;
                                                                darchib Level 1
                                                                First, thanks everyone for your help. I received an answer back from Adobe Technical Support and the following worked! I had previously tried all recommendations listed below except I didn't have the "Clean Script" which seemed to be the magic bullet for me.The link provided will uninstall ALL Adobe products. Remember to make sure you have your serial numbers before you run the script:

                                                                Set the values of TEMP and TMP so that it’s exactly the same.
                                                                1. Right-click on My Computer and select Properties.
                                                                2. Select the Advanced tab
                                                                3. Click the Environment Variables button at the bottom
                                                                4. Under User variables for [username] you should see Variables of TEMP
                                                                and TMP with their respective Values. Edit one of these to match the
                                                                other…it shouldn’t matter which folder you use as long as they both use
                                                                the same one. To be sure, use C:\Temp.
                                                                5. Reboot your computer.
                                                                6. Install RoboHelp 7.

                                                                The above instructions did not work on your end. We might need to
                                                                completely remove other Adobe applications to make sure that there’s no
                                                                conflict. Before we proceed, please make sure that you still have your
                                                                installers and serial numbers for the Adobe products that you have. The
                                                                troubleshooting that we will be doing will remove ALL Adobe products
                                                                that you have installed.

                                                                Once you have secured all the installers and serial numbers, please
                                                                proceed to doing the following:

                                                                A. Running Clean Script
                                                                1. Download Clean Script from http://tinyurl.com/ynplg3
                                                                2. Unzip the file into your harddrive
                                                                3. Close all applications that you have currently running and make sure
                                                                that your user account has full Admin rights on the machine
                                                                4. Run the Windows Cleanup Utility
                                                                5. Run the file that you have extracted for Clean Script
                                                                6. When you run it, you will be prompted to choose the level on which
                                                                you wish to run. It will only show Levels 1 and 2. On this selection,
                                                                type in 4 then proceed with running the Clean Script.
                                                                7. Restart the machine after it has completed running Clean Script then
                                                                check if all instances of RoboHelp has been removed from your machine.
                                                                8. Run Clean Script again at Level 4 then restart

                                                                B. Going to Selective Startup. To eliminate any possible conflict with
                                                                any application or services in your machine, it is best to install
                                                                RoboHelp while on Selective Startup.
                                                                1. In Windows XP, click the Start button and select Run.
                                                                2. Type msconfig in the Open field. This will bring up the System
                                                                Configuration Utility dialog box.
                                                                Note: msconfig.exe is not installed on Windows 2000, however it is
                                                                available for download on the Internet.
                                                                3. On the General tab, choose Selective Startup.
                                                                4. Under Selective Startup, deselect all of the check boxes except for
                                                                Load System Services. Leave Use Original BOOT.INI selected.
                                                                5. Click the Services tab and click the Disable All button to deselect
                                                                all of the check boxes. There will be a few check boxes that cannot be
                                                                deselected, like DCOM Server and Remote Procedure Call. Leave those
                                                                selected.
                                                                6. Still in the Services tab, enable Windows Installer
                                                                7. Ignore the other tabs.
                                                                8. Click OK and restart your machine when prompted.
                                                                9. After restarting into Selective Startup mode, install RoboHelp
                                                                • 30. Re: RH 7 Install &quot;Rolling back action&quot;
                                                                  SeanAitken Level 1
                                                                  I hit this today. No fun. Had RH 6 installed prior, so I tried to uninstall and try again. Same issue. This fixed it for me:
                                                                  Make the following modification to the registry:

                                                                  Windows Registry Editor Version 5.00

                                                                  [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
                                                                  "DisableRollback"=dword:00000001

                                                                  Not ideal, but worked. Don't forget to switch it back to "0" after the installation completes.
                                                                  Cheers!