11 Replies Latest reply on Oct 20, 2017 5:04 AM by alexdauchez

    keyboard shortcuts to userscripts - chaos

    Stephan Moebius Level 1

      Hello,

       

      all you scripters must be having the same problem - everytime you flush your indesign preferences (perhaps to fix a broken palette) - basically everytime indesign re-assigns new action-IDs to the scripts then your keyboard shortcuts are shuffled into chaos. This  also keeps me from synching the keyboard-preferences on different workplaces, because on different installations indesign will assign other action-IDs to my scripts, so i cannot reuse my keyboard shortcuts.indk file on different computers. (By the way synching the other preferences, color managment and workspaces works great with dropbox and "folder-synch". It's just the shortcuts that i have to set again and again)

       

      How do you scripters cope with this problem? Or can we find a solution?

       

      I am having this problem since Indesign CS4. From windows-XP to Win7. But i don't think this is relevant. It's because indesign doesn't assign the shortcuts to the scripts by filename but by those volatile action-IDs.

       

      with kind regards,

      Stephan Möbius

        • 1. Re: keyboard shortcuts to userscripts - chaos
          [Jongware] Most Valuable Participant

          Stephan Moebius wrote:

          ..i don't think this is relevant. It's because indesign doesn't assign the shortcuts to the scripts by filename but by those volatile action-IDs.

           

          Are you sure about that? I just renumbered the action-id's in my indk file, from its apparent random numbering scheme to a simple incrementing value="0xff000000 + 1", ".. + 2", etc. -- and it all still seems to work.

           

          (I did not bother to try "+ 0" as the very first number. In my very basic SDK experience, I've learned that 'base' numbers -- constant plus zero -- may be special in one way or another. So it may or may not work the same with the KBS -- I don't need to know )

          • 2. Re: keyboard shortcuts to userscripts - chaos
            Stephan Moebius Level 1

            I did not dare to fiddle around with those keys in the .indk file before and will do some testing thanks to you. Jongware.

             

            But if the action-IDs are irrelevant, why do my keyboardshortcuts to the userscripts get shuffled as described?

            Surely as a scripter you must have had this problem sometime in the last five years? I had it so often, on many different computers, i don't do anythings special or different...

             

            As an example of HOW the shortcuts get out of order: it gets shuffled like this:

             

            Before reset

            script1 - keyboardshortcut: ALT-1

            script2 - keyboardshortcut: ALT-2

            script3 - keyboardshortcut: ALT-3

            script4 - keyboardshortcut: ALT-4

             

            After a preferences-reset:

            script1 - keyboardshortcut: ALT-1, keyboardshortcut: ALT-2, keyboardshortcut: ALT-4

            script2 - <none>

            script3 - <none>

            script4 - keyboardshortcut: ALT-3

            • 3. Re: keyboard shortcuts to userscripts - chaos
              [Jongware] Most Valuable Participant

              Don't get me wrong -- I try to avoid it as much as possible, but yes, whenever I do the dreaded Reset Everything routine, my keyboard shortcuts are also mangled beyond recognition.

              But as you can see, it's something inside InDesign itself that gets it wrong. It seems unrelated to the actual action id's (other than that they point to "a script").

               

              What I meant is it should be perfectly okay to save a copy of your working KB set somewhere else, and restore that one when you find your preferences have messed it up.

              • 4. Re: keyboard shortcuts to userscripts - chaos
                Stephan Moebius Level 1

                [Jongware] wrote:

                 

                Don't get me wrong -- I try to avoid it as much as possible, but yes, whenever I do the dreaded Reset Everything routine, my keyboard shortcuts are also mangled beyond recognition.

                But as you can see, it's something inside InDesign itself that gets it wrong. It seems unrelated to the actual action id's (other than that they point to "a script").

                 

                What I meant is it should be perfectly okay to save a copy of your working KB set somewhere else, and restore that one when you find your preferences have messed it up.

                 

                I am happy that you acknoledge the problem. I was hoping that i am not alone and that i am not the cause of this myself.

                 

                Unfortunatly  using a copy of the .indk doesn't help. But i will try that again now too, as long as with the manual editing of the IDs - just to get more info on the problem.

                • 5. Re: keyboard shortcuts to userscripts - chaos
                  Stephan Moebius Level 1

                  You were right. Keeping a copy of the indk file does help. I didn't do any structuerd tests with reprocucing/forcing the error, but ever since i set the indk file to non-writable and - if i need to -overwrite it with an older version i do seem to get around the problem. I still don't  understand how a reset messes up the shortcuts file.

                  • 6. Re: keyboard shortcuts to userscripts - chaos
                    lf.corullon Level 3

                    Four years was have passed and the "problem" persists.

                    What a boring behavior!!!!

                    • 7. Re: keyboard shortcuts to userscripts - chaos
                      Trevorׅ Adobe Community Professional

                      Four years is nothing in the history of InDesign

                      • 8. Re: keyboard shortcuts to userscripts - chaos
                        lf.corullon Level 3

                        I made a copy of my indk file and set it as read-only.

                        So I made a short script to toggle between the default set and my read-only set.

                        Until now, it's working for me...

                        • 9. Re: keyboard shortcuts to userscripts - chaos
                          S Hopkins Adobe Community Professional

                          Just thought I would add my 2 cents worth. This problem has annoyed me since keyboard shortcuts for scripts was added to InDesign.

                          Seems like there should be an easier way to handle this than having to fiddle with the .indk file; but yes, this does work.

                          • 10. Re: keyboard shortcuts to userscripts - chaos
                            lf.corullon Level 3

                            My "trick" stopped to work...

                            Any new ideas?

                             

                             

                            Em 23 de jul de 2017 3:12 PM, "S Hopkins" <forums_noreply@adobe.com>

                            escreveu:

                             

                            Adobe Community <https://forums.adobe.com/?et=watches.email.thread>

                            keyboard shortcuts to userscripts - chaos

                             

                            resposta de S Hopkins

                            <https://forums.adobe.com/people/S+Hopkins?et=watches.email.thread> em *InDesign

                            Scripting* - Visualize a discussão completa

                            <https://forums.adobe.com/message/9719529?et=watches.email.thread#9719529>

                             

                            • 11. Re: keyboard shortcuts to userscripts - chaos
                              alexdauchez Level 1

                              Hi, I use a lot of scripts and after installing InDesign CC 2018, as usually there was a mess with scripts shortcuts.

                              This time, having a locked ".indk" file and restoring it didn't do the trick.

                               

                              So here is a workaround that worked for me (I'm on Mac).

                              1. quit Indesign
                              2. open your (unlocked) .indk file in textEdit on Mac, the one containing your current shortcuts ;
                              3. locate a shortcut that doesn't work anymore, by looking at its name=" ;
                              4. replace action-id value="0xff000000 with a new sequence, like action-id value="0xff000100 in the whole document with replacing all (only number "0" was changed to number "1" in "0xff000000")
                              5. open Indesign, change shortcut set to [Default] then revert back to your custom shortcut set, to be sure it's effectively applied ;

                               

                              I could retrieve every previous shortcut.

                              If you create a new shortcut, InDesign will revert the sequence back to 0xff000000, but it seems to retain the shortcut this time.

                              Hope that helps.