1 Reply Latest reply on May 7, 2013 11:36 AM by FSUKXAZ

    CF10 Upgrade - Now Forms Acting Screwy Not Accepting Mime Types On Uploads

    FSUKXAZ

      We have some sites in production that were working fine before we went from CF8 to CF10.  We upgraded to CF10 yesterday and our data analysts couldn't update the site with HTML files. We were getting a 500 server error without any information to go on. Don't you hate that? We do. At least give me a CF errror I can chase down. Anyway, the first issue was on 3 seperate webpages, Coldfusion 10 not interpreting HTML files when uploaded through a form. The Mime type that was used a day earlier and for the previous 5 years the site has been live is: text/html. It's always worked perfectly. It turns out, when you upgrade to CF10 and you use CFFILE or regular INPUT TYPE="File" with the ACCEPT attribute, you must inlude: application/xhtml+xml to be able to upload an HTML file now.  One word: STUPID!

       

      Now here is current issue. In 4 separate webpages, our data analysts cannot update the site with ZIP files. Coldfusion 10 is not interpreting ZIP files. we assume it was a  MIME type issue because we were getting the same 500 server error without any information to go on. The MIME type that was in yesterday and the previous 5 years worked fine. We put in every different ZIP file MIME type we could find on the internet and it still doesn't work. We took out the ACCEPT attribute all together and it still doesn't work. Help!  Our site is getting stale with data that is a day old!