5 Replies Latest reply on Jun 21, 2013 6:24 AM by JohnLeeAdobe

    Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work

    CTA-Lefebvre

      Hi,

       

      We bought an Nvidia Quadro 4000 for Mac for use RayTrace on After Effects CS6 (11.0.2) with our Mac Pro 5.1 on OS 10.6.8.

      And the Mac lost the Cuda driver when we restart it.

      We use the Nvidia driver 256.02.25f01 for Mac Os 10.6.8 and we made test on different Cuda driver (4.1.25, 4.2.10, 5.0.37 and 5.0.47).

      When we install Cuda driver and start directly After Effects 11.0.2 it’s works (after effects see the GPU processor).

      But when we restart the Mac and try to launch After Effects, AE doesn’t see GPU processor and ask to install Cuda driver 4.0 or later.

      Do you know this problem ?

      Do you have a solution ?

       

      Thanks.

       

      And sorry for my English !

        • 1. Re: Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work
          Rick Gerard Adobe Community Professional & MVP

          Your system preferences should show the latest cuda driver. If it doesn't try a re-install. I'm on Mountain Lion so this is what is showing for me:

               Screen Shot 2013-04-23 at 1.45.21 PM.png

          • 2. Re: Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work
            JohnLeeAdobe

            Hi All,

             

            I'm having the exact same problem on 10.6.8 with a brand new Quadro 4000.  My CUDA preferences are up to date, but After Effects CS6 is not seeing the card.

             

            GPUSniffer gives me some really weird results, which I've included.  Of particular note there is a repeated "just leaking" message, an "invalid drawable" and "Did not find any devices that support GPU computation."

             

            Anyone have a fix for this?  We just dropped a lot of money on this card so I could squeeze some more life out of this workstation (Mac Pro 4,1 dual quad 2.66 with 12GB RAM).

             

             

            Last login: Fri May 31 10:20:47 on console

            edit-e-room-20:~ johnlee$ /Applications/Adobe\ Premiere\ Pro\ CS6/Adobe\ Premiere\ Pro\ CS6.app/Contents/GPUSniffer.app/Contents/MacOS/GPUSniffer

            --- OpenGL Info ---

            2013-05-31 10:28:52.456 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x1046095a0 of class NSCFString autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.458 GPUSniffer[71708:903] invalid drawable

            Vendor: NVIDIA Corporation

            Renderer: NVIDIA Quadro 4000 OpenGL Engine

            OpenGL Version: 2.1 NVIDIA-1.6.37

            GLSL Version: 1.20

            Monitors: 2

            Monitor 0 properties -

               Size: (0, 0, 2560, 1600)

               Max texture size: 16384

               Supports non-power of two: 1

               Shaders 444: 1

               Shaders 422: 1

               Shaders 420: 1

            2013-05-31 10:28:52.467 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411d900 of class NSCFString autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.467 GPUSniffer[71708:903] invalid drawable

            Monitor 1 properties -

               Size: (2560, 0, 1600, 1200)

               Max texture size: 16384

               Supports non-power of two: 1

               Shaders 444: 1

               Shaders 422: 1

               Shaders 420: 1

             

             

             

             

            --- GPU Computation Info ---

            Did not find any devices that support GPU computation.

            2013-05-31 10:28:52.471 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x1041234d0 of class NSCFArray autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.471 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x1041236a0 of class NSCFArray autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.471 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411c030 of class NSView autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.471 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411c030 of class NSView autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.472 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411b000 of class NSCFArray autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.472 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x104110e00 of class NSCFArray autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.472 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411ccc0 of class NSView autoreleased with no pool in place - just leaking

            2013-05-31 10:28:52.473 GPUSniffer[71708:903] *** __NSAutoreleaseNoPool(): Object 0x10411ccc0 of class NSView autoreleased with no pool in place - just leaking

            edit-e-room-20:~ johnlee$

             

             

             

            http://i.imgur.com/ytr6wvn.png

            • 3. Re: Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work
              Rick Gerard Adobe Community Professional & MVP

              Try rolling back one driver version. I don't have that card so I don't have any other ideas. You sould also look for any other drivers or GPU software that may be installed and remove it.

              • 4. Re: Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work
                Emery8892

                I had the exact same issue, exact same error message in the GPUsniffer, etc.  Uncanny how exact.  The only difference across the board is that I have the Quadro FX 4800.  I had to go all the way back to CUDA Driver Version 4.2.10.  Cleared up all the issues.  Smooth sailing.  Hope it helps if you haven't fixed it already.

                • 5. Re: Nvidia quadro 4000 for mac and os 10.6.8 on After Effects CS6 (11.0.2) Cuda don't work
                  JohnLeeAdobe Level 1

                  Yep, I ended up having to do the same thing.  Should have posted that the 4.2.10 drivers resolved the problem.

                   

                  I'm not really blown away by the performance boost just yet, but that's probably also because my system only has 12GB of RAM.  Premiere is noticeably faster, and I'm sure if I get back to doing more C4D work there will be an increase there.