2 Replies Latest reply on Apr 23, 2013 4:10 PM by makdm1

    Possible fix for CS5.5 spinning beach ball and slow performance

    makdm1 Level 1

      After searching high and low on the Adobe boards and other places on the web, I think I may have found a solution to the constant spinning beach ball and overall performance issues I've been having in After Effects CS5.5 for Mac.  Just wanted to throw this in here in case anyone else is on the same endless quest for answers to a similar problem. 

       

      On this project I've been working with comps that are 3840x720, containing many nested comp layers, and lots of blended layer modes.  I tried everything Adobe suggests to get the system and After Effects to run faster, but previews were taking forever and practically every other keystroke was met with yet another spinning beach ball.

       

      Anyway, this is what I did and it seems to have worked wonders with speeding up the system!

       

      Set Open GL texture memory to 80% of VRAM on your video card.  Then have Fast Previews pulldown in Composition Settings window set to Open GL- Interactive.  Disk cache is on and current set for 50gb on a fast local disk.

       

      Check out #8 at the following Adobe link: 

       

      http://helpx.adobe.com/after-effects/kb/troubleshoot-opengl-problems-effects-cs4.html

       

      I had previously tried changing the Fast Preview setting but to no avail and had already had my disk cache set to 50gb in this case as well.  ** The only thing that was really any different now was that I set the OpenGL Texture Memory (located in the "Open GL Information" box in the "Previews" preferences setting in After Effects) to 80% of the total VRAM available on my video card-- in this case 409mb for a Nvidia GeForce GT120 video card with 512mb of on-board VRAM.  It was only set to 200mb previously.  Increasing to 80% seems to have done the trick because AE is now running like it should! 

       

      Processor:  2 x 2.26 Ghz Quad-Core Intel Xeon

      Memory:     16GB

      Mac OS:     10.6.8

      AE Version:  CS5.5 (10.5.1.2)

      Video Card:  NVIDIA GeForce GT 120

                           Open GL version 2.1 NVIDIA-1.6.36

       

      Hope this helps you, too!

        • 1. Re: Possible fix for CS5.5 spinning beach ball and slow performance
          Todd_Kopriva Level 8

          Thanks for reporting back with what worked for you.

           

          Note that this issue shouldn't be present at all if you just turn OpenGL rendering off entirely.

           

          Also, because of issues like this, we completely redid how we use OpenGL in After Effects CS6 and later, so this should all be moot when you upgrade.

          • 2. Re: Possible fix for CS5.5 spinning beach ball and slow performance
            makdm1 Level 1

            Hi Todd, thanks for the reply.  Actually, I do have CS6 via my Creative Cloud membership but I'm having to work in 5.5 on this particular client's system for a project. 

             

            I was hoping that the above solution would be the answer I was searching for but alas, that is apparently not the case, since the issues have returned and the spinning beach ball continues to churn... (nothing like the elation of finding a solution only to later feel crushing defeat as the problem returns...)

            ;-) 

             

            The issues were resolved for a while, so perhaps this post may still be able help someone.  I'd rather be working in CS6 right now, and I'm pushing for this client to do the upgrade as well.  Considering how much time is being wasted waiting for the Mac to continue after hanging every other keystroke, I'd think the client would be anxious to make the change!