1 Reply Latest reply on Apr 24, 2013 11:28 AM by Brett N

    can CS5.1 run on Mac OX10.7.5?

    lonrun

      I have to upgrade from OSX10.6.8 to install other software. I need to make sure my CS5.1 will still work.