4 Replies Latest reply on May 20, 2013 4:26 AM by AlkaParveen

    SearchIndex configuration in workspace.xml without effect?

    hrietz Level 1

      Hi everybody,

      I have been experimenting with different params for the SearchIndex section of the workspace.xml (CQ 5.5 SP2). The following documented settings do not seem to have any effect on the indexing process (on CentOS):

       

              <param name="forkJavaCommand" value="nice java -Xmx32m"/>
              <param name="extractorPoolSize" value="4"/>

       

      I have also tried to set an extractorPoolSize of "0" to achieve synchronous text extraction and indexing - no effect.

      We have also tried to set

      <param name="indexingConfiguration" value="${wsp.home}/indexing_config.xml"/>

      The settings in our indexing_config.xml where also ignored completely.

       

      What am I missing? Wrong parameters? Wrong configuration file?

       

      Thanks for any help.

      Henning

        • 1. Re: SearchIndex configuration in workspace.xml without effect?
          Sham HC Level 7

          Hi Henning,

           

          After configuring indexingConfiguration, have you rebuild the index?  How are you verfying the property is picked or not?

           

          Thanks,

          Sham

          @adobe_sham

          • 2. Re: SearchIndex configuration in workspace.xml without effect?
            hrietz Level 1

            Hi Sham,

            actually, I have not rebuilt the index. I did not see any reason, for the properties did not have anything to do with the structure of the index. But I have wondered if this could be needed... so I'll try that.

            I can see that the "extractorPoolSize" of zero is not working, because I still have the concurrent threads doing the indexing after the creating of content is long finished. An the forkJavaCommand was without effect in so far as no Java processes were created at all. The behaviour of CQ5 for of our test case (migration of some hundred PDF documents) never changed - no matter what I put in the SearchIndex section. Maybe if we recreate the index...

            Thanks for pointing this out.

             

            Henning

            • 3. Re: SearchIndex configuration in workspace.xml without effect?
              Sham HC Level 7

              Hi Henning,

               

              Property will defenetly get effective.  Might be the threads you might be seeing is tar indexing one.

              I do not see anything wrong in parameters. Please update with exact issues.

               

              Thanks,

              Sham

              @adobe_sham

              1 person found this helpful
              • 4. Re: SearchIndex configuration in workspace.xml without effect?
                AlkaParveen

                Hi,

                 

                I am also trying to restrict searches in DAM assets using index_config file but CQ doesnt seem to pick up the changes done in file.

                 

                I have added this in workspace.xml and respository.xml

                 

                <param name="indexingConfiguration" value="${wsp.home}/indexing_config.xml"/>

                 

                PFB my index config.xml file:

                <?xml version="1.0"?>

                          <!DOCTYPE configuration SYSTEM "http://jackrabbit.apache.org/dtd/indexing-configuration-1.2.dtd">

                          <configuration

                          xmlns:cq="http://www.day.com/jcr/cq/1.0"

                          xmlns:dam="http://www.day.com/dam/1.0"

                          xmlns:nt="http://www.jcp.org/jcr/nt/1.0"

                          xmlns:jcr="http://www.jcp.org/jcr/1.0"

                          xmlns:sling="http://sling.apache.org/jcr/sling/1.0">

                 

                          <!-- Do not index content of subassets -->

                          <index-rule nodeType="nt:resource"

                          condition="ancestor::subassets/@jcr:primaryType='{http://www.jcp.org/jcr/nt/1.0}unstructured'">

                          </index-rule>

                 

                          <!--

                          Exclude some well known properties from the node scope

                          fulltext index. Do not add rules below this one, since

                          this rule matches any node and acts as a default/fallback.

                          -->

                          <index-rule nodeType="nt:base">

                          <property nodeScopeIndex="false">analyticsProvider</property>

                          <property nodeScopeIndex="false">analyticsSnippet</property>

                          <property nodeScopeIndex="false">hideInNav</property>

                          <property nodeScopeIndex="false">offTime</property>

                          <property nodeScopeIndex="false">onTime</property>

                          <property nodeScopeIndex="false">cq:allowedTemplates</property>

                          <property nodeScopeIndex="false">cq:childrenOrder</property>

                          <property nodeScopeIndex="false">cq:cugEnabled</property>

                          <property nodeScopeIndex="false">cq:cugPrincipals</property>

                          <property nodeScopeIndex="false">cq:cugRealm</property>

                          <property nodeScopeIndex="false">cq:designPath</property>

                          <property nodeScopeIndex="false">cq:isCancelledForChildren</property>

                          <property nodeScopeIndex="false">cq:isDeep</property>

                          <property nodeScopeIndex="false">cq:lastModified</property>

                          <property nodeScopeIndex="false">cq:lastModifiedBy</property>

                          <property nodeScopeIndex="false">cq:lastPublished</property>

                          <property nodeScopeIndex="false">cq:lastPublishedBy</property>

                          <property nodeScopeIndex="false">cq:lastReplicated</property>

                          <property nodeScopeIndex="false">cq:lastReplicatedBy</property>

                          <property nodeScopeIndex="false">cq:lastReplicationAction</property>

                          <property nodeScopeIndex="false">cq:lastReplicationStatus</property>

                          <property nodeScopeIndex="false">cq:lastRolledout</property>

                          <property nodeScopeIndex="false">cq:lastRolledoutBy</property>

                          <property nodeScopeIndex="false">cq:name</property>

                          <property nodeScopeIndex="false">cq:parentPath</property>

                          <property nodeScopeIndex="false">cq:segments</property>

                          <property nodeScopeIndex="false">cq:siblingOrder</property>

                          <property nodeScopeIndex="false">cq:template</property>

                          <property nodeScopeIndex="false">cq:trigger</property>

                          <property nodeScopeIndex="false">cq:versionComment</property>

                          <property nodeScopeIndex="false">jcr:createdBy</property>

                          <property nodeScopeIndex="false">jcr:lastModifiedBy</property>

                          <property nodeScopeIndex="false">sling:alias</property>

                          <property nodeScopeIndex="false">sling:resourceType</property>

                          <property nodeScopeIndex="false">sling:vanityPath</property>

                          <property nodeScopeIndex="false">sling:OrderedFolder</property>

                          <property isRegexp="true">.*:.*</property>

                          </index-rule>

                 

                          <!-- Cq Page for jcr:contains(jcr:content, "...") searches -->

                          <aggregate primaryType="cq:PageContent">

                          <include>*</include>

                          <include>*/*</include>

                          <include>*/*/*</include>

                          <include>*/*/*/*</include>

                          </aggregate>

                 

                          <aggregate primaryType="dam:Asset">

                          </aggregate>

                 

                          <!-- nt:file child axis orderby index -->

                          <aggregate primaryType="nt:file">

                          <include>jcr:content</include>

                          <include>jcr:content/jcr:lastModified</include>

                          </aggregate>

                 

                          <!-- cq:Page child axis orderby index -->

                          <aggregate primaryType="cq:Page">

                          <include>jcr:content</include>

                          <include>jcr:content/cq:lastModified</include>

                          </aggregate>

                 

                          </configuration>

                 

                 

                Problem is that when I try to search PDF it returns the subnodes as well (/pdf/property-map.pdf/jcr:content/renditions/original). I want to restrict this behavior. It should only show the acual pdf file not the renditions and parent folder.

                I have removed the index folders and restarted CQ after it, still no change.

                Please let me know if i am doing anything wrong here.

                 

                Regards,

                Alka