1 Reply Latest reply on Apr 25, 2013 6:54 PM by Rick Gerard

    Can you upgrade After affects 5.5 to cs5?

    OmenSpirits

      As the title states.