14 Replies Latest reply on Nov 2, 2007 3:54 AM by joerg.z

    No WYSIWYG editor

    joerg.z
      Hi,

      I have installed RoboHelp (HTML) successfully. But I am missing the WYSIWYG editor. When I try to open a *.htm file e.g. with the context sensitive menu (it provides the WYSIWYG editor) then the file opens in the TrueCode editor.

      I am using RoboHelp HTML X5.0.1 Build 606 on Windows XP Professional.

        • 1. Re: No WYSIWYG editor
          RoboColum(n) Level 5
          Hi joerg.z and welcome to the RH community. You need to go to your options (Tools > Options menu item) and click on the HTML Editor tab. There you should find that the "RoboHelp Truecode" is the default editor. Change this to the RoboHelp WYSIWYG.
          • 2. Re: No WYSIWYG editor
            joerg.z Level 1
            Thank you for the quick reply.

            I´m sorry, but the RoboHelp WYSIWYG editor is the default editor.
            • 3. Re: No WYSIWYG editor
              Peter Grainge Adobe Community Professional (Moderator)
              Look in Topic Properties. What is set there?

              • 4. Re: No WYSIWYG editor
                joerg.z Level 1
                General Tab, Attribute "Editor" = RoboHelp WYSIWYG
                • 5. Re: No WYSIWYG editor
                  Peter Grainge Adobe Community Professional (Moderator)
                  You started by saying "I have installed RoboHelp (HTML) successfully." I am beginning to question that!

                  What happens if you double click a topic in Project Manager or the Topic List?

                  Are all your attempts with one project? If yes, open one of the supplied projects and see what happens there.

                  Is the project you refer to a new one or one created in an earlier version? Have you got other projects you created?

                  Is there a tab for the WYSIWYG editor?

                  • 6. Re: No WYSIWYG editor
                    Peter Grainge Adobe Community Professional (Moderator)
                    Hang on! Looks like you have not installed the patch. You should be on 5.0.2.

                    • 7. Re: No WYSIWYG editor
                      joerg.z Level 1
                      quote:

                      Originally posted by: Peter Grainge
                      You started by saying "I have installed RoboHelp (HTML) successfully." I am beginning to question that!
                      => I do so too. Well, the install application said so ;-)

                      What happens if you double click a topic in Project Manager or the Topic List?
                      => TrueCode editor opens

                      Are all your attempts with one project? If yes, open one of the supplied projects and see what happens there.
                      => I tried the cuisine example too

                      Is the project you refer to a new one or one created in an earlier version? Have you got other projects you created?
                      => Created with the same version

                      Is there a tab for the WYSIWYG editor?
                      => no there isn´t




                      I tried on another computer where RoboHelp 5.0.1 is installed too. Everything is allright there. So I´m afraid that version 5.0.2 isn´t the solution.

                      Then I tried a second install on my computer. But it don´t work.
                      • 8. Re: No WYSIWYG editor
                        Peter Grainge Adobe Community Professional (Moderator)
                        If you don't have the tab, then something is definitely wrong with your installation. It is not something that I can recall having been posted before.

                        Is RH being installed with your logon and with admin rights attached?

                        Is the project on your local drive?

                        Via my website, email me a screenshot of RoboHelp.

                        • 9. Re: No WYSIWYG editor
                          joerg.z Level 1
                          quote:

                          Originally posted by: Peter Grainge
                          If you don't have the tab, then something is definitely wrong with your installation. It is not something that I can recall having been posted before.

                          Is RH being installed with your logon and with admin rights attached?
                          => I´ve installed RH with "run as .." admin while i was logged on with my normal (not admin) user.
                          => I start RH with as not admin user

                          Is the project on your local drive?
                          => yes

                          Via my website, email me a screenshot of RoboHelp.
                          => must be there now



                          • 10. Re: No WYSIWYG editor
                            Peter Grainge Adobe Community Professional (Moderator)
                            I asked about installing rather than using with admin rights. Get you IT people to give you admin rights just to see if that makes a difference. I'll look at the screenshot shortly.

                            • 11. Re: No WYSIWYG editor
                              joerg.z Level 1
                              Now I´ve installed RH beeing logged in with admin rights.
                              Unfortunately I can´t see any differences.
                              There are two other points found out.
                              The first one is the"component 4 not found" message (I send you per mail)
                              The second one ist that I can´t open RH with my admin user. => In the TaskManager I can see RoboHTML.exe in process tab but in hangs there until I kill it.
                              • 12. Re: No WYSIWYG editor
                                Peter Grainge Adobe Community Professional (Moderator)
                                Component 4 is a message that is normally found when people attempt to install other than RH7 on Vista.

                                Earlier versions are not compatible. There are some threads on the forum about attempts to fix it.

                                • 13. Re: No WYSIWYG editor
                                  joerg.z Level 1
                                  my biggest problem seems to be:
                                  when my user has admin rights or I use the admin user to open RH, RH did not start. (see previous task)
                                  • 14. Re: No WYSIWYG editor
                                    joerg.z Level 1
                                    Whats about the Windows Service Pack? We use SP2.
                                    What about Word? We use Word 2002, which is not listed in the install program, so we choose Word XP. I can not choose 2000 or 2003 because RH brings ab a message box "not installed".