2 Replies Latest reply on Jul 10, 2013 11:13 AM by CQHondo

    Override IIS default 404 erorr page with CQ 404.jsp

    deepbluez Level 1

      Hi guys,

       

      Anyone is using IIS server?

       

      I have got the 404.jsp and placed it under /apps/sling/serlvet/errorhandler.

       

      All works well until the page is deployed into production enviornment which is running on an IIS server.

       

      Now whenever CQ gets a 404 page, instead of display the customised 404 page instructed by the 404.jsp, the IIS 404 standard (ugly) page gets displayed all the time.

       

      We don't want to change the IIS configuration to be too specific to point to a single jsp page because there are other things running on the IIS server. Any suggestions on making IIS pass on the 404 error and let the application handle it?

       

      many thanks.

        • 1. Re: Override IIS default 404 erorr page with CQ 404.jsp
          CQHondo

          Was a solution to this problem ever found?  We are also experiencing this same issue with CQ5.5 and IIS7.  We followed the instructions for setting up IIS and the dispatcher from the release-notes.txt file found in the dispatcher installation package.  We were advised not to follow the instructions found with in the Day documentation for Dispatcher.

           

          Has anyone else got a custom 404 page to work using IIS7?  And which set of instructions did you follow?

           

          Thanks.

          • 2. Re: Override IIS default 404 erorr page with CQ 404.jsp
            CQHondo Level 1

            We determined that the configuration of the IIS server was the source of our problem.

             

            In the file, web.config, the following configuration needs to exist.  This allows the IIS server pass to along custom 404 pages from CQ, rather than the IIS "custom" error pages.

             

            <configuration>

                <system.webServer>

                    <httpErrors errorMode="Detailed" />

                </system.webServer>

            </configuration>