0 Replies Latest reply on Apr 26, 2013 2:49 PM by flashkid14

    IOS app rejected due to a blank, black screen upon launch

    flashkid14

      I recently got my iPhone app rejected and the reason is below:

       

      "We found that your app exhibited one or more bugs, when reviewed on iPhone 5 running iOS 6.1.3, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.


      Specifically, the app displayed a blank, black screen upon launch. Please see the attached screenshot/s for more information.


      The steps to reproduce are:


      1. Launch app

      2. Bug encountered"

       

       

       

      I use FlashDevelop and the latest Apache Flex + Air SDK 3.7 + swfversion=20. I don't have an iPhone 5 to test on but I've tested the application on a 3GS, iPod touch (4th gen.) on IOS 4.3, 5.1 and 6.1.3 (latest) and the application works on all of them.

       

      The attached screenshot mentioned above is here:

       

      temp..pkeohrsc.png

       

      As it shows, the "blank" screen is actually a deep blue one, which the color I've set to my project's background.

       

      I didn't make any special modifications in the code to support iPhone 5 to be honest, and the project dimensions were set to 640x960, but I did include the Default-568h@2x.png, and it shows inside the .ipa at Payload/Myapp.app/

       

      In almost all the iPhone 5 discussions I've read online, theat launch problem is due to the Default-568h@2x.png not being there in the root of the release .ipa, but I'm sure it does exist on my ipa. Also, I have request high resolution set to high, and the Info.plist has the correct DTPlatformVersion (6.0) and DTSDKName (iphoneos6.0).

       

      Any ideas what the problem could be?

       

      Thanks.