1 Reply Latest reply on Apr 27, 2013 7:19 PM by pwillener

    'Plug-in blocked' can't download latest.

    geoff 69

      Flash Player v 11.4 was working fine until this evening.  Now get 'Plug-in blocked' on all videos; and am unable to download v11.7.  I am on Mac OS X 10.6.8; which is compatable according to Adobe download page.  Can anyone help?