4 Replies Latest reply on May 9, 2013 4:42 AM by Willam van Weelden

    Table Columns Disappearing in Editor

    mrbrayer

      After importing HTML files from another project, I'm having problems with the second column disappearing in tables in the editor when viewing a topic.

      If I go to the file in Windows Explorer and click on it, it comes up perfectly in IE 8, but if imported, anything to the right of the first column is missing on all tables in the file.

      Any suggestions?

        • 1. Re: Table Columns Disappearing in Editor
          Willam van Weelden Adobe Community Professional & MVP

          Hi,

           

          What is the HTML of the table? Is it correct, or does it perhaps contain a HTML syntax error?

           

          In RoboHelp, is the column simply not visible or is it missing in the HTML too?

           

          Greet,

           

          Willam

          • 2. Re: Table Columns Disappearing in Editor
            mrbrayer Level 1

            Thanks for responding so quickly. The HTML looks good through Window's Explorer, but in the Robo Editor, there is a null value in the td cells that have disappeared.

            • 3. Re: Table Columns Disappearing in Editor
              mrbrayer Level 1

              Here's some of the markup from the file in Window's Explorer and from the Robo Editor:

               

              Markup from file in IE8

              <tr valign="top" class="whs46">

              <td class=standout style="width: 14.749%; padding-left: 2px; padding-top: 2px; padding-right: 2px;

              padding-bottom: 2px; background-color: #f4f4f4; x-cell-content-align: top;"

              valign=top bgcolor=#F4F4F4 width=14.749%>

              <p class="whs48">Last Name </td>

              <td class=formtext style="width: 85.251%; padding-left: 2px; padding-top: 2px; padding-right: 2px;

              padding-bottom: 2px; background-color: #f4f4f4; x-cell-content-align: top;"

              valign=top bgcolor=#F4F4F4 width=85.251%>

              <p class=bullets>Employee's last name. </td></tr>

               

               

              Markup from file in RoboHelp7 editor

              <tr class="whs46" style="x-cell-content-align: top;" valign=top>

              <td class="standout" style="width: 14.749%; padding-left: 2px; padding-top: 2px; padding-right: 2px;

              padding-bottom: 2px; background-color: #f4f4f4; x-cell-content-align: top;"

              valign=top bgcolor=#F4F4F4 width=14.749%>

              <p class="whs48">Last Name </td>

              <td_null></tr>

              • 4. Re: Table Columns Disappearing in Editor
                Willam van Weelden Adobe Community Professional & MVP

                Mmmh,

                 

                RH9 imports it correctly. I don't have RH7 installed, so I'll have to look around to see where I left that installation...

                 

                What happens if you add the </p> (paragrahp closing tag) in the document before </td>?

                 

                Greet,

                 

                Willam